LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   installing alsa on Slackware (http://www.linuxquestions.org/questions/slackware-14/installing-alsa-on-slackware-807193/)

Goldfish777 05-11-2010 02:28 PM

installing alsa on Slackware
 
How should I go about installing alsa and making it start on boot?

sycamorex 05-11-2010 02:41 PM

Alsa is part of standard Slackware. Have you installed the full version of Slackware 13?
If you haven't, you can get the alsa packages from here:
http://www.mirrorservice.org/sites/f...0/slackware/l/
(That's for Slackware13)
After downloading it, you can install it by:
Quote:

installpkg *.txz
Any other alsa-plugins can be installed from slackbuilds
http://slackbuilds.org/repository/13.../alsa-plugins/

I suggest you look at a piece of software called sbopkg
http://www.sbopkg.org/
It'll make installing slackbuilds easier

Also, look at the following tutorial:
http://www.slackbook.org/html/packag...utilities.html

sycamorex 05-11-2010 02:48 PM

One more remark: If you haven't installed the full version of Slackware, you MIGHT be better off reinstalling it again choosing FULL install.
Slackware doesn't automatically handle dependencies like yum or apt-get, so if you just installed minimal system, it might
be a complex and daunting task to install what you want (with dependencies.)
It wouldn't be a big problem for an experienced slackware user (it'd still be rather time-consuming), but from your post
I assume you are rather new to slackware.

Just a suggestion:)

Goldfish777 05-11-2010 03:12 PM

I installed the full system except KDE. KDE is slow and bloated.

sycamorex 05-11-2010 03:17 PM

In that case alsa is installed on your system.
If you don't hear any sound, try to run alsamixer (from the command line) and see if the channels are not muted)

I don't like KDE either. Try XFCE.

Anyway, any day now (hopefully) Slackware 13.1 will be released with a much better version of KDE.

Goldfish777 05-11-2010 03:19 PM

Quick question: before I install should download and install alsa-lib or alsa-oss or both?

dugan 05-11-2010 03:23 PM

Quote:

Originally Posted by Goldfish777 (Post 3964839)
I installed the full system except KDE.

EDIT:

As has been pointed out, ALSA should be installed in this case. Do you know how to check?

The following line will tell you if the packages have been installed:
Code:

ls /var/log/packages | grep alsa
Please tell us why you think you still need to install ALSA.

dive 05-11-2010 03:25 PM

You need these packages:

alsa-lib-1.0.18-i486-2
alsa-utils-1.0.18-i486-1
alsa-oss-1.0.17-i486-1

When they are installed run alsaconf as root so it detects your soundcard, then run alsamixer to set your mutes and volumes etc. When you have sound working use 'alsactl store'

kingbeowulf 05-11-2010 03:39 PM

If you did a full install (/ap and /l series), did you run alsaconf during installation (it should come up automatically)? If not, run alsaconf as root. In the rough order, after logging on as root:
1. "lspci" find your audio or multimedia chip and check for compatibility at http://www.alsa-project.org
2. "lsmod" to see if the sound modules are loading
3. "alsaconf" to configure you sound hardware
4. "alsamixer" to make sure your channels are not muted
5. "alsactl -store" to store the mixer settings.

Note "alsaconf" should take care of #4 and #5.

To test the card go here: http://alsa.opensrc.org/index.php/Speaker-test

Goldfish777 05-11-2010 04:56 PM

Quote:

Originally Posted by dugan (Post 3964856)
EDIT:

As has been pointed out, ALSA should be installed in this case. Do you know how to check?

The following line will tell you if the packages have been installed:
Code:

ls /var/log/packages | grep alsa
Please tell us why you think you still need to install ALSA.

Well I put in the command and it seems I do have alsa. I will do the alsaconf and stuff to see f I can't get it running.

Goldfish777 05-11-2010 05:22 PM

I know it is installed and I ran alsaconf and set it up and I went into the alsamixer. Does the "00" mean muted or the "MM" mean muted? Basicall I am not getting any sound whatsoever.

dive 05-11-2010 05:35 PM

Green 00 means unmuted.

sycamorex 05-11-2010 05:51 PM

Another thought: I don't know if it's applicable here, but have you added your user to the audio group?

Goldfish777 05-11-2010 07:05 PM

I did not add my user and I dont know if it is already added. How do I tell?

dugan 05-11-2010 07:07 PM

Code:

groups
The output lists the groups that you belong to.


All times are GMT -5. The time now is 07:30 PM.