LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-18-2010, 03:37 AM   #121
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,385

Rep: Reputation: 186Reputation: 186

I X going using nvidia driver by recompiling kernel, however got something else strange happening too. I got X going by recompiling 2.6.7.35 kernel with config file used for 2.6.33.4 kernel using my own custom version so as to not bork the standard /lib/modules/2.6.35.7 directory. Using my custom kernel everything seems to work great at the moment. However now when I boot with the generic-2.6.35.7 kernel and try to run
Quote:
#sh NVIDIA-Linux-x86_64-260.19.21.run
I get a can't install error, Unable to load the kernel module 'nvidia.ko'. However if I do "lsmod" no nvidia display driver of any sort is displayed.
Earlier while trying to get X to work, had somehow got nvidiafb driver loading on bootup and it would not show up with "lsmod", and the only way I could get
Quote:
modprobe -r nvidiafb
to remove it was to recompile the 2.6.35.7 kernel. However when I recompiled that kernel I didn't use a custom version or an older config file. couldn't get X to work with this kernel either. Don't know if it makes any difference, but I don't use initrd to boot when I compile my own kernel. LOL It's late, I feel like I'm writing a book here that nobody will make sense of, but maybe somebody can make sense of this

Last edited by colorpurple21859; 11-18-2010 at 03:44 AM.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-18-2010, 04:14 AM   #122
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 308
Blog Entries: 2

Rep: Reputation: 84
Just installed the latest update 15minutes ago, at first KDE would segfault just before the "K" logo appears on the splash screen.

However xfce and other desktops loaded as normal, to fix it (if your using the NVIDIA binarys). You simply reboot into run-level 3 or end all x sessions...

Code:
# nvidia-uninstall
and then reinstall it; depending on where you saved it to
Code:
# ./NVIDIA-Linux-x86_64-260.19.21.run
if needed regenerate an xorg.conf with
Code:
# nvidia-xconfig
and KDE should be working again.
Smooth update.
 
Old 11-18-2010, 04:36 AM   #123
Barx
Member
 
Registered: Jun 2004
Distribution: Slack x86 current
Posts: 128

Rep: Reputation: 16
Quote:
Originally Posted by coralfang View Post
Now i have another problem with anything gtk2 related:
Code:
/usr/lib64/firefox-3.6.12/firefox-bin: symbol lookup error: /usr/lib64/libgio-2.0.so.0: undefined symbol: g_variant_unref
Whats happened now o.o
I've got the same problem with thunderbird. Solved running ldconfig as root (without rebooting). Thunderbird and Firefox works good after that
 
Old 11-18-2010, 06:20 AM   #124
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,517

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Just a thought for people who have done upgrades and are having problems with X and KDE in particular. It may pay to look in /usr/lib/modules/extensions/ (/usr/lib64/modules/extensions/ in 64bit) to see if you have any old libraries hanging around.
I just amazed myself with the amount of clutter I had accumulated from previous driver installations.
I think anything older than Nov 17 05:25 can be safely deleted.
 
Old 11-18-2010, 07:05 AM   #125
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,646

Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
KDE crashing at startup vs Mesa 7.9

Quote:
Originally Posted by Slackware-current's Changelog
If X crashes at start, try disabling compositing. Create a file named
/etc/X11/xorg.conf.d/disable-composite.conf with this in it:
Section "Extensions"
Option "Composite" "Disable"
EndSection
This works here, so I will keep Mesa 7.9.

I have a nVidia Corporation Quadro NVS 140M (rev a1) and don't use the blob.

Well, as I use some KDE apps but never the KDE desktop I'm not even sure I will disable compositing at time of upgrading to 13.2 - even if this issue is not solved by then

@allend: no clutter accumulated here but a fresh install of slackware-current.

Last edited by Didier Spaier; 11-18-2010 at 07:13 AM.
 
Old 11-18-2010, 09:27 AM   #126
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.18.0) UEFI enabled
Posts: 360

Rep: Reputation: 77
No compositing

Didier The fix in the changelog works here also on a nvidia 6150LE onboard chipset

I can live without 'special effects' for now

thanks
john
 
Old 11-18-2010, 10:21 AM   #127
akiku
Member
 
Registered: Jun 2009
Distribution: Slackware
Posts: 62

Rep: Reputation: 17
Quote:
Originally Posted by BobNutfield View Post
Well, there a number of updates again tonight, many of which looked like the same as the previous update. I had hoped this was going to be a fix, but no such luck. X still seg faults. I haven't found anything in this thread that works. Guess I won't be using Slack for a while. I will see if any future updates fixes the problem before I consider my two yearl old heavily configured installation totally hosed. I have put way too much time into it to not at least try to fix it.

I noticed that the last line states that:



I thought that kind of error could be fixed, but maybe not.

Bob
Not sure what driver X is trying to use for your card, but I have an IGP340M that requires the radeon driver, and none of the recommended fixes work. X does work with the VESA drivers, though.
You may want to try that.

Regarding the last line in your log, I think that just means that the server died while xinit was still running, so no server to connect to.
 
Old 11-18-2010, 05:15 PM   #128
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Quote:
Originally Posted by akiku View Post
Not sure what driver X is trying to use for your card, but I have an IGP340M that requires the radeon driver, and none of the recommended fixes work. X does work with the VESA drivers, though.
You may want to try that.

Regarding the last line in your log, I think that just means that the server died while xinit was still running, so no server to connect to.
Thanks for your reply. I have been using an xorg.conf file for a long time and it has always worked perfectly. The driver is the open source "radeon" driver. I have tried everything I could from this thread and nothing has made any difference. I have put too much time into geting Slack the way wanted for over two years. I won't reinstall and will continue to try to find an answer. Disappointed, but hopefully some future updates will fix it. The rest of the system, including wireless, seems to work fine.

Anyone have any ideas of what else I can try I would really like to fix this if I can.

Thanks

Bob
 
Old 11-18-2010, 06:59 PM   #129
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,273

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
Completed my second -current upgrade today. All is well. Many thanks to Robby and the entire Slackware team.
 
Old 11-18-2010, 08:21 PM   #130
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Rep: Reputation: 39
Just updated last night, so far everything works. Though in my minimal test setup some library needs to be added to start X.

In my main Slack, everything just works. Although I have noticed some minor differences on the fonts. I'll have to tweak it further.
 
Old 11-18-2010, 08:50 PM   #131
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,385

Rep: Reputation: 186Reputation: 186
to Bobnutfield, try recompiling kernel. Also couldn't get X to work and tried a lot of different things as mention in my earlier post. reconfiguring the kernel seems to fixed eveything. I first got X to work by just compiling the only the drivers I needed for my hardware, but still couldn't get the vmlinuz-generic-2.6.35.7 kernel to work. I just got done recompiling the generic kernel with the /boot/config-generic-2.6.35.7 file, didn't make any changes to it before compiling and X is working including kde. I know you don't have the same video card, as mine is a Nvidia gefore 6150se nforce430, but recompiling the kernel might work.
 
Old 11-18-2010, 08:53 PM   #132
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Everything is working for me (granted I did a clean install), but now my /dev/cdrom symlink to /dev/sr0 is not being created anymore.
 
Old 11-19-2010, 12:57 AM   #133
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,385

Rep: Reputation: 181Reputation: 181
I just finished round two of this massive update. This time, I finished without incident. The last thing I did was to upgrade the kernel and make a new initrd. I had been running 2.6.35.4. I usually build a custom kernel, but I've since given in to using the generic. Seems to work well!
 
Old 11-19-2010, 04:56 AM   #134
GazL
Senior Member
 
Registered: May 2008
Posts: 3,502

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Did a completely clean install from a dvd-burn of yesterdays 64 current tree. I have the same issue as rmjohnso with regard to /dev/cdrom, /dev/dvd symlinks not being there, but I've fallen in to the habit of just using /dev/sr0 ever since the libata change, so I didn't actually notice until (s)he posted and I checked.
 
1 members found this post helpful.
Old 11-19-2010, 07:46 AM   #135
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,385

Rep: Reputation: 181Reputation: 181
My symlinks are still there, but I did not do a clean install. They point to sr0 and sr1. One thing I noticed - KDE starts way quicker now than before. Booting period seems to be faster. I may be off on that though, since I don't reboot that often.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest current problems brodo Slackware 17 03-03-2010 11:14 AM
Latest current ? brodo Slackware 34 03-13-2009 04:15 PM
Latest nmap (4.50) in current and its gui jazzor Slackware 30 05-16-2008 01:22 PM
Race condition in /etc/rc.d/ with latest -current ? Yalla-One Slackware 1 08-06-2006 03:23 PM
warning about latest current aaa_elflibs-10.1.0 xushi Slackware 2 01-25-2005 08:57 AM


All times are GMT -5. The time now is 08:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration