LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-14-2010, 11:28 PM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Rep: Reputation: 176Reputation: 176
Installed The Latest Changes to Current and......


Ugh!
X crashes and reports a segmentation fault, address nil.
I've been using the generic Radeon driver without any problems, until now. Looks like it will be winblows until I figure out the problem.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-15-2010, 12:43 AM   #2
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
After upgraded the X crashed too.
It complained that missing liblzma.so.0, so i made a link to liblzma.so.5 and it worked.

other issues of the lastest current update:

1. /dev/shm missing, revert to udev-153 fixed
2. the rc.M script section of gdk-pixbuf2 error
g_module_open() failed for /root/--update-cache: /root/--update-cache.so: cannot open shared object file: No such file or directory
3. bluetooth mouse not worked, revert former version of bluez fixed
 
3 members found this post helpful.
Old 11-15-2010, 01:21 AM   #3
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 286

Rep: Reputation: 76
Post

Quote:
Originally Posted by zhoun View Post
After upgraded the X crashed too.
It complained that missing liblzma.so.0, so i made a link to liblzma.so.5 and it worked.
fixed
Thanks, i was about to post the same thread asking how to fix.

Managed to get KDE up and running, but all gtk apps show:
Code:
error while loading shared libraries: libgdk_pixbuf-2.0.so.0: cannot open shared object file: No such file or directory
Any idea on what that needs linking to?

I tried having a look, only found a directory
Code:
$ find /usr/lib64 -name 'gdk*pixbuf*2*' 2>/dev/null
/usr/lib64/gdk-pixbuf-2.0
 
Old 11-15-2010, 01:34 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
maybe it would help to
Code:
slackpkg install-new
installing packages added to the -current tree.
 
2 members found this post helpful.
Old 11-15-2010, 01:39 AM   #5
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 286

Rep: Reputation: 76
Quote:
Originally Posted by ponce View Post
maybe it would help to
Code:
slackpkg install-new
installing packages added to the -current tree.
Ah wow, whole time i was running slackware 13.1 i never noticed an option for that.

Installed:
gdk-pixbuf2-2.22.1-x86_64-1.txz
radeon_ucode-20100902-noarch-1.txz

Thanks.
 
Old 11-15-2010, 03:57 AM   #6
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 423

Rep: Reputation: 45
Quote:
Originally Posted by zhoun View Post
After upgraded the X crashed too.
It complained that missing liblzma.so.0, so i made a link to liblzma.so.5 and it worked.

other issues of the lastest current update:

1. /dev/shm missing, revert to udev-153 fixed
2. the rc.M script section of gdk-pixbuf2 error
g_module_open() failed for /root/--update-cache: /root/--update-cache.so: cannot open shared object file: No such file or directory
3. bluetooth mouse not worked, revert former version of bluez fixed
For #1, I found a hack:
Code:
#install -dv /lib/{firmware,udev/devices/{pts,shm}}
works on my side.

For #2, do a #slackpkg install-new would be ok.

For #3, I have not test the bluetooth yet...

I also notice that the fonts are sharpener than before. Does anyone have the same kind of feeling?
 
Old 11-15-2010, 04:26 AM   #7
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,574

Rep: Reputation: 429Reputation: 429Reputation: 429Reputation: 429Reputation: 429
Quote:
Originally Posted by grissiom View Post
I also notice that the fonts are sharpener than before. Does anyone have the same kind of feeling?
Yes, i think it's getting better
 
Old 11-15-2010, 04:44 AM   #8
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 746

Rep: Reputation: 64
Synaptics scrolling

After upgrade to current I lost the scroll function of my synaptics touchpad (Thinkpad T41). To fix it:
Code:
cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/
and edit /etc/X11/xorg.conf.d/50-synaptics.conf to suit your wishes. I added
Code:
        Option "VertEdgeScroll" "on"
        Option "HorizEdgeScroll" "on"
and all is well again

And yes, nicer fonts here too
 
Old 11-15-2010, 04:48 AM   #9
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
I am using slackware64 current, the gdk-pixbuf2 script still compained after installed.
 
Old 11-15-2010, 04:59 AM   #10
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,294

Rep: Reputation: Disabled
Please check my blog post http://alien.slackbook.org/blog/huge...-to-my-laptop/ which addresses several of the issues mentioned above. Your issues are caused by incompletely upgrading to slackware-current.

Eric
 
4 members found this post helpful.
Old 11-15-2010, 05:41 AM   #11
hiptobecubic
LQ Newbie
 
Registered: Oct 2009
Distribution: Slackware
Posts: 23

Rep: Reputation: 2
Can anyone comment on the font situation with these new updates? The default GTK font changed from actual arial to Liberation Sans, using gtk-chtheme to set it back doesn't work. If arial is selected, it is autotragically (did i just invent that?) changed back to Liberation Sans.

Additionally, monospace 8 is ... different. As if it were really just monospace 9 with less space between the lines; the character sizes look the same.

Have a look:
http://imgur.com/a/YXIEi/monospace_8__before_and_after


Any ideas?
 
Old 11-15-2010, 05:55 AM   #12
kemsiro
Member
 
Registered: Sep 2007
Location: Vietnam
Distribution: Slackware
Posts: 38

Rep: Reputation: 15
Mirror in Norway error?

Is there anyone use the Norway mirror of Slackware -current? I used it to update with slackpkg but got a lot of md5 checksum failed. When I change to US mirror, there is no error.

Is that the mirror of Norway error?
 
Old 11-15-2010, 06:47 AM   #13
helo
LQ Newbie
 
Registered: May 2007
Distribution: slackware
Posts: 17

Rep: Reputation: 2
I've had to revert cryptsetup back to the 1.1.0 version as the new version (1.1.3) hangs when doing a luksOpen.

Love the fonts.
 
Old 11-15-2010, 07:07 AM   #14
55020
Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 387
Blog Entries: 4

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
Originally Posted by zhoun View Post
I am using slackware64 current, the gdk-pixbuf2 script still compained after installed.
Are you running multilib?

Apparently there's a new dependency from gtk-query-immodules (in gtk+2) to gdk-pixbuf2. You need to get gdk-pixbuf2-2.22.1-i486-1.txz and convert and install it --

Code:
convertpkg-compat32 -i gdk-pixbuf2-2.22.1-i486-1.txz -d /tmp
installpkg /tmp/gdk-pixbuf2-compat32-2.22.1-x86_64-1.txz
 
Old 11-15-2010, 07:39 AM   #15
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
thanks.

convert gtk2 and gdk-pixbuf2 to compat32 packages and upgrade them fix it.

Quote:
Originally Posted by 55020 View Post
Are you running multilib?

Apparently there's a new dependency from gtk-query-immodules (in gtk+2) to gdk-pixbuf2. You need to get gdk-pixbuf2-2.22.1-i486-1.txz and convert and install it --

Code:
convertpkg-compat32 -i gdk-pixbuf2-2.22.1-i486-1.txz -d /tmp
installpkg /tmp/gdk-pixbuf2-compat32-2.22.1-x86_64-1.txz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest current problems brodo Slackware 17 03-03-2010 10:14 AM
Latest current ? brodo Slackware 34 03-13-2009 03:15 PM
Latest nmap (4.50) in current and its gui jazzor Slackware 30 05-16-2008 12:22 PM
Race condition in /etc/rc.d/ with latest -current ? Yalla-One Slackware 1 08-06-2006 02:23 PM
warning about latest current aaa_elflibs-10.1.0 xushi Slackware 2 01-25-2005 07:57 AM


All times are GMT -5. The time now is 10:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration