LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-30-2002, 05:18 PM   #1
Ice Dragon
Member
 
Registered: Aug 2002
Distribution: Fedora Core 3
Posts: 31

Rep: Reputation: 15
Installed Slackware, but no KDE?


Ok, so I installed slackware today (not so bad), but now all I have is the command prompt =-/. I thought it would have sent me to a screen similar to the screen when you boot up RedHat and then I could have chosen which win manager to use, but ti didn't =-/.

I'm not sure what to do. Maybe it is because I use LILO to boot up? (wasn't sure if I should have setup LILO or not, didn't know if I could boot up without it). Can you please help me? I am new to linux so I don't know my why around it much yet.
 
Old 08-30-2002, 06:34 PM   #2
wickdgin
Member
 
Registered: Apr 2002
Distribution: Gentoo, Slackware
Posts: 63

Rep: Reputation: 15
Slackware starts up by defualt in multi-user mode (runlevel 3). This is why you are presented with a console.

You can start up x-windows with the command `startx` from the console, or change your runlevel to level 4 - which will start x at boot up.

I prefer to start up in console mode, especially if anything happened to x-windows. But you can change your defualt runlevel in /etc/inittab. You can do so by doing the following:

login or su to root
pico /etc/inittab

look for a line that looks like 'id:3:initdefault:', you should see a comment line above it that says Default runlevel or something... anyway change the 3 to a 4 so that it looks like 'id:3:initdefault:' - press ctrl-X to exit, y to save and now your system will boot up into x.

Last edited by wickdgin; 08-30-2002 at 06:35 PM.
 
Old 08-30-2002, 06:44 PM   #3
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
During the Slack you should have been prompt to setup a default Window manager. The first choice is KDE I think. That setting is what the system will run when the X system is configured. Which is your next step usually. You can attempt to use the "startx" command to see if you get anything graphical to be displayed or just error messages. I usually get latter! Without knowing any of your hardware, I would think I can suggest two ways to configure. 1st) Try standard VESA mode. 2nd) See if X will configure itself.

The 1st method, try the following after logging as root:

cd /etc/X11
mv XF86Config XF86Config.orig
mv XF86Config-vesa XF86Config
startx

The second method, also as root:

/usr/X11R6/bin/xf86cfg

If you get a graphical screen and the mouse works OK, etc. Then save the config by using the buttons indicated. I haven't used it for awhile so I can't remember the details. But I have had success with the program where other methods have failed.

Welcome to the Slack world!
 
Old 08-31-2002, 09:05 PM   #4
Ice Dragon
Member
 
Registered: Aug 2002
Distribution: Fedora Core 3
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks! It worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker Suse/Novell 1 02-13-2005 08:01 PM
checking for KDE... configure: error:, no KDE headers installed mythief Mandriva 4 10-23-2004 08:20 AM
checking for KDE... configure: error:, no KDE headers installed mythief Linux - Software 2 10-23-2004 05:20 AM
just installed slackware 10 and no kde aelthric Linux - Newbie 6 08-17-2004 02:33 AM
i just installed kde 3.2.3 on slackware 9.1 and.... artistik Linux - Software 2 06-17-2004 07:20 AM


All times are GMT -5. The time now is 09:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration