LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Installed slack 14, updated kernel to 3.2.45, setup lilo.conf, reboot->kernel panics (http://www.linuxquestions.org/questions/slackware-14/installed-slack-14-updated-kernel-to-3-2-45-setup-lilo-conf-reboot-kernel-panics-4175477649/)

slacker_ 09-18-2013 03:45 PM

Installed slack 14, updated kernel to 3.2.45, setup lilo.conf, reboot->kernel panics
 
I installed slackware 14, ran slackpkg update, slackpkg upgrade-all, slackpkg install-new, wound up with kernel version 3.2.45 so I configured lilo.conf accordingly and ran /sbin/lilo to update everything. After rebooting I get a kernel panic. I didn't think much of it, figured I messed up configuration so I booted the slack install cd and mounted/chrooted into my fs to fix it but I still get a kernel panic, latest one is as follows:
Code:

[0.926103] No filesystem could mount root, tried:  romfs
[0.9262222] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)
[0.926356] Pid: 1, comm: swapper Not tainted 3.2.45 #1
[0.926433] Call Trace:
[0.926515]  [<c143cb341>] ? printk+0x1s/0x1f
[0.926593]  [<c143b248>] panic+0x5c/0x138
[0.926673]  [<c15f1b51>] mount_block_root+0x21e/0x23e
[0.926753]  [<c1002931>] ? do_notify_resume+0x31/0x70
[0.926832]  [<c10fa13c>] ? sys_mknod+0x2c/0x30
[0.926910]  [<c15f1754>] ? start_kernel+0x31e/0x31e
[0.926989]  [<c15f1d3a>] mount_root+0xa1/0xa7
[0.927082]  [<c15fe8e>] prepare_namespace+0x14e/0x192
[0.927164]  [<c10eb65>] ? sys_access+0x25/0x30
[0.927242]  [<c15f187a>] kernel_init+0x126/0x12b
[0.927320]  [<c1443206>] kernel_thread_helper+0x6/0x10

I had to reconfigure lilo via live cd from this point on, and when I run /sbin/lilo from live cd (chrooted into my filesystem) it returns:
Code:

Warning: '/proc/partitions' does not exist, disk scan bypassed
Warning: Unable to determine video adapter in use in the present system.
Warning: Video adapter does not support VESA BIOS extensions needed for display of 256 colors. Boot loader will fall back to TEXT only operation.
Added Linux *
4 warnings were issued.

I'm totally new to kernel work and the lilo boot loader. Can any of you slackers help me out?

gegechris99 09-18-2013 04:08 PM

Hello,

Are you running the huge or generic kernel?

If you're running the generic kernel, you should not forget to run mkinitrd to update your /boot/initrd.gz file before running /sbin/lilo.

For detailed instructions about how to use mkinitrd, please refer to README.initrd

Alien Bob 09-18-2013 04:11 PM

You may have installed the generic kernel as part of the update. If that is so, you probably have forgotten to create an initial ramdisk and then add a line for that initrd to /etc/lilo.conf.
The generic kernel requires an initrd, the huge kernel (which gets installed by default) does not need one.

Eric

Edit: gegechris99 was faster.

slacker_ 09-18-2013 05:23 PM

Is there any benefit between the huge kernel and the generic kernel?

Richard Cranium 09-18-2013 08:36 PM

Quote:

Originally Posted by slacker_ (Post 5030293)
Is there any benefit between the huge kernel and the generic kernel?

  1. Bug reports for those using the huge kernel are handled at a lower priority than those using the generic one.
  2. The machine will probably boot faster, since you aren't forcing a lot of unnecessary probes at boot time.
  3. The generic kernel will probably use less memory than the huge one.

If you use the /usr/share/mkinitrd/mkinitrd_command_generator.sh script to create your initrd, it's not much of a hassle.

slacker_ 09-20-2013 11:58 AM

Have been quite busy the last few days, finally got time to get in there and create the initrd, the command I used was as follows:
Code:

mkinitrd -c -k 3.2.45 -m ext3 -f ext3 -r /dev/sda1
I don't get a kernel panic any longer, however, after it loads the modules for ext3 I get this:
Code:

[    2.511316] EXT-3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
mount: mounting /dev/sda1 on /mnt failed: Invalid argument
ERROR:  No /sbin/init found on rootdev (or not mounted). Trouble ahead. You can try to fix it. Type 'exit' when things are done.

/bin/sh: can't access tty; job control turned off
/#

Then it just drops me to a bash shell, as noted by that last line. Not sure what to do here. I have "/sbin/init" on my root device, but as noted earlier it wouldn't mount because of "unsupported optional features." What does this usually mean? Did I generate the initrd wrong?

Edit: Wait... I think I loaded the wrong fs module... My fs is ext4 and I am ashamed. Apparently though, when I go into reload the initrd with the proper module, now it's saying
Code:

Error: No /lib/modules/3.2.45 kernel modules tree found for kernel "3.2.45"
This confuses me because it completely before without fault for the ext3. But it is correct, there is no longer a directory for 3.2.45 modules. Do I need to reload something else that I'm unaware of?

Didier Spaier 09-20-2013 12:42 PM

Quote:

Originally Posted by slacker_ (Post 5031494)
This confuses me because it completely before without fault for the ext3. But it is correct, there is no longer a directory for 3.2.45 modules. Do I need to reload something else that I'm unaware of?

If you did a slackpkg upgrade-all that should have installed package kernel-modules 3.2.45, that you obviously need. Is there any reason you unchecked that when asked?

Anyhow do this:
Code:

slackpkg upgrade kernel-source.
And you need to have only one mirror (for slackware-14.0) uncommented in /etc/slackpkg/mirrors.

slacker_ 09-20-2013 12:51 PM

Quote:

Originally Posted by Didier Spaier (Post 5031518)
If you did a slackpkg upgrade-all that should have installed package kernel-modules 3.2.45, that you obviously need. Is there any reason you unchecked that when asked?

Anyhow do this:
Code:

slackpkg upgrade kernel-source.
And you need to have only one mirror (for slaklware-14.0) uncommented in /etc/slackpkg/mirrors.

I did that slackpkg upgrade all a while ago to get the latest (for slack14) kernel packages. That was ages ago and I didn't uncheck anything.

Figured it out just now though: Because my laptop was unable to boot the kernel properly due to a missing initrd in the first place, I had to run from live cd, but when I went in to fix the mixup with ext3 and ext4 I mounted my root partition, but forgot the "chroot /dev/sda1" step. Did that, ran the commands, everything went off with out a hitch. Thanks for your time! Now to get onto testing that pesky wifi diver issue... (if you're interested in helping with that, I have a thread started elsewhere here, just look through my threads).

Bertman123 09-22-2013 03:04 PM

I tried installing the generic kernel, and ultimately succeeded (kind of), but found that I couldn't get my broadcom wireless card to be recognized. At that point I found it best to keep with the huge kernel. If it takes a little longer to boot that's fine with me.

slacker_ 09-22-2013 03:16 PM

Quote:

Originally Posted by Bertman123 (Post 5032646)
I tried installing the generic kernel, and ultimately succeeded (kind of), but found that I couldn't get my broadcom wireless card to be recognized. At that point I found it best to keep with the huge kernel. If it takes a little longer to boot that's fine with me.

What chipset do you have?


All times are GMT -5. The time now is 02:58 AM.