LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2009, 08:45 AM   #1
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,060

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Installed Minimal Slack incl. dhcp/dhcpd but what to install to connect?


OK, several questions.
Installed Slack-12.2, DSL and TTYLinux to a VHD 1GB and can't update slackpkg's 'cause it says turn off CHECKGPG, which I did, and something
about installing gnugpg or something?
So, how to fix this?
And how to fix internet, as I have always on broadband and dhcp is usually what I use?

Other strange things, after installing I used Grub and to boot Slack and others successfully here's what I had to do to make the menu.lst-

Code:
title MyDSL-4.4.10
kernel /boot/linux24 root=/dev/hda3 etc-etc
initrd /boot/minirt24.gz

title PortaSlack-12.2
kernel (hd0,1)/boot/vmlinuz root=/dev/hda1

title TTYLinux-8.0.1
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2
I have slack on hda1, tty on hda2, and dsl on hda3.
If I tell slack "kernel (hd0,0)/boot/vmlinuz root=/dev/hda1"
It says "no setup image found" and won't boot??
If I use (hd0,1), which should be hda2(ttylinux), it boots into slack
and says "darkstar login:"

What's going on here?
Any help appreciated..
PortaSlack install is most of a, and others, comes up to 283MB
Installed-so how to get internet working and issues with
menu.lst
Thanks!
 
Old 05-31-2009, 04:40 AM   #2
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
The first thing that strikes me is that we do not have anywhere near enough information to proceed with either of these. The second is that they would be better separated into two threads.

1) Portaslack/minimal slack
Quote:
PortaSlack install is most of a, and others, comes up to 283MB
we would have to know what packages are installed in able to find the ones that were missing.

2) Try putting the root on a separate line for example
Quote:
title Slackware
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal
initrd /boot/initrd.gz
also you will need an initrd.gz if you are using the generic kernel.

samac
 
Old 05-31-2009, 04:49 AM   #3
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,279

Rep: Reputation: 61
Quote:
Originally Posted by linus72 View Post
OK, several questions.
Installed Slack-12.2, DSL and TTYLinux to a VHD 1GB and can't update slackpkg's 'cause it says turn off CHECKGPG, which I did, and something
about installing gnugpg or something?
So, how to fix this?
And how to fix internet, as I have always on broadband and dhcp is usually what I use?

Other strange things, after installing I used Grub and to boot Slack and others successfully here's what I had to do to make the menu.lst-

Code:
title MyDSL-4.4.10
kernel /boot/linux24 root=/dev/hda3 etc-etc
initrd /boot/minirt24.gz

title PortaSlack-12.2
kernel (hd0,1)/boot/vmlinuz root=/dev/hda1

title TTYLinux-8.0.1
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2
I have slack on hda1, tty on hda2, and dsl on hda3.
If I tell slack "kernel (hd0,0)/boot/vmlinuz root=/dev/hda1"
It says "no setup image found" and won't boot??
If I use (hd0,1), which should be hda2(ttylinux), it boots into slack
and says "darkstar login:"

What's going on here?
Any help appreciated..
PortaSlack install is most of a, and others, comes up to 283MB
Installed-so how to get internet working and issues with
menu.lst
Thanks!
I have managed to get slack 12.1 down to about 120mb, it does take some trial and error to know which packages will work and ones that wont.

To get the internet to work you need to adjust the /etc/rc.d/rc.inet1.conf file, look for this at the top of the script.

Quote:
USE_DHCP[0]=""
And change to

Quote:
USE_DHCP[0]="yes"
This will get the dhcp client to grab an ipaddress from your dhcp server.


Quote:
title PortaSlack-12.2
kernel (hd0,1)/boot/vmlinuz root=/dev/hda1

title TTYLinux-8.0.1
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2
The reason this is not working is, you have both entries pointing to the same kernel, /boot/vmlinuz. You should have different names for the different kernels. When you have copied the kernels over, the last kernel slackware, would have over-written the TTYLinux kernel being in the same directory, that's why you had to change the entry to (hd0,1)

Copy the TTYLinux kernel over using a different name, and then change it back to (hd0,0), and it should work.


Quote:
which I did, and something
about installing gnugpg or something?
You will need to have this installed so it can verify the packages, this also needs another package that contains the libraries for gnugpg to work, it maybe in the same /a directory, or it maybe under /ap directory

Last edited by fotoguy; 05-31-2009 at 04:51 AM.
 
Old 05-31-2009, 05:32 AM   #4
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,060

Original Poster
Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
OK, thanks guys, but no dice...
I tried several options with this one and so I am re-installing to a different VHD
and try to dual boot with DSL and use lilo instead of Grub....maybe

I made a 1.8GB vhd and 3 partitions; hda1=slack, hda2=dsl, and a swap partition.
This time I installed alot + fluxbox and xfce.
Any pointers on adding dsl from hda2 to my lilo.conf?
 
Old 05-31-2009, 05:34 AM   #5
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,060

Original Poster
Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
OK, more info guys- I'm installing slack to a portable vhd made with portable qemu-img
and called it simply "vhd"
"qemu-img create vhd 1800M"
Then I boot up slack12.2 DVD and use cfdisk to chop up the vhd.
Then "poweroff"

OK, again start slack DVD and install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MadWiFi, getting Netgear WG311T to connect with dhclient/dhcpd (DHCP) Cb6000 Linux - Wireless Networking 30 02-16-2006 03:29 PM
Problem with DHCP usign minimal install linuxmandrake Debian 1 09-09-2005 11:54 AM
Minimal Install Tagfiles --- Slack 10? Nitrox Slackware 5 10-12-2004 08:58 PM
Minimal Slack 9.1 Install Questions Poetics Slackware 1 05-22-2004 04:31 PM
Installed DHCP on RH7.2, no dhcpd.conf file??? AnthonyM Linux - Networking 8 07-30-2002 07:21 AM


All times are GMT -5. The time now is 01:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration