LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-22-2011, 11:06 AM   #1
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
Installation of VMware-Player-4 on Slackware 13.37 32 bit


Installation of VMware-Player-4.0.0-471780.i386.bundle on my (almost) default Slackware 13.37 32 bit is failing and it is not giving me much hints:

Quote:
Rolling back VMware USB Arbitrator 8.4.18
Deconfiguring...
[########################################### ] 62%All configuration information is about to be removed. Do you wish to
keep your configuration files? [yes]: no

Uninstalling VMware Installer 2.0
Deconfiguring...
[######################################################################] 100%
Installation was unsuccessful.
It fails also in an root X session. Does anybody has any experience on how to deal with this?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 10-22-2011, 11:17 AM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.
 
10 members found this post helpful.
Old 10-22-2011, 11:36 AM   #3
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Original Poster
Rep: Reputation: 89
That just worked! Thank you!
 
Old 10-22-2011, 11:52 AM   #4
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
You'll have issues if you install the VMware Tools on Slackware guests.
VMware expects to see an /etc/pam.d directory, (you can just create this empty directory).

Theres a flaw is in the installation script which calls mkinitrd -h (expecting it to return help). On Slackware mkinitrd -h specifies the hibernation location. When/IF you decided to use VMware Tools on a Slackware guest, you can edit the installation $NAME.pl file, and replace mkinitrd -h with mkinitrd --help.

Or, optionally, not use VMware tools at all. Slackware already includes a mouse and graphics driver for VMware guests. You will have to disable compositing in Xorg though if you expect to run KDE on the guest VM. Search this forum, its been posted a few times
 
2 members found this post helpful.
Old 10-23-2011, 03:20 PM   #5
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Original Poster
Rep: Reputation: 89
Not only is LQ answering my questions, it is also anticipating them :-)

Yes I did try KDE (as it happens to be my favorite DE) and it crashed. Nevertheless, I am not fussy when I am working on a Virtual Machine and I am happy also with XFCE, but since you mentioned it, I persisted. So after some investigations, I started XFCE, then ran:

$ /usr/bin/systemsettings

and disabled all the desktop effects.

This solved it.
 
Old 12-19-2011, 03:44 PM   #6
geep999
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by disturbed1 View Post
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.
I can report that this also works on Slackware 13.37 x86_64 with VMware-Player-4.0.1-528992.x86_64.bundle

Cheers,
Peter
 
Old 07-15-2012, 05:40 PM   #7
caduqued
Member
 
Registered: Apr 2008
Location: Coventry, United Kingdom
Distribution: Slackware64, Slackware64 13.37, linuxslackware
Posts: 81

Rep: Reputation: 19
Quote:
Originally Posted by disturbed1 View Post
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.
Fantastic.... Just to let you all know, this also helps to get vmware-player 4.0.4 working on a Slackware64 13.37

Great!!!
 
Old 12-07-2012, 04:18 AM   #8
pino_otto
Member
 
Registered: Dec 2005
Location: Italy
Distribution: Slackware
Posts: 83

Rep: Reputation: 18
This solution also works on Slackware 14.0 with VM Player 5.0.1

# sh VMware-Player-5.0.1-894247.i386.bundle --console --ignore-errors
 
1 members found this post helpful.
Old 12-08-2013, 01:45 PM   #9
aalary
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
This workaround also works for Slackware 14.1 x86_64 with vmplayer 6.0.1

sh ./VMware-Player-6.0.1-1379776.x86_64.bundle --console --ignore-errors
 
Old 02-05-2014, 07:26 PM   #10
StevenXL
Member
 
Registered: Jan 2014
Posts: 70

Rep: Reputation: Disabled
Quote:
Originally Posted by disturbed1 View Post
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.
Hi - this worked perfectly, but I wanted to learn more about why it works and how it works.

Where can I look up what --console and --ignore-errors is doing, and are these options / arguments passed into the *.bundle file or to the sh program?

Thanks!
 
Old 03-03-2014, 06:35 PM   #11
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,574

Rep: Reputation: 463Reputation: 463Reputation: 463Reputation: 463Reputation: 463
Quote:
Originally Posted by aalary View Post
This workaround also works for Slackware 14.1 x86_64 with vmplayer 6.0.1

sh ./VMware-Player-6.0.1-1379776.x86_64.bundle --console --ignore-errors
It depends what you call "works", I guess.

When I do that, the installer completes (so that part works) but the end result won't actually run anything (which is a rather important part).

The vmmon and vmnet kernel modules appear to build correctly, but both of them have the added version magic of "preempt" which isn't in any other module on my system. As a result they won't load when you attempt to run /etc/init.d/vmware restart and the two services "Virtual machine monitor" and "Virtual ethernet" won't start.

Or can virtual machines be started without either of those two services running?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] slackware-current and vmware-player 3.1.3 thach.trung.ngoc Slackware 4 03-21-2011 04:56 PM
Trying to convert my slackware 64 bit version 13 to vmware ciantark Linux - Virtualization and Cloud 7 02-23-2010 03:59 PM
Flash player on Slackware 13.0 64 bit satinet Slackware 10 11-18-2009 05:33 PM
VMWare Player Install on Slackware 12.0 perry Slackware 23 11-04-2007 01:32 PM
Installation and running VMware Player spnoe Linux - Software 4 06-17-2006 12:09 AM


All times are GMT -5. The time now is 12:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration