LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Installation of VMware-Player-4 on Slackware 13.37 32 bit (http://www.linuxquestions.org/questions/slackware-14/installation-of-vmware-player-4-on-slackware-13-37-32-bit-909539/)

ChrisAbela 10-22-2011 10:06 AM

Installation of VMware-Player-4 on Slackware 13.37 32 bit
 
Installation of VMware-Player-4.0.0-471780.i386.bundle on my (almost) default Slackware 13.37 32 bit is failing and it is not giving me much hints:

Quote:

Rolling back VMware USB Arbitrator 8.4.18
Deconfiguring...
[########################################### ] 62%All configuration information is about to be removed. Do you wish to
keep your configuration files? [yes]: no

Uninstalling VMware Installer 2.0
Deconfiguring...
[######################################################################] 100%
Installation was unsuccessful.
It fails also in an root X session. Does anybody has any experience on how to deal with this?

disturbed1 10-22-2011 10:17 AM

as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.

ChrisAbela 10-22-2011 10:36 AM

That just worked! Thank you!

disturbed1 10-22-2011 10:52 AM

You'll have issues if you install the VMware Tools on Slackware guests.
VMware expects to see an /etc/pam.d directory, (you can just create this empty directory).

Theres a flaw is in the installation script which calls mkinitrd -h (expecting it to return help). On Slackware mkinitrd -h specifies the hibernation location. When/IF you decided to use VMware Tools on a Slackware guest, you can edit the installation $NAME.pl file, and replace mkinitrd -h with mkinitrd --help.

Or, optionally, not use VMware tools at all. Slackware already includes a mouse and graphics driver for VMware guests. You will have to disable compositing in Xorg though if you expect to run KDE on the guest VM. Search this forum, its been posted a few times :)

ChrisAbela 10-23-2011 02:20 PM

Not only is LQ answering my questions, it is also anticipating them :-)

Yes I did try KDE (as it happens to be my favorite DE) and it crashed. Nevertheless, I am not fussy when I am working on a Virtual Machine and I am happy also with XFCE, but since you mentioned it, I persisted. So after some investigations, I started XFCE, then ran:

$ /usr/bin/systemsettings

and disabled all the desktop effects.

This solved it.

geep999 12-19-2011 02:44 PM

Quote:

Originally Posted by disturbed1 (Post 4505232)
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.

I can report that this also works on Slackware 13.37 x86_64 with VMware-Player-4.0.1-528992.x86_64.bundle

Cheers,
Peter

caduqued 07-15-2012 04:40 PM

Quote:

Originally Posted by disturbed1 (Post 4505232)
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.

Fantastic.... Just to let you all know, this also helps to get vmware-player 4.0.4 working on a Slackware64 13.37

Great!!!

pino_otto 12-07-2012 03:18 AM

This solution also works on Slackware 14.0 with VM Player 5.0.1

# sh VMware-Player-5.0.1-894247.i386.bundle --console --ignore-errors

aalary 12-08-2013 12:45 PM

This workaround also works for Slackware 14.1 x86_64 with vmplayer 6.0.1

sh ./VMware-Player-6.0.1-1379776.x86_64.bundle --console --ignore-errors

StevenXL 02-05-2014 06:26 PM

Quote:

Originally Posted by disturbed1 (Post 4505232)
as root -
sh VMware-$NAME-$VERSION.bundle --console --ignore-errors

VmMare expects certain -isms from other distros to be present. This allows VMware to gracefully error on non critical events.

Hi - this worked perfectly, but I wanted to learn more about why it works and how it works.

Where can I look up what --console and --ignore-errors is doing, and are these options / arguments passed into the *.bundle file or to the sh program?

Thanks!

Richard Cranium 03-03-2014 05:35 PM

Quote:

Originally Posted by aalary (Post 5077476)
This workaround also works for Slackware 14.1 x86_64 with vmplayer 6.0.1

sh ./VMware-Player-6.0.1-1379776.x86_64.bundle --console --ignore-errors

It depends what you call "works", I guess.

When I do that, the installer completes (so that part works) but the end result won't actually run anything (which is a rather important part).

The vmmon and vmnet kernel modules appear to build correctly, but both of them have the added version magic of "preempt" which isn't in any other module on my system. As a result they won't load when you attempt to run /etc/init.d/vmware restart and the two services "Virtual machine monitor" and "Virtual ethernet" won't start.

Or can virtual machines be started without either of those two services running?


All times are GMT -5. The time now is 01:40 PM.