LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Install "VirtualBox-3.2.12-68 302" in slackware64-current ( kernel 2.6.38.7 ) (http://www.linuxquestions.org/questions/slackware-14/install-virtualbox-3-2-12-68-302-in-slackware64-current-kernel-2-6-38-7-a-887642/)

afreitascs 06-21-2011 10:11 PM

Install "VirtualBox-3.2.12-68 302" in slackware64-current ( kernel 2.6.38.7 )
 
Is there any way to install "VirtualBox-3.2.12-68302" in the "slackware64-current" (Kernel 2.6.38.7) ?

I have problems with the 4.0.x version of VB!

The version "VirtualBox-3.2.12-68302" works fine with my hardware!
I tested using "VB 3.2.12" and Slackware64-13.37 (kernel 2.6.37.6).

I get the warning when I try to install a guest OS in "VB 3.2.12" running slackware64-current ...

Quote:

there is a permission problem with /dev/vboxdrv. Please reinstall
the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS
package first.
This package keeps track of Linux kernel changes and recompiles the
vboxdrv kernel module if necessary"
and still

Quote:

Failed to open a session for the virtual machine Slackware12.0.
The virtual machine 'Slackware12.0' has terminated unexpectedly during
startup with exit code 1.


Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
Machine
Interface:
IMachine {6d9212cb-a5c0-48b7-bbc1-3fa2ba2ee6d2}
thanks

markush 06-25-2011 02:41 PM

Did you notice that there are versions for 64bit and for 32bit systems available? Did you try the 64bit-version with Slackware64-current?

Markus

rmjohnso 06-25-2011 02:59 PM

Assuming you are running the 64-bit version of VB, execute the following as root and tell us what shows up:

Code:

/etc/rc.d/rc.vboxdrv setup

afreitascs 06-25-2011 10:39 PM

Quote:

Originally Posted by markush (Post 4395640)
Did you notice that there are versions for 64bit and for 32bit systems available? Did you try the 64bit-version with Slackware64-current?

Markus

I installed

VirtualBox-3.2.12-68302-Linux_amd64.run

many thanks

afreitascs 06-25-2011 10:45 PM

Quote:

Originally Posted by rmjohnso (Post 4395656)
Assuming you are running the 64-bit version of VB, execute the following as root and tell us what shows up:

Code:

/etc/rc.d/rc.vboxdrv setup


Here is:

Quote:

root@base1:~# /etc/rc.d/rc.vboxdrv setup
Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules ...done.
Trying to register the VirtualBox kernel modules using DKMS ...failed!
(Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...failed!
(Look at /var/log/vbox-install.log to find out what went wrong)
many thanks

rmjohnso 06-25-2011 11:04 PM

What does /var/log/vbox-install.log show? Also, what problems do you have with the latest VB 4.x series? It works for me on slackware64-current and kernel 2.6.38.7.

afreitascs 06-25-2011 11:47 PM

Quote:

Originally Posted by rmjohnso (Post 4395841)
What does /var/log/vbox-install.log show? Also, what problems do you have with the latest VB 4.x series? It works for me on slackware64-current and kernel 2.6.38.7.

Here is :

Quote:

make KBUILD_VERBOSE=1 -C /lib/modules/2.6.38.7/build SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo; \
/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/vbox.0
gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d -nostdinc -isystem /usr/lib64/gcc/x86_64-slackware-linux/4.5.3/include -I/usr/src/linux-2.6.38.7/arch/x86/include -Iinclude -include include/generated/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -fstack-protector -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -fno-omit-frame-pointer -fno-optimize-sibling-calls -pg -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -DCC_HAVE_ASM_GOTO -I/lib/modules/2.6.38.7/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/linux/SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
In file included from /tmp/vbox.0/include/VBox/types.h:30:0,
from /tmp/vbox.0/linux/../SUPDrvInternal.h:35,
from /tmp/vbox.0/linux/SUPDrv-linux.c:31:
/tmp/vbox.0/include/iprt/types.h:97:31: fatal error: linux/autoconf.h: No such file or directory
compilation terminated.
make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
make[1]: *** [_module_/tmp/vbox.0] Error 2
make: *** [vboxdrv] Error 2
With "vB4" I have a problem I suppose is only occurring with me.
Please look at the link.

http://www.linuxquestions.org/questi...solved-884060/

I hope (sincerely) that you are understanding what I write :-)

many thanks

markush 06-26-2011 03:42 AM

Hello afreitascs,

the errors refer to your kernel, are you using the stock Slackware64 kernel of current or did you build it by yourself?

I'm running the recent Vbox 4.08 on Slackware64-current without any problems.

Markus

afreitascs 06-26-2011 10:39 AM

Quote:

Originally Posted by markush (Post 4395919)
Hello afreitascs,

the errors refer to your kernel, are you using the stock Slackware64 kernel of current or did you build it by yourself?

I use stock .


Quote:

I'm running the recent Vbox 4.08 on Slackware64-current without any problems.
I have problem with "VB 4.0.x" and still not have a solution. Please see the link below.

http://www.linuxquestions.org/questi...solved-884060/

I hope (sincerely) that you are understanding what I write :-)

many thanks

markush 06-26-2011 11:39 AM

Well, I understood what you've written, I followed your other thread, but I think I can't really help you.

It seems that one of both doesn't work properly, your Slackware-installation or the Vbox-installer.

What happens if you download the most recent version of Vbox? do you get the same errormessages?

Markus

afreitascs 06-26-2011 12:16 PM

Quote:

Originally Posted by markush (Post 4396168)

What happens if you download the most recent version of Vbox? do you get the same errormessages?

Markus

VB versions 4.0.x, install fine on my Slackware64-current, and work, but
I have to disable AMD-V.

I just wanted to know why my host pc resets when I enable AMD-V.

In WindowsXP guest does not need to disable AMD-V (everything works fine)!

many thanks

rmjohnso 06-26-2011 12:28 PM

Are you sure that your processor supports AMD-V? What is the output of:

Code:

cat /proc/cpuinfo

afreitascs 06-26-2011 12:57 PM

Quote:

Originally Posted by rmjohnso (Post 4396206)
Are you sure that your processor supports AMD-V? What is the output of:

Code:

cat /proc/cpuinfo

Quote:

base1@base1:~$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
stepping : 2
cpu MHz : 1000.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips : 2008.83
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 107
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
stepping : 2
cpu MHz : 1000.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips : 2008.83
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

base1@base1:~$
also link

http://www.cpu-world.com/CPUs/K8/AMD...0DOBOX%29.html

many thanks

markush 06-26-2011 01:13 PM

You'll probably have to configure your kernel to support this feature. I'm not sure since I have my own kernel .config file and cannot seem to find out on my system if this feature is enabled with the stock kernel.

Within the kernelsources I find
Code:

markus@samsung:/tmp/linux-3.0-rc1/Documentation$ grep -Ri svm * | grep -i amd   
kernel-parameters.txt:  kvm-amd.nested= [KVM,AMD] Allow nested virtualization in KVM/SVM

Maybe this has something to do with AMD-V, I'm not sure.

Markus

afreitascs 06-26-2011 01:58 PM

Quote:

Originally Posted by markush (Post 4396234)
You'll probably have to configure your kernel to support this feature. I'm not sure since I have my own kernel .config file and cannot seem to find out on my system if this feature is enabled with the stock kernel.

Within the kernelsources I find
Code:

markus@samsung:/tmp/linux-3.0-rc1/Documentation$ grep -Ri svm * | grep -i amd   
kernel-parameters.txt:  kvm-amd.nested= [KVM,AMD] Allow nested virtualization in KVM/SVM

Maybe this has something to do with AMD-V, I'm not sure.

Markus

If I understand ...

my processor does not support "Nested Paging", but that should not be a problem ...
It supports only AMD-V ...

This problem only happens with linux guest OS. In Windows guest NO problem.

I installed Fedora 15 host on another hdd to test the behavior of VB 4, using slackware 12.0 guest with AMD-V enabled.

many thanks


All times are GMT -5. The time now is 06:01 AM.