LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Incorrect screen resolution with slackware64 13.1 and nvidia 195.36.15 driver (http://www.linuxquestions.org/questions/slackware-14/incorrect-screen-resolution-with-slackware64-13-1-and-nvidia-195-36-15-driver-810169/)

Phorize 05-26-2010 05:06 AM

Incorrect screen resolution with slackware64 13.1 and nvidia 195.36.15 driver
 
Hi All,

I am running slackware64 13.1 with nvidia 195.36.15 driver and kernel. The gpu is an nvidia 6600 and the monitor an asus vw192s.

I am unable to achieve full resolution (1440x900) and can only get 1024x800.

Below is my xorg.conf (produced by nvidia-xconfig with screen section hand edited).

Any ideas?

All the best,

Kris

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Mar 12 02:12:40 PST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/lib64/X11/fonts/misc/:unscaled"
FontPath "/usr/lib64/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib64/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib64/X11/fonts/misc/"
FontPath "/usr/lib64/X11/fonts/Type1/"
FontPath "/usr/lib64/X11/fonts/Speedo/"
FontPath "/usr/lib64/X11/fonts/100dpi/"
FontPath "/usr/lib64/X11/fonts/75dpi/"
FontPath "/usr/lib64/X11/fonts/cyrillic/"
FontPath "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24

SubSection "Display"
Depth 24
Modes "1440x900"
EndSubSection
EndSection

mlangdn 05-26-2010 06:10 AM

Open the NVIDIA X Server Settings app and click on the X Server Display Configuration on the left side.
I have the same resolution (1440x900) and see where its set. Mine is set to auto, but you can click on the drop-down box and select your desired resolution.

I do not have the screen subsection in my xorg.conf.

Phorize 05-26-2010 06:48 AM

Quote:

Originally Posted by mlangdn (Post 3981563)
Open the NVIDIA X Server Settings app and click on the X Server Display Configuration on the left side.
I have the same resolution (1440x900) and see where its set. Mine is set to auto, but you can click on the drop-down box and select your desired resolution.

I do not have the screen subsection in my xorg.conf.

Hi, thanks for your reply. I forgot to mention that irrespective of the values that I add to the mode section, or whether I have modes in xorg.conf at all, nvidia-settings does not show 1440x900 (closest shown is 1440x1050). I have used the used the HorizSync and
VertRefresh values for an analogue output as recommended on any specs that I have found on the web (I don't have the vw192s manual) as they would usually be the first place that I would look to resolve a resolution issue. It is probably worth noting that I have always easily achieved 1440x900 on any linux distro with the nvidia driver until (I mainly used fedora until about 1 year ago) but started getting this with fedora 11. Do we know of any changes to x11 or the nvidia driver that would cause this-interestly the nouveau driver on fedora 13 detects my resolution perfectly.

skaterase 05-26-2010 07:00 AM

Can you post the contents of your log file: /var/log/Xorg.0.log

Try starting X without an xorg.conf file or try removing the Display subsection or try with only the Device section.

uppman 05-26-2010 07:09 AM

I would guess the problem is with the HorizSync and VertRefresh.
The X-server doesn't like to be restrained.. :) Try to comment both and see if X can sort itself out.

Quote:

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

LouRobytes 05-26-2010 07:50 AM

If you add this option to the Device section of xorg.conf
Code:

        Option "ModeDebug" "True"
and then reboot, a wealth of info, including EDID reported data will be logged to /var/log/Xorg.0.log.

Please attach your log file.

Cheers, Lou

allend 05-26-2010 11:06 AM

Try adding this line to the Monitor section of your xorg.conf and changing the mode name in the Display subsection to "1440x900_60.00".
Quote:

Modeline "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
The above line was output by running 'cvt 1440 900'.
It appears that your monitor is reporting incomplete information when EDID is interrogated.
FYI, there is a later version of the nVidia driver available.

dr_alex 05-27-2010 03:29 PM

Quote:

Originally Posted by kristizz (Post 3981514)
Hi All,

I am running slackware64 13.1 with nvidia 195.36.15 driver and kernel. The gpu is an nvidia 6600 and the monitor an asus vw192s.

I am unable to achieve full resolution (1440x900) and can only get 1024x800.

Below is my xorg.conf (produced by nvidia-xconfig with screen section hand edited).

Any ideas?

All the best,

Kris

Hi Kris! May be this help you?
Code:

Identifier    "My Monitor"
    VendorName    "Samsung"
    ModelName      "SyncMaster 961BW"
    HorizSync      30.0 - 81.0
    VertRefresh    56.0 - 75.0
    ModeLine      "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    Option        "DPI" "96 x 96"
    Option        "ModeValidation" "NoMaxPClkCheck"
EndSection

Section "Device"

    #VideoRam    4096
    # Insert Clocks lines here if appropriate
    Identifier    "VESA Framebuffer"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS"
    Option        "ExactModeTimingsDVI"
    Option        "ModeValidation" "NoDFPNativeResolutionCheck"
EndSection

Section "Screen"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.
#  DefaultDepth 8
#  DefaultDepth 16
#  DefaultDepth 32
# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)
    Identifier    "Screen 1"
    Device        "VESA Framebuffer"
    Monitor        "My Monitor"
    DefaultDepth    24
    Option        "NoLogo" "True"
    Option        "TwinView" "0"
    Option        "metamodes" "1440x900_60 +0+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection


LuckyCyborg 05-27-2010 04:05 PM

Quote:

Originally Posted by kristizz (Post 3981514)
The gpu is an nvidia 6600

Ouch! Your GPU have the age of my granny... It's... soooooooooo old!

You are sure that you use the right driver?

How about to try a little hardware upgrade (spending few bucks, like a burger) if you want gingles and bells? :D

T3slider 05-27-2010 04:23 PM

Quote:

Originally Posted by LuckyCyborg (Post 3983358)
Ouch! Your GPU have the age of my granny... It's... soooooooooo old!

You are sure that you use the right driver?

How about to try a little hardware upgrade (spending few bucks, like a burger) if you want gingles and bells? :D

My old PC had a 6100. Not the best but it worked. Some motherboards are still sold with 6100/6200 integrated graphics. Even a few Linux games ran on my integrated 6100...Urban Terror was even playable. Of course I prefer my nice shiny GTX-260 but if it works, it works.

[/off-topic]

I, at one point, required a custom modeline for my 6100 to support a 1680x1050 screen, so allend's advice may certainly be valid.

Phorize 05-27-2010 05:26 PM

Quote:

Originally Posted by T3slider (Post 3983373)
My old PC had a 6100. Not the best but it worked. Some motherboards are still sold with 6100/6200 integrated graphics. Even a few Linux games ran on my integrated 6100...Urban Terror was even playable. Of course I prefer my nice shiny GTX-260 but if it works, it works.

[/off-topic]

I, at one point, required a custom modeline for my 6100 to support a 1680x1050 screen, so allend's advice may certainly be valid.

Thanks for the suggestions guys-I'll work on this and post back.

Kris

Phorize 05-28-2010 05:05 AM

1 Attachment(s)
Ok chaps-thanks for all of your help here. I have changed the hor/vert frequency values and can now use nvidia-settings to set 1440x900. The problem that I have now is that my panel/windows borders maximise to outside of the left side of my screen by several pixels. I am assuming that I need to use xorg.conf to tell x about the dimensions of my monitor? I have attached my log file. I'm going to look for guidance on setting monitor dimensions on the xorg site, but any further help is very appreciated.


All the best,

Kris

zordrak 05-28-2010 05:31 AM

Although it doesn't help the resolution issue, you should pull the input devices from your config file.

For reference:
http://blog.tpa.me.uk/2010/04/09/con...-on-slackware/

LouRobytes 05-28-2010 05:31 AM

Your modeline should be using these values from your log file:
Code:

(II) May 28 08:11:49 NVIDIA(0):  Validating Mode "1440x900_60.00":
(II) May 28 08:11:49 NVIDIA(0):    1440 x 900 @ 60 Hz
(II) May 28 08:11:49 NVIDIA(0):    Mode Source: X Configuration file ModeLine
(II) May 28 08:11:49 NVIDIA(0):      Pixel Clock      : 106.50 MHz
(II) May 28 08:11:49 NVIDIA(0):      HRes, HSyncStart : 1440, 1528
(II) May 28 08:11:49 NVIDIA(0):      HSyncEnd, HTotal : 1672, 1904
(II) May 28 08:11:49 NVIDIA(0):      VRes, VSyncStart :  900,  903
(II) May 28 08:11:49 NVIDIA(0):      VSyncEnd, VTotal :  909,  934
(II) May 28 08:11:49 NVIDIA(0):      H/V Polarity    : -/+
(II) May 28 08:11:49 NVIDIA(0):    Mode is valid.

Example
Code:

    ModeLine      "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
If using these values doesn't correct your size problem, then there should be a hardware menu button on your display to set sizes, positions, and such.

Lou

uppman 05-28-2010 05:58 AM

Quote:

Originally Posted by kristizz (Post 3983920)
Ok chaps-thanks for all of your help here. I have changed the hor/vert frequency values and can now use nvidia-settings to set 1440x900. The problem that I have now is that my panel/windows borders maximise to outside of the left side of my screen by several pixels. I am assuming that I need to use xorg.conf to tell x about the dimensions of my monitor? I have attached my log file. I'm going to look for guidance on setting monitor dimensions on the xorg site, but any further help is very appreciated.


All the best,

Kris

You can also use nvidia-settings to change the overscan which will adjust the screen size.
The "Dimensions" in xorg.conf is only used (AFAIK) to calculate the dpi.


All times are GMT -5. The time now is 09:24 AM.