LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-18-2012, 05:43 PM   #1
mariostg
Member
 
Registered: Apr 2011
Location: Gatineau, Quebec
Distribution: OpenBSD
Posts: 80

Rep: Reputation: 5
Improving responsiveness of rxvt


I recently installed Slackware in dual boot beside Arch.
I am sure there might be dozen of things to consider or look at but I am not clear as to how to proceed with the folowing.
I installed rxvt-unicode from Slackbuild.org and it seems not to respond as fast as it does when used in Arch. There is that fraction of a second where it seems to hang when typing.

Out of curiosity, I modified the slackbuild script to reflect the PKGBUILD in Arch, reinstalled rxvt and yet no improvement.

So is there a specific area I should look at?

Thanks all.
 
Old 09-19-2012, 01:33 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,391

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Hi and welcome to the Club

IIRC a possible culprit *could* be the nouveau version included in Slackware 13.37, as I observed that with it but not with a more recent one nor with the blob that I am right now using.

But I usually run xterm, not rxvt-unicode. Did you try with an xterm and does that make any difference?

I will switch to nouveau later today and will tell you if I still observe this behavior.

Meanwhile, what are your GPU kernel driver + X module used for video? If it's Intel or ATI my assumption can be safely moved to /dev/null "lspci -k| grep -A3 VGA" is usually enough to answer that.

OTOH, would it be right you just would have to wait a few days till Slackware 14 be released (if, indeed, you are not already running Slackware-current).

Last edited by Didier Spaier; 09-19-2012 at 02:32 AM.
 
Old 09-19-2012, 12:54 PM   #3
fl0
Member
 
Registered: May 2010
Location: Germany
Distribution: Slackware
Posts: 105

Rep: Reputation: 34
Hi,

do you use antialiasing? i have had the same "problem" with rxvt-unicode, i disabled antialiasing and now it's ok.

regards fl0
 
Old 09-19-2012, 03:52 PM   #4
mariostg
Member
 
Registered: Apr 2011
Location: Gatineau, Quebec
Distribution: OpenBSD
Posts: 80

Original Poster
Rep: Reputation: 5
@Didier. Thanks for the welcome.

My graphic card is nvidia...
Quote:
├─(/home/marst)
└──> lspci -k| grep -A3 VGA
05:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400] (rev a2)
Subsystem: nVidia Corporation Device 0243
Kernel driver in use: nouveau
Kernel modules: nouveau, nvidiafb
My Arch installation uses the nvidia driver. If I find time and boot Arch, I should probably try to install the nouveau driver for comparison purposes.

I am running Slackware 13.37 at the moment.
I briefly tried xterm. Hard to tell. I will see if I can customize it a bit i.e. no border, black background and see how it goes.

@fl0. No I don't use antialiasing In fact, this is my configuration
Quote:
URxvt.termName:rxvt
URxvt.transparent: true
URxvt.inheritPixmap: false
URxvt.scrollBar: false
URxvt.savelines: 1000
URxvt.urlLauncher: firefox
URxvt.cursorBlink: true
URxvt.geometry: 93x26
URxvt.fading: 25%
urxvt.font: xft:Bitstream Vera Sans Monoixelsize=11
urxvt.boldfont: xft:Bitstream Vera Sans Mono:boldixelsize=11
urxvt.depth: 32
urxvt.background: rgba:0000/0000/0000/dddd
!URxvt.foreground: grey80
URxvt.tintColor: #262626
URxvt.borderLess: true
URxvt.borderColor: #888888
 
Old 09-19-2012, 05:25 PM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,391

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
I can't try now (it's late in Paris) but tomorrow I will switch ton nouveau in both Slackware 13.37 and Slackware current. If I see a difference I will try a more recent version of nouveau in Slackware 13.37 and tell you the results, both with xterm and urxvt.
 
Old 09-20-2012, 07:16 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,391

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Nothing really obvious here using nouveau. I have an awk script started from an xterm and spitting one line of text every 4 seconds. Sometime the first horizontal half of a line line is displayed first, then the second half. But the script is very CPU hungry so that may not be significant.

You could check that the nouveau driver *could* be involved with "cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf" and restart X to see if there is any change using the vesa driver instead of nouveau.

Last edited by Didier Spaier; 09-20-2012 at 07:18 AM.
 
Old 09-20-2012, 04:46 PM   #7
mariostg
Member
 
Registered: Apr 2011
Location: Gatineau, Quebec
Distribution: OpenBSD
Posts: 80

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by Didier Spaier View Post
Nothing really obvious here using nouveau. I have an awk script started from an xterm and spitting one line of text every 4 seconds. Sometime the first horizontal half of a line line is displayed first, then the second half. But the script is very CPU hungry so that may not be significant.

You could check that the nouveau driver *could* be involved with "cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf" and restart X to see if there is any change using the vesa driver instead of nouveau.
You mean an awk script on rxvt I presume... . The thing is it's really when I type text as opposed to when displaying say a long ls command which seem fine. Now looks like xterm behaves better. I will look at terminator too for comparison purposes.

Mario
 
Old 09-20-2012, 05:46 PM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,391

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
I am on Slackware 14-RC5 now.

I confirm that xterm looks more responsive. I don't know for urxvt as I didn't install it yet.
 
Old 09-20-2012, 06:31 PM   #9
mariostg
Member
 
Registered: Apr 2011
Location: Gatineau, Quebec
Distribution: OpenBSD
Posts: 80

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by Didier Spaier View Post
I am on Slackware 14-RC5 now.

I confirm that xterm looks more responsive. I don't know for urxvt as I didn't install it yet.
Glad to see I am not crazy . Anyway, been satisfied so far. I installed terminator. Looks good. Slackware will likely end up on my netbook too, soon.
 
Old 09-21-2012, 05:59 AM   #10
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
On my older PC I've also encountered this issue with urxvt. I believe the problem was solved by installing the nvidia driver.
 
Old 09-21-2012, 06:59 AM   #11
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
Quote:
Originally Posted by Didier Spaier View Post
You could check that the nouveau driver *could* be involved with "cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf" and restart X to see if there is any change using the vesa driver instead of nouveau.
nouveau is a kernel mode setting driver, so that likely won't work unless the OP also blacklists it (and reboots).
 
Old 09-21-2012, 07:40 AM   #12
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,391

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Quote:
Originally Posted by el chapulín View Post
nouveau is a kernel mode setting driver, so that likely won't work unless the OP also blacklists it (and reboots).
Good point. I just tried, and though Xorg.0.log show nothing weird, the nouveau kernel module becomes angry that his buddy the nouveau X module be discarded. To avenge this affront it spits so many[*] lines like this one in the logs
Code:
Sep 21 14:19:05 machine kernel: [  118.325211] [drm] nouveau 0000:01:00.0: PFIFO_BAR_FAULT - VM: Trapped write at 0001075c78 status 00001a26 channel 0 (0x00000040)
that the system becomes *really* unresponsive

[*] 645 lines accounting for 106258 characters in one second.

Last edited by Didier Spaier; 09-21-2012 at 07:56 AM. Reason: Tell how big is many
 
Old 09-21-2012, 07:52 AM   #13
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,391

Rep: Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091Reputation: 1091
Was a duplicate post.

Last edited by Didier Spaier; 09-21-2012 at 09:15 AM.
 
Old 09-21-2012, 05:30 PM   #14
mariostg
Member
 
Registered: Apr 2011
Location: Gatineau, Quebec
Distribution: OpenBSD
Posts: 80

Original Poster
Rep: Reputation: 5
Well, I try rebooting with an xorg.conf but the screen resolution kind of suck. I set up terminator to my liking and will go with that. It has been a learning experience .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] TERM=rxvt / rxvt-unicode and ctrl-L irb Slackware 10 06-09-2010 05:09 AM
Linux responsiveness Uqbar Linux - General 1 12-18-2008 05:54 AM
How to enhance responsiveness? Uqbar Linux - Desktop 8 09-05-2007 09:52 AM
UI responsiveness yaBoy Linux - Laptop and Netbook 1 05-21-2004 05:23 PM
Improving USB Keyboard Responsiveness? dumtruck51 Linux - Newbie 4 12-26-2003 10:54 AM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration