LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Improving responsiveness of rxvt (http://www.linuxquestions.org/questions/slackware-14/improving-responsiveness-of-rxvt-4175427904/)

mariostg 09-18-2012 06:43 PM

Improving responsiveness of rxvt
 
I recently installed Slackware in dual boot beside Arch.
I am sure there might be dozen of things to consider or look at but I am not clear as to how to proceed with the folowing.
I installed rxvt-unicode from Slackbuild.org and it seems not to respond as fast as it does when used in Arch. There is that fraction of a second where it seems to hang when typing.

Out of curiosity, I modified the slackbuild script to reflect the PKGBUILD in Arch, reinstalled rxvt and yet no improvement.

So is there a specific area I should look at?

Thanks all.

Didier Spaier 09-19-2012 02:33 AM

Hi and welcome to the Club :cool:

IIRC a possible culprit *could* be the nouveau version included in Slackware 13.37, as I observed that with it but not with a more recent one nor with the blob that I am right now using.

But I usually run xterm, not rxvt-unicode. Did you try with an xterm and does that make any difference?

I will switch to nouveau later today and will tell you if I still observe this behavior.

Meanwhile, what are your GPU kernel driver + X module used for video? If it's Intel or ATI my assumption can be safely moved to /dev/null ;) "lspci -k| grep -A3 VGA" is usually enough to answer that.

OTOH, would it be right you just would have to wait a few days till Slackware 14 be released (if, indeed, you are not already running Slackware-current).

fl0 09-19-2012 01:54 PM

Hi,

do you use antialiasing? i have had the same "problem" with rxvt-unicode, i disabled antialiasing and now it's ok.

regards fl0

mariostg 09-19-2012 04:52 PM

@Didier. Thanks for the welcome. :)

My graphic card is nvidia...
Quote:

├─(/home/marst)
└──> lspci -k| grep -A3 VGA
05:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400] (rev a2)
Subsystem: nVidia Corporation Device 0243
Kernel driver in use: nouveau
Kernel modules: nouveau, nvidiafb
My Arch installation uses the nvidia driver. If I find time and boot Arch, I should probably try to install the nouveau driver for comparison purposes.

I am running Slackware 13.37 at the moment.
I briefly tried xterm. Hard to tell. I will see if I can customize it a bit i.e. no border, black background and see how it goes.

@fl0. No I don't use antialiasing In fact, this is my configuration
Quote:

URxvt.termName:rxvt
URxvt.transparent: true
URxvt.inheritPixmap: false
URxvt.scrollBar: false
URxvt.savelines: 1000
URxvt.urlLauncher: firefox
URxvt.cursorBlink: true
URxvt.geometry: 93x26
URxvt.fading: 25%
urxvt.font: xft:Bitstream Vera Sans Mono:pixelsize=11
urxvt.boldfont: xft:Bitstream Vera Sans Mono:bold:pixelsize=11
urxvt.depth: 32
urxvt.background: rgba:0000/0000/0000/dddd
!URxvt.foreground: grey80
URxvt.tintColor: #262626
URxvt.borderLess: true
URxvt.borderColor: #888888

Didier Spaier 09-19-2012 06:25 PM

I can't try now (it's late in Paris) but tomorrow I will switch ton nouveau in both Slackware 13.37 and Slackware current. If I see a difference I will try a more recent version of nouveau in Slackware 13.37 and tell you the results, both with xterm and urxvt.

Didier Spaier 09-20-2012 08:16 AM

Nothing really obvious here using nouveau. I have an awk script started from an xterm and spitting one line of text every 4 seconds. Sometime the first horizontal half of a line line is displayed first, then the second half. But the script is very CPU hungry so that may not be significant.

You could check that the nouveau driver *could* be involved with "cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf" and restart X to see if there is any change using the vesa driver instead of nouveau.

mariostg 09-20-2012 05:46 PM

Quote:

Originally Posted by Didier Spaier (Post 4785012)
Nothing really obvious here using nouveau. I have an awk script started from an xterm and spitting one line of text every 4 seconds. Sometime the first horizontal half of a line line is displayed first, then the second half. But the script is very CPU hungry so that may not be significant.

You could check that the nouveau driver *could* be involved with "cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf" and restart X to see if there is any change using the vesa driver instead of nouveau.

You mean an awk script on rxvt I presume... :). The thing is it's really when I type text as opposed to when displaying say a long ls command which seem fine. Now looks like xterm behaves better. I will look at terminator too for comparison purposes.

Mario

Didier Spaier 09-20-2012 06:46 PM

I am on Slackware 14-RC5 now.

I confirm that xterm looks more responsive. I don't know for urxvt as I didn't install it yet.

mariostg 09-20-2012 07:31 PM

Quote:

Originally Posted by Didier Spaier (Post 4785417)
I am on Slackware 14-RC5 now.

I confirm that xterm looks more responsive. I don't know for urxvt as I didn't install it yet.

Glad to see I am not crazy :). Anyway, been satisfied so far. I installed terminator. Looks good. Slackware will likely end up on my netbook too, soon.

elesmod 09-21-2012 06:59 AM

On my older PC I've also encountered this issue with urxvt. I believe the problem was solved by installing the nvidia driver.

el chapulín 09-21-2012 07:59 AM

Quote:

Originally Posted by Didier Spaier (Post 4785012)
You could check that the nouveau driver *could* be involved with "cp /etc/X11/xorg.conf.vesa /etc/X11/xorg.conf" and restart X to see if there is any change using the vesa driver instead of nouveau.

nouveau is a kernel mode setting driver, so that likely won't work unless the OP also blacklists it (and reboots).

Didier Spaier 09-21-2012 08:40 AM

Quote:

Originally Posted by el chapulín (Post 4785749)
nouveau is a kernel mode setting driver, so that likely won't work unless the OP also blacklists it (and reboots).

Good point. I just tried, and though Xorg.0.log show nothing weird, the nouveau kernel module becomes angry that his buddy the nouveau X module be discarded. To avenge this affront it spits so many[*] lines like this one in the logs
Code:

Sep 21 14:19:05 machine kernel: [  118.325211] [drm] nouveau 0000:01:00.0: PFIFO_BAR_FAULT - VM: Trapped write at 0001075c78 status 00001a26 channel 0 (0x00000040)
that the system becomes *really* unresponsive ;)

[*] 645 lines accounting for 106258 characters in one second.

Didier Spaier 09-21-2012 08:52 AM

Was a duplicate post.

mariostg 09-21-2012 06:30 PM

Well, I try rebooting with an xorg.conf but the screen resolution kind of suck. I set up terminator to my liking and will go with that. It has been a learning experience :).


All times are GMT -5. The time now is 01:50 AM.