LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-29-2012, 01:30 PM   #1
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
If you have problems compiling some programs on 14.0


If you have problems compiling programs of slackware 14.0, especially if the errors have to do with 'libdl' or 'libm', I recommend adding this to '~/.bashrc':

Code:
export LIBS="-lm -ldl"
That should fix it.
 
Old 10-01-2012, 09:20 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Original Poster
Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
So, nobody has had a problem ? The problem was with ROX-Filer and Geany (I think). Either way after that I added the export LIBS and I cannot say for sure how many more packages are affected. I suppose it is mostly the software maintainer's fault for not adding these to the linker flags.
 
Old 10-01-2012, 10:23 AM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,493

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
i think it's GCC's fault
 
Old 10-01-2012, 10:27 AM   #4
imitis
Member
 
Registered: Oct 2007
Location: Latvia, Liepaja
Distribution: Slackware, Ubuntu
Posts: 39

Rep: Reputation: 3
I have problems with clementine
 
Old 10-01-2012, 06:33 PM   #5
jmccue
Member
 
Registered: Nov 2008
Location: US
Distribution: slackware
Posts: 120

Rep: Reputation: 29
Quote:
Originally Posted by H_TeXMeX_H View Post
So, nobody has had a problem ?
The only issue I have had is 'gtk/gnome type software. I was playing around wondering what a specific package did and was not concerned if it compiled or not. All apps I care about compiled fine so far

Quote:
Originally Posted by H_TeXMeX_H View Post
I suppose it is mostly the software maintainer's fault for not adding these to the linker flags.
I tend to agree with that, if you needed advance math functions you needed to specify -lm, for example: "man sqrt".

John
 
Old 10-01-2012, 06:39 PM   #6
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 792

Rep: Reputation: 104Reputation: 104
I've had several issues already. Good tip and will definitely add that to my .bashrc file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Ktigcc(compiling programs) hakin9 Slackware 3 12-03-2007 02:47 AM
Compiling C++ programs rchillal Linux - Newbie 13 02-08-2005 05:27 AM
Problems compiling sigc++ programs siminone Programming 4 10-24-2004 06:31 PM
problems with lilo.conf and compiling c programs javadi82 Linux - Newbie 3 11-02-2003 03:16 PM
Have anyone experimented problems compiling programs in rh9? mkaman Red Hat 2 10-31-2003 10:41 AM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration