LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-01-2014, 11:26 PM   #1
Barking Shark
LQ Newbie
 
Registered: Jan 2014
Location: Pennsylvania
Distribution: Slackware
Posts: 5

Rep: Reputation: Disabled
Question ICS between Wifi capable Windows 7 laptop and Slackware desktop


Disclaimer: I just installed Slackware 14.1, and I have never used any kind of Linux OS before, nor have I done any kind of networking.
Here's the goal: Internet Router -(WiFi)- Windows 7 laptop -(Ethernet)- Slackware desktop

I know this question has been asked before (on this forum and others), because I've spent the last three days googling how to do this. All of the explanations I've found rely on a base of Slackware/Linux/networking knowledge I just don't have yet, and I can't download new packages and learn about this stuff without an internet connection. I'd really appreciate an ultra-beginners guide to setting up this kind of connection. If anyone has a link to an existing guide/answer (one that doesn't rely entirely on phrases like "check the contents of /etc/resolv.conf";
"Are you setting this address statically or are you using dhcpcd?"; or "If you are setting it statically you need to run the route command."), I'd happily use that too.

Thank you all in advance for your help.
 
Old 01-02-2014, 01:53 AM   #2
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 731

Rep: Reputation: 339Reputation: 339Reputation: 339Reputation: 339
Greetings and...whew! Please believe me that I am saying this in all kindness and sincerity and with a non-judgmental attitude. I happen to actually believe that none of us knows these details a priori and if a person isn't a "noob" at something that person is probably lacking in ambition and reach.

Maybe there are others on here who will help you "paint by numbers" and I'll take a stab at it, but I can't help but wonder why you chose Slackware when the Ubuntus (and just about everybody else) does all that stuff for you with Windows-like "wizards". The simple facts are that it is faster to do networking by command line and this implies at least some basic knowledge of commands and locations of pertinent files.

For example "/etc/resolv.conf" corresponds to the DNS boxes in a windows-like Network Device TCPIP section. It tells your system the addresses of the primary and secondary Domain Name Servers, either the default ones from your ISP or a service like OpenDNS, which some people find yields a "snappier" Internet experience since DNS is the translator that converts human language like "Yahoo.com" into machine friendly numbers like "207.69.42.20". So "/etc/resolv.conf" can be quite important to the task you've set for yourself.

It is possible as long as you know what your Nic's designation is, for example whether it is "eth0" or "eth1" to be up and running with 2 or 3 commands, mainly "ifconfig" and "route" especially if you're creating a static IP for your Slack Box on your internal network. This assumes you know the IP address of your router, commonly 192.168.0.1 or 192.168.1.0. This will become your Gateway address on your slack box. If you become good at stringing command switches with appropriate addresses you can set IP, Netmask and Default Gateway with just one command - ifconfig. Some prefer to separate Gateway into a 3rd command since (no need for strict sequence here - one could set DNS anytime having no effect on IP, Netmask and Gateway.

The easiest way for a beginner to setup an ethernet driven Internet connection is to simply edit 2 files, the aforementioned "/etc/resolv.conf" and "/etc/rc.d/rc.inet1.conf" and this is because Patrick and the team have put lots of nice comments in it to help you decide what you need. Here is an unedited one with the exception that I snipped off the bottom half for interfaces you said you don't need for this project

Code:
 # /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
If you look at the line "USE_DHCP[0]=" you'll see that by default it is already answered for you as "Yes" if you chose DHCP during Slackware Installation. This means if your router is set to DHCP, where it dispenses leases on IPs (complete with Netmask, and Gateway) you're done! It will just boot up and connect ba-da-boom, ba da bing! If instead you prefer static just put the numbers in there in the provided spaces and change "yes" to "no".

All the preliminary scary stuff was just to demonstrate how easy it can be if you knew ahead of time, during installation, what manner of connection you would have, defined by how your router is setup. It's not rocket surgery. It just require you be willing to learn a little something at least about nomenclature of TCPIP terms.

I sincerely hope the clock telling me it is 2AM isn't sniggering at my foggy brain and I have managed to help you some. In any case, best wishes and hope you stick with Slackware...it's worth the learning curve many times over.

Last edited by enorbet; 01-02-2014 at 01:57 AM. Reason: punctuation
 
2 members found this post helpful.
Old 01-02-2014, 02:06 AM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Welcome to LQ!

Your internet router is almost certainly configured to act as a DHCP server.

1. Connect router and Slackware desktop with ethernet cable after powering down both devices.
2. Turn on router.
3. Turn on Slackware desktop, (booting to runlevel 3 and a login prompt which is the install default), and log in as root.
4. Type 'netconfig' and hit Enter.
5. A box will open titled "ENTER HOSTNAME". This will become the name of your Slackware desktop on your network. I suggest something short, 8 characters or less.
6. A box will open titled "ENTER DOMAINNAME for '<your hostname choice>'. In a home network this can be your choice. I use 'home.net.au'.
7. A box will open titled "CONFIGURATION TYPE FOR '<your hostname choice>.<your domainname choice>'. Select DHCP.
8. A box will open titled "SET DHCP HOSTNAME". Just hit Enter.
9. A box will open titled "CONFIRM SETUP COMPLETE". Select Yes.
10. A box will open saying "Settings accepted. Basic network configuration is complete." Hit Enter.
11. The root command prompt will reappear.
12. Type '/etc/rc.d/rc.inet1 restart' and hit Enter.
You should see something like this:
Code:
Polling for DHCP server on interface eth0:
dhcpcd[1292]: version 6.0.5 starting
dhcpcd[1292]: eth0: soliciting an IPv6 router
dhcpcd[1292]: eth0: soliciting a DHCP lease
dhcpcd[1292]: eth0: offered 10.1.1.2 from 10.1.1.1
dhcpcd[1292]: eth0: leased 10.1.1.2 for 86400 seconds
dhcpcd[1292]: eth0: adding host route to 10.1.1.2 via 127.0.0.1
dhcpcd[1292]: eth0: adding route to 10.1.1.0/24
dhcpcd[1292]: eth0: adding default route via 10.1.1.1
dhcpcd[1292]: forked to background, child pid 1331
Enjoy!
 
2 members found this post helpful.
Old 01-02-2014, 08:11 AM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,153

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Welcome to LinuxQuestions.

By default Windows 7 ICS will use the 192.168.137.x subnet and has a built in DHCP server.
http://windows.microsoft.com/en-us/w...#1TC=windows-7

Follow the other posts for setting up the network connection on your slack box with DHCP and you should be good to go.
 
Old 01-05-2014, 09:10 PM   #5
Barking Shark
LQ Newbie
 
Registered: Jan 2014
Location: Pennsylvania
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
First of all, thank you all for your quick and full replies. I feel a lot more comfortable about learning how to use Slackware knowing there's a very supportive community out there. Reading your responses, I found that I learned about both how Slackware handles networking and certain concrete steps I could take to connect to the internet. That said, this pesky network configuration problem doesn't seem to want to go away, so I'll address the results of trying the above suggestions.
Quote:
Maybe there are others on here who will help you "paint by numbers" and I'll take a stab at it, but I can't help but wonder why you chose Slackware when the Ubuntus (and just about everybody else) does all that stuff for you with Windows-like "wizards". The simple facts are that it is faster to do networking by command line and this implies at least some basic knowledge of commands and locations of pertinent files.
You're completely right in wondering about that, because I sometimes wonder about it myself. I knew perfectly well that using Ubuntu or another distro would be a lot easier considering my lack of basic knowledge, but I still chose to use Slackware for two reasons: (1) by making the learning curve very steep, I hoped to gain much more from the learning experience, and (2) I hoped that I would find good documentation and helpful and knowledgeable people in forums like this. So far, I have found both my assumptions to be correct, as I've learned a lot already about vi, router settings, the command line, and much much more; and all of your in-depth answers have shown that there is a community of interested and caring people out there.

Quote:
"/etc/resolv.conf" corresponds to the DNS boxes in a windows-like Network Device TCPIP section
This file seems to be entirely blank, except for the domain name I chose when I tried allend's solution. When I first looked at the file, it only had two commented lines, saying something like "/etc/rc.d/rc.inet1.conf.head could be replaced here" and "/etc/rc.d/rc.inet1.conf.tail could be replaced here"

Quote:
The easiest way for a beginner to setup an ethernet driven Internet connection is to simply edit 2 files, the aforementioned "/etc/resolv.conf" and "/etc/rc.d/rc.inet1.conf"
When I took a look at the /etc/rc.d/rc.inet1.conf file, the "USE_DHCP[0]" option was already set to "yes", (and my router is set to DHCP)so the connection should've worked the first time around. I also tried setting eth1, 2, and 3 to yes, to no avail.

Quote:
1. Connect router and Slackware desktop with ethernet cable after powering down both devices.
I can't connect my desktop to the router directly, but I followed the steps, only to get an error message indicating a timeout when the connection failed.

On my Windows 7 machine, I have enabled sharing the wireless connection and have set the both TCP/IPv4and TCP/IPv6 to "Obtain an IP address automatically".

Thank you all for your help, and I hope this is just a simple problem that can easily be fixed (because after that comes package management!).
 
Old 01-05-2014, 11:00 PM   #6
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,577

Rep: Reputation: 468Reputation: 468Reputation: 468Reputation: 468Reputation: 468
How are you connecting your slackware machine to the Windows machine?

A direct ethernet connection (running a cable directly from one machine to another) won't work unless you are using a special cable.

Last edited by Richard Cranium; 01-06-2014 at 12:03 AM. Reason: Moved right paren so the sentence makes some sense. Duh.
 
1 members found this post helpful.
Old 01-05-2014, 11:11 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,153

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Good point. Depends on the age your computer/ethernet adapters. Most these days are able to auto detect a connection. If you do not see any link lights on the adapters then you need a ethernet crossover cable.
 
2 members found this post helpful.
Old 01-06-2014, 07:24 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,451
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Member Response

Hi,

Welcome to LQ & Slackware!

Barking Shark, look at Slackware Doc Project & http://slackbook.org/beta/

Look at my sig for more useful links.

Hope this helps.
 
Old 01-06-2014, 09:56 AM   #9
Barking Shark
LQ Newbie
 
Registered: Jan 2014
Location: Pennsylvania
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
A direct ethernet connection (running a cable directly from one machine to another) won't work unless you are using a special cable.
I am using an enhanced CAT5 ethernet patch cable, so not a crossover cable according to my googling. The cable, however, worked perfectly fine when I had Windows running on both machines. Is the problem then in the way that the Linux machine interprets the data coming across the cable?

Quote:
Depends on the age your computer/ethernet adapters. Most these days are able to auto detect a connection. If you do not see any link lights on the adapters then you need a ethernet crossover cable.
The laptop is fourish years old and the desktop 10 (old, but not that old). Both adapters have lit link lights.
 
Old 01-06-2014, 10:33 AM   #10
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,577

Rep: Reputation: 468Reputation: 468Reputation: 468Reputation: 468Reputation: 468
Quote:
Originally Posted by Barking Shark View Post
I am using an enhanced CAT5 ethernet patch cable, so not a crossover cable according to my googling. The cable, however, worked perfectly fine when I had Windows running on both machines. Is the problem then in the way that the Linux machine interprets the data coming across the cable?
No, this should be at the hardware level. If it worked for one OS, it should work for another.

In your case, consider my cable comment to be a red herring. Sorry for the noise.
 
Old 01-06-2014, 10:38 AM   #11
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,577

Rep: Reputation: 468Reputation: 468Reputation: 468Reputation: 468Reputation: 468
What is the output of the following command when run as root from a terminal?
Code:
lspci | grep -i ethernet
 
Old 01-06-2014, 12:56 PM   #12
Barking Shark
LQ Newbie
 
Registered: Jan 2014
Location: Pennsylvania
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Code:
01:01.0 Ethernet Controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
 
Old 01-06-2014, 04:03 PM   #13
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,577

Rep: Reputation: 468Reputation: 468Reputation: 468Reputation: 468Reputation: 468
Quote:
Originally Posted by Barking Shark View Post
This file seems to be entirely blank, except for the domain name I chose when I tried allend's solution. When I first looked at the file, it only had two commented lines, saying something like "/etc/rc.d/rc.inet1.conf.head could be replaced here" and "/etc/rc.d/rc.inet1.conf.tail could be replaced here"
A standard DHCP server should provide the information for your DHCP client to fill this in automatically. The DHCP server that is underneath Windows 7 ICS may not provide that information.



Quote:
When I took a look at the /etc/rc.d/rc.inet1.conf file, the "USE_DHCP[0]" option was already set to "yes", (and my router is set to DHCP)so the connection should've worked the first time around.
If your desktop was connected to your router, that would apply. However, you are connecting to your Windows 7 box and that is what will provide DHCP services for your linux desktop.


Please change the line
Code:
DEBUG_ETH_UP="no"
in /etc/rc.d/rc.inet1.conf to be
Code:
DEBUG_ETH_UP="yes"
and enter the following command as root:
Code:
/etc/rc.d/rc.inet1 restart
You should see something along the lines of...
Code:
# /etc/rc.d/rc.inet1 restart
Polling for DHCP server on interface eth0:
dhcpcd[9088]: version 6.0.5 starting
dhcpcd[9088]: eth0: soliciting an IPv6 router
dhcpcd[9088]: eth0: soliciting a DHCP lease
dhcpcd[9088]: eth0: offered 172.16.1.54 from 172.16.1.1
dhcpcd[9088]: eth0: leased 172.16.1.54 for 3600 seconds
dhcpcd[9088]: eth0: adding host route to 172.16.1.54 via 127.0.0.1
dhcpcd[9088]: eth0: adding route to 172.16.1.0/24
dhcpcd[9088]: eth0: adding default route via 172.16.1.1
Stopping NTP daemon...
Starting NTP daemon:  /usr/sbin/ntpd -g
Saving system time to the hardware clock (localtime).
dhcpcd[9088]: forked to background, child pid 9153
...but if you did, you wouldn't be having any problems. There should also be useful logs in /var/log/messages and /var/log/syslog.
 
Old 01-06-2014, 08:52 PM   #14
Barking Shark
LQ Newbie
 
Registered: Jan 2014
Location: Pennsylvania
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
I obviously can't copy and paste from the Slackware machine onto here, so I'll attach these more manual screenshots. I also just noticed that there's an icon on the Xfce desktop that says "Ethernet Network | Wired connection 1". I'm not entirely sure which are the important bits from the /var/log/messages and /var/log/syslog log files, but I attached what seemed to be relevant. Please let me know if there's something I should be looking out for, and thank you once again for your dedication to solving this problem.
Attached Images
File Type: jpg IMG_3413[1].jpg (257.6 KB, 13 views)
File Type: jpg IMG_3414[1].jpg (288.2 KB, 11 views)
File Type: jpg IMG_3415[1].jpg (282.8 KB, 11 views)
 
Old 01-07-2014, 12:09 AM   #15
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,577

Rep: Reputation: 468Reputation: 468Reputation: 468Reputation: 468Reputation: 468
Ah. Do you intend to use NetworkManager to connect or by editing /etc/rc.d/rc.inet1.conf? The two mechanisms are different.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows ICS & ad-hoc WiFi cumptrnrd Linux - Wireless Networking 1 03-07-2006 02:05 AM
Windows 2000 ICS -> Slackware 10.1 Mephator Linux - Networking 4 10-28-2005 03:46 PM
Home Network Help (Slackware 10 laptop and Windows Desktop) Corallis Linux - Networking 0 07-03-2004 04:32 PM
Slackware, Windows xp detecting hardware and ICS? Volcom Linux - Networking 3 07-07-2003 10:57 AM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration