LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2005, 09:00 PM   #1
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
i will disable this x-server for now... back to console?


hello all,

ok i misconfigured my xorgconfig file. not sure WHY though, since i did select the nvidia geforce driver (number 349) on a fresh slack 10.1 install, and all other settings came from my hardware manual. oh well.

my problem now is not fixing this (at least not yet), the problem i have must be the noobiest question ever asked.

on reboot, i get the Xserver starting and a message in a gui-ish dos-shis window:

"i will disable this x-server for now" (looks like a schwarzenegger movie sentence... "i'll be back")

when i check the log, i see the

"(EE) No devices detected"
"Fatal server error: no screens found"


SO: i click OK, the server gets disabled... and me?! well i get back to where the log was

starting up the X-server

and i have a blank cursor flashing on a black screen under the booting log, with no bash prompt. i can type anything on the screen but get no answers. how can i login as root then? no commands seem to be recognized. i can type. nice indeed.

any ideas on HOW can i get my hands on a prompt so to login as root and reconfigure my server?

Last edited by acidjuice; 02-17-2005 at 09:02 PM.
 
Old 02-17-2005, 09:08 PM   #2
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Have you tried switching virtual consoles? I think runlevel 4 leaves one open at tty6 (to switch to it hit ALT+F6 or CTRL+ALT+F6 if you want to make sure that X doesn't get in your way).

Last edited by alienDog; 02-17-2005 at 09:10 PM.
 
Old 02-17-2005, 09:18 PM   #3
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
i have only tried Alt ( +Ctrl also) +F1 to F4:

F1 is locked showing the boot log
F2 shows the "i will disable the terminator server"
F3 black screen with cursor on top, can't type anything
F4 same as F3

you are sure i can try to get in at F6? that would be good news. before i reboot: what when i'm there? will i have a login prompt?

thank you
 
Old 02-17-2005, 09:33 PM   #4
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
hello, i finally managed to reset my X server by typing in console X -config and then using the freshly generated xorg.config.new file under &root to replace the existing one under /etc/X11/.

now: i ve read that i should run xorgconfig to setup my card, but this destroys my xorgconfig file. and i don-t know why. should i FIRST download and install NVIDIA drives prior setting up xorg?

any help welcomed... thank you, really this is appreciated
 
Old 02-17-2005, 09:34 PM   #5
frzburn
Member
 
Registered: Feb 2004
Location: Canada
Distribution: FreeBSD
Posts: 38

Rep: Reputation: 15
As this is a frash installation, I suppose the nvidia module is installed.
So your problem is probably your screen frequency configuration.
Generally, the #8 option, smething like "Monitor that can do 1280x1024 @ 60 Hz" sould do it.
Enter you horizontal frenquency (40-100 should do).
Try and install NVidia drivers from their site.
To boot at console, boot using your install CD following the instructions, and change yout /etc/inittab. At the top of the file, comments say how to boot in multiuser mode. The line should look like :
Code:
id:3:initdefault:
Good luck!
 
Old 02-17-2005, 09:43 PM   #6
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
thnk you... this is a start, seems a long way to go...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you disable console mode? shuego Debian 8 12-08-2005 07:50 PM
Console screensaver won't disable jev-bird Linux - Software 0 10-13-2004 01:51 PM
How to disable console output kamel Programming 2 06-02-2004 02:41 PM
Disable the console beep? csvke Linux - General 6 03-01-2004 05:00 AM
Booting up in X server... how do I disable it or fall back to console mode? Delmarc Linux - Newbie 3 09-06-2003 09:23 PM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration