LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2005, 02:20 PM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
i think i broke my libtool


Damn it,

All i want is some bloody visualizations...

I've tried adding '/usr/lib' to /etc/ld.so.conf , typed ldconfig, and the viz didnt work, untill i noticed i had to install another package.

Now everytime i want to compile anything, i get this error in make,

Code:
lv_error.lo lv_ui.lo lv_thread.lo lv_object.lo lv_transform.lo  -lm -ldl  -L. -L/usr/lib
libtool: link: cannot find the library `'
make[2]: *** [libvisual.la] Error 1
make[2]: Leaving directory `/home/d/Download/amarok viz/libvisual-0.2.0/libvisual'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/d/Download/amarok viz/libvisual-0.2.0'
make: *** [all] Error 2
I've removed /usr/lib from /etc/ld.so.conf, reinstalled pkgconfig, reinstalled libtool, rebooted, but still i keep getting this error when i try to compile anything on my machine...

EDIT:
Sorry, after the reboot, only libvisual has the problem (tried compiling nano, and make worked this time).

I guess one of the moderators can close this thread so i can start a similar one in software (for libvisual), unless someone knows a solution for it

EDIT::::: Solved
Nevermind.. Turns out it didn't like having a space in the name 'amarok viz' ... But what a way to find out.

Erm, if any moderator wishes to remove this thread i have no objections..

Last edited by xushi; 03-15-2005 at 02:32 PM.
 
Old 03-15-2005, 02:42 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
That sounds like a configuration script bug: perhaps not quoting things correctly.
 
Old 03-15-2005, 02:51 PM   #3
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
So you think its something worth mentioning to the developers?
 
Old 03-15-2005, 02:55 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Do not remove this thread, it can be useful for someone who has the same prob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do one need in libtool? Ygrex Programming 1 11-01-2005 07:31 AM
libtool and pango kernelhacker Linux - Software 4 05-21-2005 02:48 AM
degrading libtool yonderstar Linux - Software 0 04-15-2004 03:24 PM
how do I uninstall libtool? dcardena Linux - Newbie 3 07-10-2003 01:21 PM
how do I uninstall libtool? dcardena *BSD 0 07-10-2003 01:11 PM


All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration