LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-04-2005, 11:56 AM   #1
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
I know this botheres you all, but I need "full duplex" (point at least the HowTo)


Yes, I know you answered many times to this q, but I was searching for an hour about listenning to more than one audio channel in this forum, then looked at LQ tutorials, then "How I do it all" (the first page). I don't understand: if this q appears to EVERY newbie, why people who knows the solution don't make a mini HowTo? (or if you know one - please tell me the address) I found in some thread a link to alsa-project.org/.../software mixing. There's a code to add to .asoundrc. I searched all my mount points (except /mnt ), but didn't find smth similar. So I ask you to answer this topical annoying q. And please check link before posting 'em: while searching I found some 'wize' man who advised not valid link. Thanks if you answer.
_________________
I just want playing more than xmms at a time... please post a valid reply.
_________________
Growing old - mandatory,
growing up - optional.
 
Old 02-04-2005, 12:01 PM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Did you set audio output plugin to alsa in xmms preferences (right click on xmms) ?
 
Old 02-04-2005, 12:28 PM   #3
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
Yes.
Also someone was told to use 'esd'. But if I run it i get:
root@darkstar:~# esd
Audio device open for 44.1Khz, stereo, 16bit failed
Trying 44.1Khz, 8bit stereo.
Audio device open for 44.1Khz, stereo, 8bit failed
Trying 48Khz, 16bit stereo.

So can anybody help me??? I again ask for any Howto covering this q.
 
Old 02-04-2005, 12:35 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
You need to create a ~/.asoundrc file with the contents suggested in :
http://www.alsa-project.org/alsa-doc...tel8x0#softmix

After that make sure that alsa outplug plugin configuration is set to default, that should work

Last edited by keefaz; 02-04-2005 at 12:36 PM.
 
Old 02-04-2005, 01:02 PM   #5
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
Did smth, but now if I press play button on xmms I get the message that I should check if soundcard is configures properly, if I have the correct output plugin, if no other app blocks the sound dev. If I choose OSS drv back music is played, but xine still don't plays music. AND I DON'T KNOW HOW TO SET ALSA OUTPUT PLUGIN TO DEFAULT (and how to know it). Help again, please.
 
Old 02-04-2005, 01:24 PM   #6
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
In xmms:
- right click > options > preferences
- set output plugin to ALSA
- click on configure button near the bottom
- look at audio device, it should be set to default, click OK
- In case you can't open multiple instance of xmms, go to options tab and check "allow
multiple session"

Now I assume you did create ~/.asoundrc with the contents from the link I posted
try :
xmms &
xmms &
and play one with a sound, then play on the other with the same sound or another
 
Old 02-04-2005, 01:44 PM   #7
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
I did it. But the same window appears telling me to check... If i choose not default, but intelAC'97 sound is played but again alone. Here's my console:
root@darkstar:~# xmms
ALSA lib pcm_dmix.c:868snd_pcm_dmix_open) unable to open slave

** WARNING **: alsa_setup(): Failed to open pcm device (default): No such device

I haven't such module???
 
Old 02-04-2005, 02:15 PM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Your ~/.asoundrc should be :
Code:
pcm.!default {
    type plug
    slave.pcm "dmixer"
}


pcm.dmixer  {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
}

ctl.dmixer {
    type hw
    card 0
}
That's all, nothing else or maybe play with the value for pcm "hw:0,0" (like 1,0)
 
Old 02-05-2005, 10:50 AM   #9
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
Thank you very much, keefaz! But problem was that, on alsa site, is pcm "hw:1,0", not as you pointed: pcm "hw:0,0"! I don't understand why there's incorrect info??? Or this is because of Slack? Or because of my intelAC'97? Goddamn! Of course, I should look a bit more at the .asoundrc, but... I really don't understand whether it is mistake on alsa site, or ... as above. So really thanks for "stupid" copying of probably your .asoundrc But this became not stupid.
ADVICE TO MODERATORS: make a mini HowTo about it, in your 'Tutorials' menu!!! It'll save much time for EVERY (at least Slack's) newbie. It can contain: create .asoundrc in ~ with the above (prev. post) contents; choose alsa as default output plugin in xmms.
_____________________________
incorrect info on alsa site?..
 
Old 02-05-2005, 11:04 AM   #10
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
Smile

Guys! Now's another "problem". I run xmms, "run" music. If I press pause button, then resume (don't restart!) playing - xmms doesn't play!!! Is it xmms' bug??? xine, e.g., works correctly. Or is this again smth with alsa??? That's not a real problem, but a real q...
EDIT: Hey, that's really xmms' bug! It stops playing even when I launch kppp! And VMware too. Bug, bug, bug... Again: xine works perfectly! xmms is not so good as I thought.
EDIT2: smth incredible happens: I've just run kppp while xmms was playing, and all's ok!!! May be error was because of VMware? But "pause errors" (see above) still occur!
EDIT3: really incredible! Now when I start kppp while xmms is playing, xmms stops again... hmm...

Last edited by kornerr; 02-05-2005 at 01:14 PM.
 
Old 02-05-2005, 01:56 PM   #11
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
Yes, I'm a real fool! I again looked a bit more at output plugin settings. Now xmms doesn't stop after I press pause button (see above). I just unselected 'Mmap mode' in ALSA output plugin settings. I was wrong - xmms is perfect!!! (and xine too)
___________________
LQ is the best site with the best people Thanks to all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
howto half/full duplex eth0 mickeyboa Fedora 2 02-25-2009 08:36 AM
"Refer To" option to point questioners to existing discussion/material sboddy LQ Suggestions & Feedback 6 12-01-2005 03:14 AM
Please point to the right "M" so I can "RTFM" floog Linux - Networking 3 03-24-2005 06:28 PM
Howto disable "Graphical Login" or "Standard Login?" the_gripmaster Red Hat 1 07-08-2004 03:55 PM
"Can't resolve mount point ..." - Mandrake 9.2 to WinXP host funcii Linux - Newbie 3 02-27-2004 02:17 PM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration