LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   i just want to listen to music (http://www.linuxquestions.org/questions/slackware-14/i-just-want-to-listen-to-music-57058/)

airWave 04-27-2003 07:27 PM

i just want to listen to music
 
Hi
I have an msi mobo with an onboard Realtek Avance sound card. When i start x in slack 9 i get the error "Couldnt open mixer device /dev/sound/mixer" Ive looked in /dev .. there is no directory named sound but there is /dev/mixer

bash-2.05b# ln -s /dev/sound/mixer /dev/mixer
ln: `/dev/mixer': File exists
bash-2.05b# ln -s /dev/mixer /dev/sound/mixer
ln: creating symbolic link `/dev/sound/mixer' to `/dev/mixer': No such file or directory

bash-2.05b# cp mixer /dev/sound
cp: cannot open `mixer' for reading: No such device

ive tried linking and making a directory to put mixer in and it wasnt working so then i tried modprobing ...

bash-2.05b# modprobe realtek
modprobe: Can't locate module realtek
bash-2.05b# modprobe avance
modprobe: Can't locate module avance

ok .. now i dont know what to do
O_O

any help would be greatly appreciated

-=airWave=-

Tinkster 04-27-2003 08:58 PM

I seem to recall that this would be
modprobe ac97_codec
modprobe ac97_audio

If it's not it, give me the exact type
of your mobo and I'll grep through my
kernel sources :D

Cheers,
Tink

Aussie 04-27-2003 11:57 PM

Do "lspci -vv" to ID the sound controller.

airWave 04-28-2003 01:33 AM

Tink: modprobe ac97 and modprobe ac97_codec both worked but modprobe ac97_audio did not.
My board is a MSI K7T266 Pro2.

Bern: what a great command!^_^

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 10)
Subsystem: Avance Logic Inc.: Unknown device 4710
Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin C routed to IRQ 10
Region 0: I/O ports at e800 [size=256]
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

So after i have modprobed what is the next step? Do I have to add the modual to /etc/moduals.conf or moduals.devfs. or am I way off?

Thanks alot btw for your timely replies :)

lss223 04-28-2003 01:43 AM

What I suggest is:

Add this to /etc/rc.d/rc.modules

/sbin/modprobe ac97
/sbin/modprobe via82cxxx_audio


Then reboot. :) It should get it up and running.

Have fun!

r_jensen11 04-28-2003 03:22 PM

Soundcard not listed...
 
My soundcard isn't even listed... I typed in lspci to get a list of all of the devices and I got this list:
Hostbridge
ISA Bridge
IDE interface
USB controller
VGA compatible controller
Ethernet controller

Why wouldn't my soundcard be listed? I mean, it even worked in WinME, ME!!!

hecresper 04-28-2003 05:05 PM

I have an MSI KT4VL board which comes with the VIA 82xxx sound chipset. For it to work in Slackware, you have to take a trip to www.alsa-project.org and get the needed files from there. Look under the sound card matrix, find the via82cxxx link and follow the installation instructions. Keep us posted as to your progress. Have fun! I did! ;)

airWave 04-28-2003 10:03 PM

This is what happens when i try to make the alsa drivers. the utilities and the libraries installed fine. Im on a desk top so i dont see how these could matter but it wont work without them.

vxpocket.h:26:29: pcmcia/cs_types.h: No such file or directory
vxpocket.h:27:23: pcmcia/cs.h: No such file or directory
vxpocket.h:28:27: pcmcia/cistpl.h: No such file or directory
vxpocket.h:29:23: pcmcia/ds.h: No such file or directory
vx_entry.c:29:28: pcmcia/ciscode.h: No such file or directory
vx_entry.c:30:27: pcmcia/cisreg.h: No such file or directory
In file included from vxp440.c:14:
vxpocket.c:35:28: pcmcia/version.h: No such file or directory
In file included from vxpocket.c:36,
from vxp440.c:14:
vxpocket.h:26:29: pcmcia/cs_types.h: No such file or directory
vxpocket.h:27:23: pcmcia/cs.h: No such file or directory
vxpocket.h:28:27: pcmcia/cistpl.h: No such file or directory
vxpocket.h:29:23: pcmcia/ds.h: No such file or directory
In file included from vxp_mixer.c:29:
vxpocket.h:26:29: pcmcia/cs_types.h: No such file or directory
vxpocket.h:27:23: pcmcia/cs.h: No such file or directory
vxpocket.h:28:27: pcmcia/cistpl.h: No such file or directory
vxpocket.h:29:23: pcmcia/ds.h: No such file or directory
In file included from vxp_ops.c:30:
vxpocket.h:26:29: pcmcia/cs_types.h: No such file or directory
vxpocket.h:27:23: pcmcia/cs.h: No such file or directory
vxpocket.h:28:27: pcmcia/cistpl.h: No such file or directory
vxpocket.h:29:23: pcmcia/ds.h: No such file or directory
vxpocket.c:35:28: pcmcia/version.h: No such file or directory
In file included from vxpocket.c:36:
vxpocket.h:26:29: pcmcia/cs_types.h: No such file or directory
vxpocket.h:27:23: pcmcia/cs.h: No such file or directory
vxpocket.h:28:27: pcmcia/cistpl.h: No such file or directory
vxpocket.h:29:23: pcmcia/ds.h: No such file or directory
make[3]: *** [fastdep] Error 1
make[3]: Leaving directory `/usr/src/alsa/alsa-driver-0.9.2/pcmcia/vx'
make[2]: *** [_sfdep_vx] Error 2
make[2]: Leaving directory `/usr/src/alsa/alsa-driver-0.9.2/pcmcia'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-0.9.2'
make: *** [include/sndversions.h] Error 2

Ideas?
airWave

Excalibur 04-28-2003 10:38 PM

I think you need to download the kernel source package and install it. It looks like it is looking for the kernel header files.

hecresper 04-29-2003 12:05 AM

Quote:

Originally posted by Excalibur
I think you need to download the kernel source package and install it. It looks like it is looking for the kernel header files.
Oops! Yep, what he said!:eek:


All times are GMT -5. The time now is 11:17 PM.