LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2005, 08:48 PM   #1
nutbag
LQ Newbie
 
Registered: Jul 2005
Location: ventura ca
Distribution: FreeBSD 6.1 and Debian etch
Posts: 23

Rep: Reputation: 15
Question I can't get from gui back to console


I'm a newbie, running the box 2.4.29 kernel, slack 10.1. my problem is i can't stop x and get back to a console to shutdown my computer. I've tried ctrl-alt- bckspce, ctrl-alt-F6, F5...etc. I' also tried using the login manager ie exit, logout. I' ve tried switching window managers and every time I get the same result which is a blackscreen. I had the opposite problem when I first installed, all I got in the beginning was blackscreen. My computer doesn't freeze it just goes black. I can still ctrl-alt-del to shutdown but I'd like to see it happen. Any suggestions would be appreciated. Where do I check for error messages. I looked through the forums for a similar problem without luck. This is my first post, usually I find an answer in thee forums, thanks in advance.
 
Old 07-20-2005, 09:06 PM   #2
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
Re: I can't get from gui back to console

Quote:
Originally posted by nutbag
I'm a newbie, running the box 2.4.29 kernel, slack 10.1. my problem is i can't stop x and get back to a console to shutdown my computer. I've tried ctrl-alt- bckspce, ctrl-alt-F6, F5...etc. I' also tried using the login manager ie exit, logout. I' ve tried switching window managers and every time I get the same result which is a blackscreen. I had the opposite problem when I first installed, all I got in the beginning was blackscreen. My computer doesn't freeze it just goes black. I can still ctrl-alt-del to shutdown but I'd like to see it happen. Any suggestions would be appreciated. Where do I check for error messages. I looked through the forums for a similar problem without luck. This is my first post, usually I find an answer in thee forums, thanks in advance.
have you tried changing /etc/initab to 3 ? Do a reboot after the change

http://www.slackbook.org/html/x-window-system-xdm.html
 
Old 07-20-2005, 10:41 PM   #3
nutbag
LQ Newbie
 
Registered: Jul 2005
Location: ventura ca
Distribution: FreeBSD 6.1 and Debian etch
Posts: 23

Original Poster
Rep: Reputation: 15
Unhappy

/etc/inittab is set to 3, any other suggestions please?
 
Old 07-21-2005, 01:12 AM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You don't need to go out of X to shutdown, just open a xterm (or Eterm, aterm, Konsole, gnome-terminal, whatever you use) and run the command.
I've had those problems when using framebuffer in text-mode, which lead me to a lot of screen crashes, you can disable it setting vga=normal in LILO.
 
Old 07-21-2005, 02:58 AM   #5
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
in /etc/X11/xorg.conf
in Section "Server Flags" add the line
Option "HandleSpecialKeys" "always"
 
Old 07-21-2005, 10:27 PM   #6
nutbag
LQ Newbie
 
Registered: Jul 2005
Location: ventura ca
Distribution: FreeBSD 6.1 and Debian etch
Posts: 23

Original Poster
Rep: Reputation: 15
Unhappy

I added the handlespecialkeys option and the same thing happened. I checked vga=normal and it is the current setting. I have shutdown from Eterm and I get recursive a shutdown line that "crashes to a blank terminal that I can't see to read. It's a little frustrating. If I use the shutdown -h command I can't see if it happens so I'm stuck with reboot, that way I at know slack has shutdown. It would be a lot easier if I could read it. I prefer not to boot into init 4, if anyone else has had this problem I would love to hear from you.
 
Old 07-21-2005, 10:31 PM   #7
slackwarefan
Member
 
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Rep: Reputation: 30
You might try just killing it if it's really so important.

killall X
or
killall gdm-binary
or whatever applies to you
 
Old 07-21-2005, 10:55 PM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Maybe you configured vga=normal in LILO but didn't update lilo after that. Run as root: /sbin/lilo -v
That should update LILO, hopefully you'll reboot and see the console.
You could also try using a different driver for X like the generic vesa and see if your console crashes or not with it, maybe it's a driver issue.

Last edited by gbonvehi; 07-21-2005 at 11:08 PM.
 
Old 07-22-2005, 04:24 AM   #9
E.T.Me
Member
 
Registered: Aug 2004
Location: N.E.Texas
Distribution: Fedora-14
Posts: 42

Rep: Reputation: 15
Are you using the NVIDIA vidio drivers???

If you are,your system isn't crashing,your monitor is shuting off because of no signal. I'm having the same problem and I've learned to type "in the dark" after closing out the KDE desktop. From there everything is typed "in the dark". I just wait a second or two before I type the next entry. It's a pain,but it works for me.....

Just a thought...
My two cents.......
and all that other good stuff....
 
Old 07-22-2005, 04:58 AM   #10
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,192

Rep: Reputation: 101Reputation: 101
I use the nVidia drivers for my GeForce FX5200 and don't have these problems, though I don't know what to suggest to fix it.
 
Old 07-24-2005, 08:03 AM   #11
kill_ads
LQ Newbie
 
Registered: Jul 2005
Posts: 5

Rep: Reputation: 0
ctrl-alt- backspace can not back to console,it will back to gdm/xdm
If you want to back to console,you can start a term ,such as "xterm" ,and input "init 3"
 
Old 07-24-2005, 08:16 AM   #12
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,353

Rep: Reputation: 74
nutbag, could you post the output with lsmod ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i will disable this x-server for now... back to console? acidjuice Slackware 5 02-17-2005 08:43 PM
X locking when switching back to console jfall Linux - Hardware 1 02-08-2005 03:51 PM
can't get back to GUI Haldanite Linux - General 2 06-28-2003 10:10 PM
How do I back out of ctrl-Z in console vofkid Linux - Newbie 3 03-18-2002 06:28 AM
cant get back to KDE from console shell TheMentat Linux - General 4 08-04-2001 04:22 PM


All times are GMT -5. The time now is 04:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration