LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-06-2014, 11:40 AM   #1
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Rep: Reputation: 30
httpd.SlackBuild and /usr/lib/libdb-4.4.la error


I am trying to do httpd package using httpd.SlackBuild http://mirrors.slackware.com/slackwa.../source/httpd/ and Apache 2.2.27.
This is to be for Slackware 12.
My problem is that httpd.SlackBuild ends up with following error referring to libtool and libdb-4.4

Code:
libtool: link: cannot find the library `/usr/lib/libdb-4.4.la'
make[2]: *** [htpasswd] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: cannot find the library `/usr/lib/libdb-4.4.la'
make[2]: *** [htdigest] Error 1
libtool: link: cannot find the library `/usr/lib/libdb-4.4.la'
make[2]: *** [rotatelogs] Error 1
make[2]: Leaving directory `/tmp/httpd-2.2.27/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/httpd-2.2.27/support'
make: *** [all-recursive] Error 1
However, libdb-4.4.so is already installed in my system.

Code:
# grep libdb-4 /var/log/packages/*
/var/log/packages/aaa_elflibs-12.0.0-i486-3:lib/libdb-4.2.so
/var/log/packages/aaa_elflibs-12.0.0-i486-3:lib/libdb-4.4.so
Can anyone advice what to do ?

Last edited by czezz; 05-06-2014 at 11:42 AM.
 
Old 05-06-2014, 11:57 AM   #2
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 299

Rep: Reputation: 179Reputation: 179
Hello,

I guess you need the package db44 which contains libdb-4.4.la

--
SeB
 
1 members found this post helpful.
Old 05-06-2014, 12:39 PM   #3
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
yup, you are right
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OPENNMS INSTALLATION ERROR -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 4 07-11-2011 01:06 PM
opennms installation error -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 2 07-08-2011 11:51 AM
fbreader.SlackBuild uses /usr/lib in x86_64 gapan Slackware 6 01-13-2010 05:42 PM
Starting httpd: /usr/sbin/httpd: symbol lookup error: /usr/local/lib/libaprutil-0.so. bijuhpd Linux - Newbie 1 10-30-2005 06:07 PM


All times are GMT -5. The time now is 03:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration