LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-26-2012, 06:47 PM   #1
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Rep: Reputation: 0
HP Printer not working properly after last -current


My HP F2050 its not working right after upgrading to the last batch updates in current. I'm running x86_64 multilib current alienbob KDE 4.8.4

The printer is detected and configured in cups.
But hp admin isn't showing in my tray any more. When running hp-toolbox in console get this:

Code:
~$ hp-toolbox 

HP Linux Imaging and Printing System (ver. 3.12.6)
HP Device Manager ver. 15.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-toolbox requires GUI support. Exiting.
until yesterday, before the update, worked just fine

Any clue?
 
Old 06-26-2012, 07:33 PM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,236

Rep: Reputation: 176Reputation: 176
Have you installed today's updates and rebuilds?
 
Old 06-26-2012, 08:34 PM   #3
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cwizardone View Post
Have you installed today's updates and rebuilds?
Just noticed a few minutes ago the updates. I'll check them right now.
 
Old 06-27-2012, 09:19 AM   #4
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Finally upgraded to latest changes and get back the printer manager.
But same problem, prints only half test page and ask for another page to print the second half of the test page.
With a text document it jumps to center page and print only half. Checked the config, page size, orientation and its all good.

Could it be the driver in hplip? or cups problem?
 
Old 06-27-2012, 08:51 PM   #5
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Rep: Reputation: 30
Quote:
Originally Posted by cesarion76 View Post

With a text document it jumps to center page and print only half. Checked the config, page size, orientation and its all good.
Is the same here!

mine is a deskjet 680C, but previously worked well!

Last edited by afreitascs; 06-27-2012 at 08:54 PM.
 
Old 06-28-2012, 02:08 PM   #6
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Rep: Reputation: 30
provide an idea there, please ...
my printer is detected and all, but in print, does not come out properly ...

 
Old 06-28-2012, 10:17 PM   #7
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
After the last updates its working again. Aparently the problem was in the ghostscript package. This is solved
 
Old 06-28-2012, 10:49 PM   #8
afreitascs
Member
 
Registered: Aug 2004
Location: Brasil
Distribution: Slackware_Cur-64_mult
Posts: 433

Rep: Reputation: 30
Quote:
Originally Posted by afreitascs View Post
provide an idea there, please ...
my printer is detected and all, but in print, does not come out properly ...

Solved here too!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error cracking CSS key on current, libdvdcss-1.2.10 not working properly andrewthomas Slackware 13 10-03-2011 10:26 PM
printer is not print properly with only linux machine bharatlalgupta Red Hat 5 12-17-2009 03:15 AM
How can I set up my Printer driver properly? I have the drivers. (slackware v 12.1) bizhub Linux - Hardware 1 04-07-2009 09:49 AM
printer not working properly tm2383 Mandriva 3 01-15-2007 09:47 AM
trying to make lexmark z22 printer properly cjae Linux - Hardware 0 03-23-2006 08:19 PM


All times are GMT -5. The time now is 01:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration