LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   HP Compaq 6720s laptop with Broadcom 4312 wireless (http://www.linuxquestions.org/questions/slackware-14/hp-compaq-6720s-laptop-with-broadcom-4312-wireless-637245/)

Pscylo 04-23-2008 04:43 AM

HP Compaq 6720s laptop with Broadcom 4312 wireless
 
I did post this over in the wireless forum, but I've not had a single response. I don't like to crosspost, but I don't have a great deal of choice. I am aware of somene els who has a BCM4312 working using the B43 cutter tool, so I guess I'm missing a trick. Any help much appreciated.

I'm trying to configure wireless on the setup above.

Lspci reports the following:

10:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 02)
10:00.0 0280: 14e4:4312 (rev 02)

I'm running Slackware current kernel version 12.1 2.6.24.4-smp i686

I've followed the instructions on http://linuxwireless.org/ and used b43 cutter to install firnware for the card. I'm currently trying to get a connection without security before I try and implement security. I can't get a response from http://linuxwireless.org/ at the minute, but I vaguely recall seeing that the 4312 wasn't supported, but I've had some limited success so it may be. I know it can be done with ndiswrapper too, and that may be my next step.

Anyway, as I've mentioned, I think I have some limited success.

If bring up wlan0, ifconfig reports this:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr 00:00:00:1A:73C
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wmaster0 Link encap:UNSPEC HWaddr 00-00-00-1A-73-DC-6C-6F-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

and iwlist scan reports this:

wlan0 Scan completed :
Cell 01 - Address: 00:**:**:**:**:**
ESSID:"*****"
Mode:Master
Channel:5
Frequency:2.432 GHz (Channel 5)
Quality=88/100 Signal level=-47 dBm Noise level=-73 dBm
Encryption keyff
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Extra:tsf=00000010d189a2d5
Cell 02 - Address: 00:**:**:**:**:**
ESSID:"SKY79516"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=55/100 Signal level=-88 dBm Noise level=-73 dBm
Encryption keyn
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=00000002b2b0cd81


which correctly reports my wireless access point as Cell01, and I guess a neighbour's as cell2. I've removed anything that can used to identify. This seems to show it's working to an extent and from this point I don't know whether it's a networking or wireless issue.

I've edited rc.inet1.conf

Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="Pscylo"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=******
WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="5"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

and on startup, it says something about polling for an IP address at which point it says no carrier detected and consequently no connection is made.

I don't know whether I've set the network up wrong, or if it is the card.

If anyone can point me in the right direction even to the point that you can tell me what files I need to look in to troubleshoot I will be extremely grateful. I would post the messages I get on startup, but I don't know where I would find the output. I'm not quite a newby, but I'm still finding my feet a bit.

Ta

P

Ilgar 04-23-2008 05:26 AM

Hi Pscylo,

Why don't you check the following thread which I started:

http://www.linuxquestions.org/questi...e-12.0-636567/

There I explain my trouble starting the wireless service using rc.inet1 but I also explain how I can make it work using console commands. I have an HP dv6400 with the same wireless card as yours.

janhe 04-23-2008 05:42 AM

Quote:

Originally Posted by Pscylo (Post 3130043)
I've edited rc.inet1.conf

Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="Pscylo"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=******
WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="5"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

As far as I've understood, you're trying to connect to a network without encryption. In that case you don't need the WPAPSK line. Maybe commenting it out might help.

Also, "iwconfig" might help you to check what your card's wireless state (access point, encryption, signal strength if applicable) is for the moment. See the man page of iwconfig for more info on using it.

To see some startup messages, I recommend using dmesg

Pscylo 04-23-2008 01:41 PM

Quote:

Originally Posted by Ilgar (Post 3130072)
Hi Pscylo,

Why don't you check the following thread which I started:

http://www.linuxquestions.org/questi...e-12.0-636567/

There I explain my trouble starting the wireless service using rc.inet1 but I also explain how I can make it work using console commands. I have an HP dv6400 with the same wireless card as yours.

Yeah, it was you whom I had seen get it working to a greater extent than I. I can't get an IP address though.

Froma standing start, without encryption, how would I bring the inerface up at the console. I think I did:

ifconfig wlan0 up

after which wlan0 shows for ifconfig, and after which the output from iwlist scan is as above.

Would it be then:#

dhcpcd wlan0

to bring it up?

I tried this and it just hanged at that point and I had to kill the process from a different console.

Have you tried bringing hyour network up without encryption? At least you'll be able to narrow down the error to it either being definitely with wpa_supplicant. It won't help a lot if you get the same error, but if you don't you know that wpa_supplicant is somehow to blame.

That said, I tihnk you'll still get the same result.


Quote:

Originally Posted by janhe (Post 3130086)
As far as I've understood, you're trying to connect to a network without encryption. In that case you don't need the WPAPSK line. Maybe commenting it out might help.

Also, "iwconfig" might help you to check what your card's wireless state (access point, encryption, signal strength if applicable) is for the moment. See the man page of iwconfig for more info on using it.

To see some startup messages, I recommend using dmesg

As it happens that line is commented out in the file; somehow I've managed to delete the hash at the beginning of the line. I don't think it would matter anyhow since all you're doing with that line is setting an environment variable and since wpa_supplicant isn't called it won't be used. Like I say though, it was commented anyhoo.

iwlist scan reports the various statistics you mention (encryption/strength etc). I'll see what iwconfog says the next time I look.

cwwilson721 04-23-2008 03:14 PM

Try the 'wait' command as shown in this post:
http://www.linuxquestions.org/questi...3/#post3130514

Back when I used the bcm chip, I remember having to do that myself.

Pscylo 04-24-2008 12:27 PM

Quote:

Originally Posted by cwwilson721 (Post 3130666)
Try the 'wait' command as shown in this post:
http://www.linuxquestions.org/questi...3/#post3130514

Back when I used the bcm chip, I remember having to do that myself.

Did you mean the "sleep" command? Tried that, didn't make any difference.

HDCPC log shows it's timing out.
Syslog shows the card recognised as a BCM4311, I don'tknow whether that's important or not.

Any further ideas anyone? I think it was iwconfig command that reported the full details of the ap. I did try and force wlan0 to 11g but it "doesn't support the command".

Pscylo 04-25-2008 05:35 AM

Well I got it working.

I have MAC address restriction set on my ap, and for some reason Slack show the MAC address of the card incorrectly.

It reports the address as being: 00:00:00:34:56:78

Where "00" are indeed two zeros, and 34,56,78 are those respective characters from the true MAC address of the card, so it's kin of reporting a minged version of the true MAC. When I added the incorrect MAC address to the trusted MAC section it worked fine.

Is there a setting anywhere that could cause the MAC to report correctly. I've seen someting like that in rc.wireless.conf, but it's not set.

I'll now try and add some security to the connection.

-{Jester}- 04-25-2008 10:13 AM

In case you have not already seen it, you might find the WPA section of this article helpful:

http://www.linuxquestions.org/linux/...r_Slackware_11

I used it to get my Broadcom 4321 with WPA working on Slackware 12.0

Pscylo 04-25-2008 01:05 PM

To be honest, the security was a doddle.

I had already created a wpa_supplicant.conf file before my quest to get a connection commenced. I created the encrypted passphrase using wpa_passphrase (intuitive eh?) and the file had the relevant (and luckily correct) settings.

The only other change I made was in rc.inet1.conf as follows:

uncomment this
WLAN_WPA[4]="wpa_supplicant"

add this line
WPAOPTS="-Dwext -iwlan0 -c/etc/wpa_supplicant.conf"

all works fine now with security at boot time - I have a live connection when I log in.

Just wish I had noticed the munged MAC address a week ago; things would have been far quicker.

cwwilson721 04-25-2008 05:32 PM

Quote:

Originally Posted by Pscylo (Post 3132837)
...

Just wish I had noticed the munged MAC address a week ago; things would have been far quicker.

Sometimes, it's the easier things we overlook.

In your case, it's a case of: "OK, mac address, ok, next line..." We all make assumptions on the 'easy' stuff. I wouldn't think the mac address to be wrong myself.

It just goes to show you...


All times are GMT -5. The time now is 01:03 AM.