LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-27-2008, 08:18 AM   #1
Supporter1984
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware, Slax
Posts: 13

Rep: Reputation: 0
Howto shutdown Slackware correctly


Hi guys, ive been searching around and i havent been able to get a valid final answer on how to properly shutdown my slackware machine.

shutdown -h now | /sbin/poweroff | halt | What?

Any ideas?

Thanks.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-27-2008, 08:31 AM   #2
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,282

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Smile

A little more information would be helpful. So shutdown -h now doesn't work? What happens when you issue that command? I have an aging Plll running Slackware 12.1 and to get it to fully shutdown I need to modify lilo.conf and add acpi=force.

Code:
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0 acpi=force"
boot = /dev/hda

Last edited by hitest; 11-27-2008 at 09:06 AM.
 
2 members found this post helpful.
Old 11-27-2008, 08:32 AM   #3
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
It depends if you are logged in a Command line terminal or in Windows Manager. In UNIX, the best way to shutdown is
Quote:
shutdown -h now
because shutdown has many more options than halt.
 
1 members found this post helpful.
Old 11-27-2008, 08:45 AM   #4
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Code:
su -c poweroff
is what I always use.
Quote:
I need to modify lilo.conf and add acpi=force.
Some of my older machines need this and some ancient ones won't powerdown properly at all !
 
Old 11-27-2008, 08:48 AM   #5
Supporter1984
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware, Slax
Posts: 13

Original Poster
Rep: Reputation: 0
When i use shutdown -h now it comes to an finishing line that says System halted.

Is that allright? Can i power off my machine then?

hitest, what do you mean with "fully shutdown"? You mean it have to go power off by its own?

*sorry for my bad english
 
Old 11-27-2008, 08:55 AM   #6
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,282

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Quote:
Originally Posted by Supporter1984 View Post
When i use shutdown -h now it comes to an finishing line that says System halted.

Is that allright? Can i power off my machine then?

hitest, what do you mean with "fully shutdown"? You mean it have to go power off by its own?

*sorry for my bad english
Yes. You can power down then when it says system halted. If you want it to shut off completely when you issue shutdown -h now you can try to add acpi=force to /etc/lilo.conf with a text editor (see my code above). For example:

# nano etc/lilo.conf

When you make your changes make sure to run lilo to update lilo.conf.

Last edited by hitest; 11-27-2008 at 08:56 AM.
 
Old 11-27-2008, 09:25 AM   #7
Supporter1984
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware, Slax
Posts: 13

Original Poster
Rep: Reputation: 0
Well i did this:

* Added the line append=" vt.default_utf8=0 acpi=force"to my lilo.conf
* Runned my lilo before shuting down, doing /sbin/lilo
* Shutdown -h now
* It stayed like before, on System halted.

Should i add the whole line ou only acpi=force ?

Thanks for the help so far guys.
 
Old 11-27-2008, 09:27 AM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Can you provide a bit more info on your computer, how old is it ? is it a laptop or desktop ? what brand if any ?
 
Old 11-27-2008, 09:31 AM   #9
Supporter1984
LQ Newbie
 
Registered: Jan 2008
Distribution: Slackware, Slax
Posts: 13

Original Poster
Rep: Reputation: 0
Its a Desktop Pentium II
Dell Optiplex GX1
512 RAM

Dual boot with windows
 
Old 11-27-2008, 10:38 AM   #10
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Dont know how old that is but maybe its using apm rather than acpi? Is there an apm kernel append line?
 
Old 11-27-2008, 10:47 AM   #11
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,282

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Quote:
Originally Posted by Supporter1984 View Post
Well i did this:

* Added the line append=" vt.default_utf8=0 acpi=force"to my lilo.conf
* Runned my lilo before shuting down, doing /sbin/lilo
* Shutdown -h now
* It stayed like before, on System halted.

Should i add the whole line ou only acpi=force ?

Thanks for the help so far guys.
Your line should look like mine; just add acpi=force to the end.

Edit: added later. Try a re-boot to see if that allows the changes to lilo to take effect.

Last edited by hitest; 11-27-2008 at 10:54 AM.
 
Old 11-27-2008, 11:04 AM   #12
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Dont know how old that is but maybe its using apm rather than acpi? Is there an apm kernel append line?
From the /usr/src/linux/arch/i386/kernel/apm.c kernel source file :
Code:
/*
 * See Documentation/Config.help for the configuration options.
 *
 * Various options can be changed at boot time as follows:
 * (We allow underscores for compatibility with the modules code)
 *	apm=on/off			enable/disable APM
 *	    [no-]allow[-_]ints		allow interrupts during BIOS calls
 *	    [no-]broken[-_]psr		BIOS has a broken GetPowerStatus call
 *	    [no-]realmode[-_]power[-_]off	switch to real mode before
 *	    					powering off
 *	    [no-]debug			log some debugging messages
 *	    [no-]power[-_]off		power off on shutdown
 *	    [no-]smp			Use apm even on an SMP box
 *	    bounce[-_]interval=<n>	number of ticks to ignore suspend
 *	    				bounces
 *          idle[-_]threshold=<n>       System idle percentage above which to
 *                                      make APM BIOS idle calls. Set it to
 *                                      100 to disable.
 *          idle[-_]period=<n>          Period (in 1/100s of a second) over
 *                                      which the idle percentage is
 *                                      calculated.
 */
I've tried mucking about with these but some older boxes (as in PII's) refuse to powerdown for me.
 
Old 11-27-2008, 11:10 AM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by Supporter1984 View Post
Its a Desktop Pentium II
Dell Optiplex GX1
512 RAM

Dual boot with windows
For such an old computer I would disable ACPI and use APM instead. So use this kernel option:

Code:
acpi=off
 
Old 11-27-2008, 11:51 AM   #14
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
I thought Slackware was set up so that pressing (not holding) the power button will shut everything down. Additionally can't you always 'sudo init 0' ??
 
Old 11-27-2008, 12:16 PM   #15
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
You the acpi config file has the power button to init 0 but it has never worked for me, although I'm glad cos a few times I've to hard reset by holding power button.
 
  


Reply

Tags
shutdown


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto shutdown power Management mickeyboa Fedora 1 04-25-2006 12:56 AM
howto map localhost correctly? computerdaves Fedora 10 02-08-2005 04:54 PM
script to shutdown system - howto matthewchin Linux - General 5 07-12-2004 12:11 AM
Graceful shutdown.. howto? rohan208 Linux - General 5 05-16-2004 03:39 PM
howto mirror a man page correctly bronko Linux - Newbie 2 03-15-2004 11:05 AM


All times are GMT -5. The time now is 10:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration