LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-08-2007, 02:10 PM   #1
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Rep: Reputation: 30
HOWTO: configure compiz


After finding a way to configure compiz using only the official package, I thought it would be nice to share. We'll assume a working compiz installation and vanilla path/env.

Quote:
mkdir ~/.compiz
compiz --replace ini decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
kde-window-decorator &
This should turn on compiz with all the default plugins, and create a bunch of .conf in ~/.compiz/options/. Note that that's 3 lines of commands.

To set up the cube's top/bottom and skydome pictures, you can modify ~/.compiz/options/cube-screen0.conf. Dig around in there. Lot's of fun.

To set up compiz as default windows manager, we modify ~/.compiz/options/decoration-allscreens.conf with:
Quote:
command=kde-window-decorator
and create a script in ~/.kde/env/ with content:
Quote:
#! /bin/sh
KDEWM="compiz ini"
export KDEWM
Restart X (Ctrl-Alt-Backspace) and you're all done

Most of this guide stolen from WulfNStein, raska and erklaerbaer.

Last edited by randomsel; 07-08-2007 at 05:32 PM.
 
Old 07-08-2007, 04:06 PM   #2
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Original Poster
Rep: Reputation: 30
note to the wary, I can't seem to change back to kwin now ...

EDIT: Ok, remove all modifications, runlevel 3, xwmconfig to xfce, startx, logout, xwmconfig to kde, back to kwin now (kde-window-decorator does not display chinese in the titlebar)

Last edited by randomsel; 07-08-2007 at 04:32 PM.
 
Old 07-08-2007, 09:25 PM   #3
trashbird1240
Member
 
Registered: Sep 2006
Location: Durham, NC
Distribution: Slackware, Ubuntu (yes, both)
Posts: 463

Rep: Reputation: 31
Hi, I've tried lots of different compiz comand lines and I always get this error:

Code:
compiz: Another window manager is already running on screen: 0
compiz: No manageable screens found on display :0.0
Like, duh, I know another window manager is running, I said "--replace"

Joel
 
Old 07-10-2007, 10:41 PM   #4
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 563

Rep: Reputation: 45
Did you have compiz working as a user or root?

I have not been able to get all effects as user. Curiosity I ran it as root on kde desktop and have wobbles, window borders etc. Pretty useless if it only works for root. Seems to me a permission issue but I haven't seen anything about permissions and compiz.
 
Old 07-10-2007, 11:24 PM   #5
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Original Poster
Rep: Reputation: 30
That's strange, the people at the compiz forum recomends *not* to run compiz as root. If you're getting wobbly, compiz is working.

I found out that many of them need special key presses (Ctrl-Alt-left/right/up/down) to activate the effect, and the order of load for the plugins is important (ish).
 
Old 07-11-2007, 04:24 AM   #6
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 563

Rep: Reputation: 45
I never use root logged into kde except just right after an install for a couple things. But with root available I thought I'd try compiz since it wasn't working right in a user account.

Seems all works as root except for the much talked about cube for which not even a config file is created. That might just be my rather dated geforce2 mmx/mx 400.

Compiz starts up with user but no window borders, wobble, etc. Not all that important to me but once I've sorted things out and built packages there will be some other workstation's whose owners will want the eye candy.

Last edited by justwantin; 07-11-2007 at 04:26 AM.
 
Old 07-11-2007, 09:41 AM   #7
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Quote:
Originally Posted by justwantin
....
Compiz starts up with user but no window borders, wobble, etc. Not all that important to me but once I've sorted things out and built packages there will be some other workstation's whose owners will want the eye candy.
mmmh... are you running kde-window-decorator right after running compiz?
After logging in, open a terminal (i.e. Konsole) and try these two commands, please tell us if you get the 3D desktop working afterwards:
Code:
compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
kde-window-decorator &
Keep the ampersand signs (&) at the end, those mean to send your commands to the background so they don't crash if you close your terminal program.

Thanks to randomsel for the above tips. I hope to find the time to review them, so I can setup a skydome and some (mis)configurations and post back here my results
 
Old 07-11-2007, 10:19 AM   #8
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Original Poster
Rep: Reputation: 30
Apropos of skydome, gradient works, but can't make it work with an image. Please share if you comes up with a solution (or an image that works). Same for top/bottom image.

Most of these configurations are undocumented, but obvious after you test them out, like 'in=1' in the cube configuration shifts your point of view to the "inside" of the cube .
 
Old 07-11-2007, 11:08 AM   #9
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Rep: Reputation: 37
I am sorry for intervening in this post, but I think I should not start a new thread since this one discusses problems with configuring compiz.
So I am running Slackware Linux 12.0 with kernel vmlinuz-generic-smp-2.6.21.5-smp. My video card is 00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
So, following the instructions in the first post, I added

Section "Extensions"
Option "Composite" "Enable"
EndSection

to my xorg.conf. When I run:
compiz --replace ini decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
I get the following:

libGL warning: 3D driver claims to not support visual 0x51
compiz: GLX_EXT_texture_from_pixmap is not supported by direct rendering context, trying indirect rendering context instead
compiz: GLX_EXT_texture_from_pixmap is missing
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0

and the borders of the windows freeze and all I can do is kill kde and start in anew.

Any suggestions what is wrong?
First of all does my video card support the "shinies" that compiz allows?

Regards,
Martin
 
Old 07-11-2007, 11:41 AM   #10
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Original Poster
Rep: Reputation: 30
seems you haven't enabled dri yet, check out the stickied thread about enabling 3d acceleration on x11
 
Old 07-11-2007, 12:02 PM   #11
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Rep: Reputation: 37
glxinfo | rendering:
libGL warning: 3D driver claims to not support visual 0x51
direct rendering: Yes

So I do have direct rendering ...

I wonder if my video card supports what compiz offers?
 
Old 07-11-2007, 01:47 PM   #12
rosepower
LQ Newbie
 
Registered: Nov 2005
Location: Portugal
Distribution: Slackware 12 / Testing Other distros
Posts: 24

Rep: Reputation: 15
Hi,

I have an ATI Radeon 9600, and i also get this message:

LibGL warning: 3D driver claims to not support visual 0x4b
compiz: GLX_EXT_texture_from_pixmap is not supported by direct rendering context, trying indirect rendering context instead
compiz: GLX_EXT_texture_from_pixmap is missing
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0

Should i install the proprietary drivers ???
I have this post here: h**p://www.linuxquestions.org/questions/showthread.php?t=568200

Regards

PSlease move or delet my post if you think it does not belong in this thread
 
Old 07-11-2007, 02:49 PM   #13
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 563

Rep: Reputation: 45
Quote:
mmmh... are you running kde-window-decorator right after running compiz?
Thanks raksa,

Yes, I'm using the complete command in two lines with "&" following each line. I played around a bit more and it seems that I can get something worthwhile if I leave out the "ini", e.g.

# #!/bin/bash
# compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
# kde-window-decorator &

I have a ~/.compiz directory and some config files that were created in it when I first ran with "ini" in the script. There is a ~/.kde/env directory with your short script in it named start-compiz (for lack of any other name) and it is executable.

If I run this script manually:

# #!/bin/bash
# compiz --replace ini decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
# kde-window-decorator &

I get the following error:

" kde-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0" "

which I now think is a failure to read the ./compiz configs and not a permission problem.


I'll have to do some more research.
 
Old 07-11-2007, 07:58 PM   #14
WulfNStein
LQ Newbie
 
Registered: May 2007
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
For configuring your video card to handle compiz I strongly recommend reading the tutorials on the compiz site.....

http://compiz.org/Documentation/Documentation

There are steps for configuring Nvidia, ATI, and Intel cards.

There is also a lot of helpful information on there forums.

http://forum.compiz.org/

Good luck.
 
Old 07-12-2007, 12:24 AM   #15
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Lubuntu, Slackware
Posts: 575

Rep: Reputation: 64
Thumbs down

I had a strange and disappointing experience with Compiz.

Fake:

First of all, I created a brand new user: "fake". I didn't want to risk my environment. I killed X, logged in as "fake" and installed Compiz. What I call "installation" is nothing more than running these commands:

Code:
rm -rf ~/.compiz
mkdir ~/.compiz
compiz --replace ini decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
kde-window-decorator &
I didn't get any error messages, and Compiz worked flawlessly. All features worked. Impressive! I killed X and logged in as "fake" again. Compiz was still there working flawlessly. I restarted X once again, Compiz was hanging tough. So I assumed it was installed for good. But the first funny thing in this story is that I inspected ~/.compiz and it was empty! No files, zilch, nada.

Myself:

So I killed X and logged in as myself. Installed Compiz and this time I got error messages. Something more or less like "file such and such not found, using defaults". Or something like that. The message was echoed about 6 or 8 times, and about 6 or 8 files were created inside ~/.compiz. Well, this time Compiz did not work at all. It was running in the background, but none of the effects worked. Sometimes it would even make KDE freeze completely and force me to kill X.

Myself with empty home:

So I dropped to runlevel 3 and moved everything in my home directory elsewhere and ran startx. I was still myself, but with an empty home directory. New installation and, again, I got the same error message about 6 or 8 times in the console, and about 6 or 8 files were created inside ~/.compiz. Now Compiz sort of worked, just a couple of features. I restarted X several times and nothing improved. And Compiz never started itself automatically as when I experimented with the "fake" user. Now I always had to run it manually.

My old self again:

So I deleted everything from my home directory, restored the backup and installed Compiz as myself with all the old baggage once more. Again, it ran in background, but none of the effects worked.

Faketoo:

I made another new user: "faketoo". Then I killed X, logged in as "faketoo" and installed Compiz. It would work fine with another brand new user like "fake", right? Wrong. I got the same error message and just a couple of features worked.

Fake:

Finally, I logged in as Mr. fake again and Compiz ran just fine. Automatically. I didn't have to "install" it. It was there already. I figured I could just copy whatever Mr. fake had in his ~/.compiz directory, but it's still empty.

Then I gave up. Too bad. It was fun while it lasted.
 
  


Reply

Tags
compiz


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure Compiz nymusicman Linux - Software 3 03-25-2007 12:56 AM
How do I configure titlebar buttons in Compiz? JoeDuncan Linux - Desktop 1 11-25-2006 03:02 AM
LXer: Howto: ATI fglrx driver+Xgl+compiz on Debian Sid for KDE users LXer Syndicated Linux News 0 10-22-2006 06:33 AM
mdv 2007 compiz cube not displaying and pictures not memorised by gset-compiz Emmanuel_uk Mandriva 0 10-10-2006 02:33 AM
LXer: Howto: Bring the Xgl and Compiz bling to Ubuntu Dapper Drake LXer Syndicated Linux News 0 09-11-2006 07:33 AM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration