LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-04-2008, 02:15 AM   #1
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 423

Rep: Reputation: 45
How to turn wireless card off with wicd


I just installed wicd and modified the rc.inet1.conf according to http://slackware.osuosl.org/slackwar...ADME.SLACKWARE . After reboot, any thing seems work fine. It could not find any wireless connections because I'm not in a wireless-network. So I want to turn the wireless card off to get a better battery life. How to achieve it? Thanks in advance.
 
Old 12-04-2008, 04:12 AM   #2
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 89
Yours is a VERY pertinent question.

I made this question to myself when booting up Slackware on my Laptop on my last flight. I hope that someone is able to take note of this issue and document it very prominently!

Chris Abela
 
Old 12-04-2008, 02:12 PM   #3
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
I don't know if this helps or if it turns it off...

But have you tried 'su -c '/sbin/modprobe -r wireless_driver_name'??

simply removing the module 'may' turn it off. If that works, you can black list the driver so that it has to manually be loaded (add the driver to /etc/modprobe.d/blacklist)

This probably isn't the best solution.
 
Old 12-04-2008, 02:17 PM   #4
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
I think that the radio switch on the front of some laptops is just a power switch that interrupts the flow of power to the WiFi module. How Windows deals with this, I do not know. But I think the only way for you to be able to do it, in Linux, is to remove the module from the kernel.

As for implementing it in wicd, I think you will have to actually implement it - meaning it is not a provided functionality.
 
Old 12-04-2008, 03:42 PM   #5
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 363

Rep: Reputation: 94
I know of various probably possible ways to achieve this. The easiest one from my side, as I use it every day, would be if you have an Asus laptop and kde. Then you can install lapsus, which is able to turn wifi off.
The more general way to achieve it would be to use the rfkill framework in the kernel. Documentation about it should be in "/usr/src/linux/Documentation/rfkill.txt", though I don't know if it's enabled in Slackware's kernel by default. The downside here is that I only know it *should* work. I tried it myself some times, but never succeeded.
I took a closer look at how lapsus works and recognized it does not utilize the rfkill framework. So either the daemon running in the background is doing some magic of the asus-laptop kernel driver is responsible for it. You might look for a similar tool to lapsus for your manufacturer, or try getting rfkill to work
 
Old 12-05-2008, 09:21 AM   #6
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,920

Rep: Reputation: Disabled
Wicd does not have this functionality, and I'm not convinced that it ever will. To do so would almost surely require wicd to use information from hal, and I'm not sure that's a direction the wicd devs want to go. If you need to "turn off" your wireless card, then a terminal is probably the best tool to use
 
Old 12-06-2008, 03:30 AM   #7
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 423

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by lumak View Post
I don't know if this helps or if it turns it off...

But have you tried 'su -c '/sbin/modprobe -r wireless_driver_name'??

simply removing the module 'may' turn it off. If that works, you can black list the driver so that it has to manually be loaded (add the driver to /etc/modprobe.d/blacklist)

This probably isn't the best solution.
Maybe it's not the best solution but this method Works!

Quote:
Originally Posted by ppr:kut
The more general way to achieve it would be to use the rfkill framework in the kernel. Documentation about it should be in "/usr/src/linux/Documentation/rfkill.txt", though I don't know if it's enabled in Slackware's kernel by default. The downside here is that I only know it *should* work. I tried it myself some times, but never succeeded.

I took a closer look at how lapsus works and recognized it does not utilize the rfkill framework. So either the daemon running in the background is doing some magic of the asus-laptop kernel driver is responsible for it. You might look for a similar tool to lapsus for your manufacturer, or try getting rfkill to work
Hmm, the rfkill frame work does not work on my box too... I have already fired a kernel bug(http://bugzilla.kernel.org/show_bug.cgi?id=11673) but get no solution yet..

Quote:
Originally Posted by rworkman
Wicd does not have this functionality, and I'm not convinced that it ever will. To do so would almost surely require wicd to use information from hal, and I'm not sure that's a direction the wicd devs want to go. If you need to "turn off" your wireless card, then a terminal is probably the best tool to use
Hmm, I get your point. I remember that on the days that "/etc/rc.d/rc.inet1" is the only network manager, wireless card can be turned off simply by "/etc/rc.d/rc.inet1 wlan_down". But this does not work after installing wicd(maybe the root cause is emptying /etc/rc.d/rc.inet1.conf). "ifconfig wlan0 stop" does not do the work too... So any hints there?
 
Old 12-06-2008, 08:29 AM   #8
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Some wifi drivers have the capabilty of turning wireless off but I don't know whether this actually turns hardware off of just stops the driver:

Code:
modinfo ipw2200
parm:           disable:manually disable the radio (default 0 [radio on]) (int)
Also you may find something in /proc/acpi/ relating to it.
 
Old 01-09-2009, 06:53 PM   #9
enno.vet
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
You'll have to check your modprobe manual. If autoloading of modules is enabled in kernel config, then any module that finds a corresponding device will be loaded.
Just remove your module from /lib/modules/<YourKernelVersion>/kernel/wherever and you won't have to bother with it. Perhaps you shouldn't rm it in case you might use it later, instead mv it to some safe place?

modprobe should (does on debian) offer a possibility to configure settings for modules, where you could place the disable=1 option, but that still wouldn't prevent the module being loaded and costing some CPU cycles.

Brgds, ed.
 
Old 01-09-2009, 09:04 PM   #10
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 222Reputation: 222Reputation: 222
go into wicd preference and select what you want it to do you can also make a wired only profile if you want hope this helps. that little icon on the right click go to preferences. or in internet ---> wicd manager. as far as not seeing the or using the hardware then rmmod your module right a litle script make put it in the bin and and then make a craete a link to the script put the link on the desk top and use it.
#!/bin/bash
rmmod your module.

Last edited by Drakeo; 01-09-2009 at 09:11 PM.
 
Old 10-08-2010, 03:36 PM   #11
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 344

Rep: Reputation: 31
On a samsung netbook which does not have a wifi switch the following worked to turn the wifi radio off.

rfkill block wifi

and to bring it back on

rfkill unblock wifi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't turn on wireless card puter Linux - Wireless Networking 1 08-10-2007 11:19 PM
LXer: Managing wireless connections seamlessly with wicd LXer Syndicated Linux News 1 07-31-2007 06:10 PM
I think I just don't know how to turn the Wireless on, lol! Richard Rahl Linux - Wireless Networking 2 08-03-2006 07:56 AM
Wireless Radio Won't turn on!!!!! byblyk Linux - Hardware 6 07-06-2006 08:25 PM
Did 10.1 turn my wireless off? 1madstork Suse/Novell 4 05-16-2006 11:28 PM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration