LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-14-2013, 05:20 AM   #1
narke
Member
 
Registered: Apr 2010
Posts: 70

Rep: Reputation: 0
How to talk/ytalk in slackware?


Hi, Group

I have not figure out how to make talk/ytalk work on my slack box. I've already enabled in.talkd daemon in my inetnd.conf file. But it just still does not work. I test it in the same computer. The command line is:

~user-b $ talk user-a (in one terminal window)
~user-a $ talk user-b (in another terminal window)

the talk program seems complains that peer user is not logged in.

Can anyone has a successful experience? Thanks.

-
woody
 
Old 07-14-2013, 07:26 AM   #2
eternauta2001
LQ Newbie
 
Registered: Dec 2008
Distribution: Slackware Linux 13.1
Posts: 18

Rep: Reputation: 7
Add in /etc/hosts.allow

talkd: ALL

Reload inetd with

# killall -HUP inetd

Last edited by eternauta2001; 07-14-2013 at 07:30 AM.
 
Old 07-14-2013, 09:12 AM   #3
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by eternauta2001 View Post
Add in /etc/hosts.allow

talkd: ALL

Reload inetd with

# killall -HUP inetd
The result is the same. In one end, it says "trying to connect to your party's daemon", in the other end, it says: "Waiting for your party respond"

I think even without "talkd: ALL", my previous hosts.allow should already allow the talk traffic, since it has "ALL: 192.168.0.0/255.255.0.0"
 
Old 07-14-2013, 10:23 AM   #4
mancha
Member
 
Registered: Aug 2012
Posts: 250

Rep: Reputation: Disabled
If you're using slackware's talk(1) you are using the ntalk protocol (udp/518).
Try enabling a listening daemon in inted.conf

Code:
ntalk   dgram   udp     wait    root    /usr/sbin/tcpd  in.talkd
and restarting inetd via

Code:
$ killall -HUP inetd
 
Old 07-14-2013, 10:26 AM   #5
eternauta2001
LQ Newbie
 
Registered: Dec 2008
Distribution: Slackware Linux 13.1
Posts: 18

Rep: Reputation: 7
Sorry, is in.talkd in /etc/hosts.allow no talkd...

Code:
in.talkd: 192.168.0.0/255.255.255.0
Restart inetd:

Code:
# killall -HUP inetd
and allow write access in your terminal:

Code:
$ mesg yes
This works for me.

Last edited by eternauta2001; 07-24-2013 at 08:55 AM.
 
Old 07-22-2013, 11:25 AM   #6
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by eternauta2001 View Post
Sorry, is in.talkd in /etc/hosts.allow no talkd...

Code:
in.talkd: 192.168.0.0/255.255.255.0
Restart inetd:

Code:
# killall -HUP inetd
and allow write access in your terminal:

Code:
$ mesg yes
This works for me.
Followed this method, I got target machine does not recognize us ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ytalk sycamorex Slackware 4 06-10-2007 01:51 PM
talk/ytalk in X santiagosilva Linux - Networking 1 09-04-2004 06:16 PM
are talk,gtalk,ytalk;LAN instant messenger?! l_9_l Linux - Networking 1 03-29-2002 04:42 PM


All times are GMT -5. The time now is 02:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration