LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-31-2004, 08:36 PM   #1
soup
Member
 
Registered: Jun 2003
Location: London, Ontario
Distribution: Ubuntu, Slackware, FreeBSD
Posts: 61

Rep: Reputation: 15
Question how to stop the monitor from blanking


Hi,
sorry if this question has been answered before but I couldn't find an answer by searching. When i'm in the console (runlevel 3 i believe - no x) after a while the monitor goes blank. I'm wondering if anyone knows how to keep this from happening. I tried passing append="noacpi" in lilo.conf

thanks for any help

soup
 
Old 04-01-2004, 12:33 AM   #2
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Urr, I got it from blanking in xwindow by adding the section below:

Section "ServerFlags"
Option "BlankTime" "6000"
EndSection

By the way, I have a Sync On Green monitor (fix frequency).

If the option on top doesn't work, try this below: (put it in between the Section and EndSection). Also play around with the figure. 6000 works for me and it doesn't go blank for weeks (so far).

# Option "StandbyTime" "36000"
# Option "SuspendTime" "36000"
# Option "OffTime" "36000"

As for in init 3 (console), I can make a wild guess. I guess it got to do with APM instead of ACPI. Maybe you should look in that direction.
 
Old 04-01-2004, 02:52 AM   #3
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
The following is in /etc/rc.d/rc.M:

# Screen blanks after 15 minutes idle time.
/bin/setterm -blank 15

comment out the command:

/bin/setterm -blank 15

Enjoy!
--- Cerbere
 
Old 04-01-2004, 05:15 AM   #4
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Thanks Cerbere!

Do you happen to know how to set the display frequency (refresh rate) for the console?
 
Old 04-01-2004, 10:59 AM   #5
soup
Member
 
Registered: Jun 2003
Location: London, Ontario
Distribution: Ubuntu, Slackware, FreeBSD
Posts: 61

Original Poster
Rep: Reputation: 15
thanks for the input. I found out that commenting out that line will not keep it from blanking but if you change it from /bin/setterm -blank 15 to /bin/setterm -blank 0 it will disable console blanking

soup

Last edited by soup; 04-01-2004 at 11:49 AM.
 
Old 04-02-2004, 03:42 AM   #6
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Glad you got it figured out, soup. I knew it was something like that.

And sorry, carboncopy, I have no idea how to change the refresh rate for the console.

You might try playing with some of the kernel settings. Set 'Code maturity level options' ---> 'Prompt for development and/or incomplete code/drivers', then look through the 'Console drivers'.

Just a thought. Good luck!

Enjoy!
--- Cerbere
 
Old 04-02-2004, 04:48 AM   #7
OdieQ
Member
 
Registered: Jan 2004
Location: Stockholm, Sweden
Distribution: Debian, Slackware
Posts: 71

Rep: Reputation: 15
Framebuffer

If you are using a framebuffer console (you are if you see a penguin at the top of the text at boot), you can set the refresh rate and resolution using fbset (I'm no fbset wizard, so check out the docs for more info). If you are running in hardware text mode, the refresh rate is hardwired to 60Hz.

If you are running a stock Slackware kernel, edit /etc/lilo.conf to set framebuffer mode (there are a bunch of commented out lines int the default lilo.conf, pick one and uncomment it). If you are compiling yourself you need to enable framebuffer console, as Cerbere pointed out.

/Odie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't stop KDE/Mandrake 9.2 from blanking screen themusk Linux - Software 1 03-20-2004 08:49 PM
will old monitor stop graphics from working, slow it down, make things blurrie? toastermaker Linux - Hardware 1 03-08-2004 10:43 PM
Stop monitor from sleeping? mmars Linux - Hardware 2 10-16-2003 11:28 AM
How to stop monitor beeping? Thymox General 1 04-17-2002 09:29 AM
Screen Blanking/non-X ldieter Linux - General 0 03-11-2002 09:05 PM


All times are GMT -5. The time now is 03:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration