LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How to stop Slackware attempting to detect RAID? (http://www.linuxquestions.org/questions/slackware-14/how-to-stop-slackware-attempting-to-detect-raid-4175427402/)

hgriggs 09-15-2012 12:41 PM

How to stop Slackware attempting to detect RAID?
 
I don't have any RAID facilities in my systems. When Slackware boots, it tests all sorts of things RAID related. Looking through dmesg, I see the suggestion to use "raid=noautodetect":

> md: Waiting for all devices to be available before autodetect
> md: If you don't use raid, use raid=noautodetect

I would like to do this, but where do I put this command? In lilo.conf? Somewhere else?

BroX 09-15-2012 01:49 PM

Add the following line to /etc/lilo.conf
Code:

append="raid=noautodetect"
In case you already have some boot parameters there, just add the raid part to it, separated by a space. E.g.
Code:

append=" vt.default_utf8=1 raid=noautodetect"

NyteOwl 09-15-2012 02:11 PM

And don't forget to run lilo after editing lilo.conf :)

hgriggs 09-15-2012 04:15 PM

I will do that. Thanks for the info.

Barx 11-24-2012 10:25 AM

Hi, I would like to disable raid autodetect on boot.

I tried the suggested metod, but raid arrays are still assembled automatically on boot (and I would like to assemble them manually, because it's a complex layout)

Here's my lilo.conf

Code:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
#
# Append any additional kernel parameters:
append="rootdelay=5 vt.default_utf8=0 raid=noautodetect"
boot = /dev/sde
prompt
timeout = 30
default = Linux
#delay = 5
vga = normal
#rootdelay = 10
# End LILO global section
# Linux root partition section
#image = /boot/vmlinuz
# root = /dev/sdb2
# label = Linux-old
# read-only
image = /boot/vmlinuz
 initrd = /boot/initrd.gz
 append = "root=LABEL=slackusb raid=noautodetect"
 label = Linux
 read-only

# End root Linux partition section

I tried to add the option in both 'append' strings, without success.

What's wrong?

Thank you

Alessandro

wildwizard 11-24-2012 02:44 PM

Barx:

Your RAID is most likely been assembled via the initrd you have, when you create the initrd you have the option of including mdadm which does the RAID setup.

1. Check /etc/mkinitrd.conf for RAID="1" (This forces mdadm to be added when you run mkinitrd)
2. Do not use "-R" when you run mkinitrd (This is the same as RAID="1")

Do note that if / is RAID then it will stop working if you do that.

This is a good time to remind people that the kernel autodetect routine is considered deprecated and may be removed without notice from the kernel and you should not be using that method for RAID assembly, mdadm is the way of the future.

xj25vm 11-27-2012 02:01 PM

@wildwizard:

Quote:

This is a good time to remind people that the kernel autodetect routine is considered deprecated and may be removed without notice from the kernel and you should not be using that method for RAID assembly, mdadm is the way of the future.
Does this involve any particular reconfiguration of the system? I run a number of RAID arrays in mirror mode, and, as I haven't taken any special steps after building them up, I guess they must be using the kernel RAID auto-detect feature. I also run mdamd from /etc/rc.d/rc.local, mainly for monitoring and alerts over email. I'm guessing that, since mdadm starts in my setups really late in the boot process, this wouldn't be enough if the the kernel RAID auto-detect feature is dropped, and I would need to reconfigure things?

Thank you

P.S. Sorry for hijacking the tread - but it is still somewhat on topic, now that you've mentioned it :-)

TracyTiger 12-02-2012 07:02 PM

Since this thread has been quiet a few days I'll respond to the hijack...

Quote:

Originally Posted by xj25vm (Post 4838179)
Does this involve any particular reconfiguration of the system?

For years I've been setting the partition type to fd (RAID autodetect) for Linux software RAID even though I was using mdadm. After reading here at LQ (probably a post by wildwizard) that partition type da (non-fs data) should be used instead, I tried it successfully with Slackware 14.0.

I used a /etc/mdadm.conf file in both cases (mdadm --detail --scan > /etc/mdadm.conf) though I'm not sure if the system really needs the file to assemble the array. I boot with an initrd with both it and lilo configured for RAID.

The partition type da seems to work fine as long as I don't configure a spare device. (Need to investigate the spare device problem when I have time.)

Your results may be different if you're depending upon a command in rc.local to assemble the array.

... end of encouraging the thread hijacking ...

xj25vm 12-03-2012 10:20 AM

Quote:

... end of encouraging the thread hijacking ...
Thanks Tracy Tiger :)


All times are GMT -5. The time now is 04:53 AM.