LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2014, 12:51 PM   #1
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
how to stop kde system messages from showing in vim


When I am using vim, I often see kde messages about ksycoca something or other which overwrite my screen so I have to redraw it with Ctrl-l. I am using xfce on this machine, but it happens also on my laptop running i3, so I guess it is because I am using a kde app like okular?

Anyway, is there a way I can stop these messages from showing up in vim?

Thanks in advance,
Brian
 
Old 03-12-2014, 04:42 PM   #2
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware
Posts: 374

Rep: Reputation: 90
Try doing something like this:

Code:
dmesg -n 1
okular&
dmesg -n 1 should disable those messages, at least if they are the messages I think they are.
 
Old 03-12-2014, 04:58 PM   #3
jmccue
Member
 
Registered: Nov 2008
Location: US
Distribution: slackware
Posts: 129

Rep: Reputation: 32
The way I read this you do this from a terminal ?
Code:
okular somefile &
vim anotherfile
I would think doing this would work (assuming sh type shell):
Code:
okular somefile > dust 2>&1
but I gave it a shot and some messages bleed through while some are redirected. So I would guess okular may spawn some new processes. I'll play around a bit and see if I can find a workaround and post if I find something. I find this behavior annoying also.
 
1 members found this post helpful.
Old 03-14-2014, 07:49 AM   #4
EYo
Member
 
Registered: Jun 2009
Location: Cloverdale
Distribution: Slackware, Debian
Posts: 39

Rep: Reputation: 16
Quote:
Originally Posted by BCarey View Post
Anyway, is there a way I can stop these messages from showing up in vim?
Try "kdebugdialog --fullmode" and pick a noise level. HTH.
 
3 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] VIM: showing line terminators. stf92 Linux - Software 4 08-08-2010 03:04 PM
[SOLVED] network-manager-applet not showing in system tray (KDE) piratesmack Slackware 14 06-15-2010 06:36 AM
evolution not showing all new messages aw76 Linux - General 1 02-09-2010 10:32 PM
[SOLVED] Vim not showing some characters kofucii Linux - Newbie 2 09-07-2009 09:09 AM
I want to stop these particular messages in /var/log/messages smartyshan Linux - Security 7 05-31-2009 02:41 AM


All times are GMT -5. The time now is 07:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration