LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   how to stop kde system messages from showing in vim (http://www.linuxquestions.org/questions/slackware-14/how-to-stop-kde-system-messages-from-showing-in-vim-4175497955/)

BCarey 03-12-2014 01:51 PM

how to stop kde system messages from showing in vim
 
When I am using vim, I often see kde messages about ksycoca something or other which overwrite my screen so I have to redraw it with Ctrl-l. I am using xfce on this machine, but it happens also on my laptop running i3, so I guess it is because I am using a kde app like okular?

Anyway, is there a way I can stop these messages from showing up in vim?

Thanks in advance,
Brian

notKlaatu 03-12-2014 05:42 PM

Try doing something like this:

Code:

dmesg -n 1
okular&

dmesg -n 1 should disable those messages, at least if they are the messages I think they are.

jmccue 03-12-2014 05:58 PM

The way I read this you do this from a terminal ?
Code:

okular somefile &
vim anotherfile

I would think doing this would work (assuming sh type shell):
Code:

okular somefile > dust 2>&1
but I gave it a shot and some messages bleed through while some are redirected. So I would guess okular may spawn some new processes. I'll play around a bit and see if I can find a workaround and post if I find something. I find this behavior annoying also.

EYo 03-14-2014 08:49 AM

Quote:

Originally Posted by BCarey (Post 5133368)
Anyway, is there a way I can stop these messages from showing up in vim?

Try "kdebugdialog --fullmode" and pick a noise level. HTH.


All times are GMT -5. The time now is 09:39 PM.