LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-02-2012, 03:31 AM   #1
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Rep: Reputation: Disabled
How to set the locale so that...?


This question might be silly, but I just don't find a place to set it right, sorry!
The question is: lately I've set the LANG="zh_HK"(which is Chinese) in my lang.sh, things are going fine.
But I just wonder if its possible that the UI not becoming in Chinese? What I want is, when the files or file names whatever are written in Chinese, then show them in Chinese; otherwise in English. I don't want the English-Chinese translation in my UI. I want to see my desktop trash "Trash", not trash in Chinese. Funny thing is, the translation is partial, you would see some button in English and others in Chinese...

Is it possible to do that?

Thx.
 
Old 11-02-2012, 04:02 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,301

Rep: Reputation: 1063Reputation: 1063Reputation: 1063Reputation: 1063Reputation: 1063Reputation: 1063Reputation: 1063Reputation: 1063
I think that it is possible, but the way of getting this behavior depends on the DE you use. Is it XFCE or KDE?
 
Old 11-02-2012, 05:41 AM   #3
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Mine is xfce. Thx.
 
Old 11-02-2012, 06:19 AM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
I think what affects filenames is LC_CTYPE. So set only that to Chinese.

However, it would probably be more convenient for you to use the en_US.UTF-8 locale. If your filenames are already encoded in something else (e.g. big5 or whatever), "convmv" can help you to migrate to utf8.

.
 
Old 11-02-2012, 09:17 PM   #5
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by guanx View Post
I think what affects filenames is LC_CTYPE. So set only that to Chinese.

However, it would probably be more convenient for you to use the en_US.UTF-8 locale. If your filenames are already encoded in something else (e.g. big5 or whatever), "convmv" can help you to migrate to utf8.

.
Thanks.
I tried to set LANG=en_US.UTF-8 and LC_CTYPE=zh_HK. Most of the UI is doing fine. But some applications are showing funny characters!

Last edited by 688a; 11-02-2012 at 10:09 PM.
 
Old 11-02-2012, 11:26 PM   #6
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by 688a View Post
Thanks.
I tried to set LANG=en_US.UTF-8 and LC_CTYPE=zh_HK. Most of the UI is doing fine. But some applications are showing funny characters!
If you would like to migrate to utf8 then use convmv to convert your old filename, then set everything to en_US.UTF-8 including LC_CTYPE.
 
Old 11-05-2012, 03:46 AM   #7
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by guanx View Post
If you would like to migrate to utf8 then use convmv to convert your old filename, then set everything to en_US.UTF-8 including LC_CTYPE.
Thanks. I will try what you said later . And I mark this thread as done as well!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 08:35 PM
set Locale for root? WiseDraco Slackware 2 02-21-2012 01:36 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 03-31-2006 11:38 PM
set locale... pixelV Linux - Software 14 03-17-2003 07:34 PM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration