LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2012, 11:17 AM   #1
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Rep: Reputation: 3
How to set the default browser in Thunderbird 3.0.4


I've looked in what I thought were the obvious places, and can't see where to make the change. Help!

I've been using Seamonkey mail, which opens Seamonkey browser. I've switched to Thunderbird email.
 
Old 03-12-2012, 12:19 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,853

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
In Thunderbird, click Edit-->Preferences-->Attachments. There is a Content Type column, and an Action column. Add a Content type of http and another for https, and in the action column, add Firefox. That should do it.

Hope this helps.
 
Old 03-12-2012, 02:44 PM   #3
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
There doesn't appear to be an "edit" function in the content section.
 
Old 03-12-2012, 02:49 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,853

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Quote:
There doesn't appear to be an "edit" function in the content section.
Look at the top line of Thunderbird after you first open it.
 
Old 03-12-2012, 04:01 PM   #5
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
I found the content page. I don't see what to do to edit the page.
 
Old 03-12-2012, 04:18 PM   #6
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
http://s1092.photobucket.com/albums/...underbird1.png

Where do I click "edit?"

Last edited by ferrel; 03-12-2012 at 04:19 PM.
 
Old 03-12-2012, 05:09 PM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,853

Rep: Reputation: 432Reputation: 432Reputation: 432Reputation: 432Reputation: 432
Looks like I was dead wrong. Sorry.

To set FF as your default browser, you do that in Firefox Preferences Advanced, General.

There should be an option System Defaults, there is a check box to have FF check on startup if its the system default, and a button to Check Now. Check now should allow you to set it as the system default.

Give that a try, and let me know.
 
Old 03-12-2012, 06:13 PM   #8
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
http://s1092.photobucket.com/albums/...underbird2.png

No problem. I did as you recommended, but the problem still remains. Perhaps the problem is something else.

Here is the original problem. I changed to Thunderbird from Seamonkey. Opened thunderbird, clicked on a new message with an embedded url, and got an error message (see the link above for a snapshot). I interpreted that as meaning that I needed to specify a default browser. When I opened such a link in seamonkey mail, the seamonkey browser would open it. I now want to use mozilla firefox and thunderbird.

I hope this provides some clarification.

Last edited by ferrel; 03-12-2012 at 06:15 PM.
 
Old 03-12-2012, 06:42 PM   #9
tmmukunn
Member
 
Registered: Nov 2007
Distribution: Slackware
Posts: 34

Rep: Reputation: 6
Quote:
Originally Posted by ferrel View Post
http://s1092.photobucket.com/albums/...underbird2.png

No problem. I did as you recommended, but the problem still remains. Perhaps the problem is something else.

Here is the original problem. I changed to Thunderbird from Seamonkey. Opened thunderbird, clicked on a new message with an embedded url, and got an error message (see the link above for a snapshot). I interpreted that as meaning that I needed to specify a default browser. When I opened such a link in seamonkey mail, the seamonkey browser would open it. I now want to use mozilla firefox and thunderbird.

I hope this provides some clarification.
EDIT: Disclaimer: I tested this for Thunderbird 10.0.2... For 3.0.4 I'm not quite sure this would be the same..

You are close. In your dialog click the Choose.. button and navigate to the firefox application (perhaps in /usr/bin) and check the "Remember my choice for http links". After that, it will show up in the Preferences->Attachments dialog.

Last edited by tmmukunn; 03-12-2012 at 06:46 PM. Reason: Clarification of version of Thunderbird used for testing
 
Old 03-12-2012, 06:54 PM   #10
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
That worked! Thanks very much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
set thunderbird as default in KDE 3.x hlpboplz Linux - Newbie 4 09-25-2005 12:30 PM
How To Set Default Font Color For Thunderbird Composer mac57 Linux - Software 2 03-16-2005 08:57 AM
KDE Default Browser Problems with firefox and thunderbird gnat79 Linux - Software 3 02-16-2005 02:10 PM
How do I make Firefox/Thunderbird my default browser/email client? Kyral Retsam Linux - Software 1 07-20-2004 10:03 PM
Firefox Default Browser (thunderbird) Warmaster Mandriva 9 05-25-2004 11:31 AM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration