LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-31-2009, 08:43 PM   #1
Larry37
LQ Newbie
 
Registered: Mar 2006
Posts: 18

Rep: Reputation: 0
How to pass initrd parameter using slack's bootstick?


I have several linux distros installed on a machine where Windows XP is the primary OS. Rather than booting with lilo or grub via the MBR, I'd like to boot using the usb bootstick I made when I installed slackware 12.2. This works fine, except some of the distros need initrd loaded to be able to load the driver for my NIC. I've tried several approaches to do this, and all failed.

Example:

I have suse installed on partition 13. I can boot suse with:

mount root=/dev/sda13 ro

but how do I pass the initrd parameter?

I tried using the "initrd" link to the real initrd file and that failed, so rather than type the long real file name with the version number in it, I duped the file and named it initrdfile. It lives in the /boot directory on sda13.

I tried the following variants:

mount root=/dev/sda13 ro initrd=initrdfile

mount root=/dev/sda13 ro initrd=/boot/initrdfile

mount root=/dev/sda13 ro initrd=/dev/sda13/boot/initrdfile

All three aborted the boot with a message that the file could not be found ("the file" was the string I entered after the = sign).

How do you do this correctly?

Thanks.

Larry
 
Old 08-02-2009, 07:16 AM   #2
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 299

Rep: Reputation: 50
in your syslinux.cfg on your usb stick have you tried this

...
append root=/dev/sda13 ro initrd=/boot/initrdfile

(assuming your initrdfile is in /dev/sda13/boot
if it's in /dev/sda13/initrdfile
then
append root=/dev/sda13 ro initrd=initrdfile
)
 
Old 08-02-2009, 11:41 PM   #3
Larry37
LQ Newbie
 
Registered: Mar 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for the reply -- no, that doesn't work.

initrdfile is in /dev/sda13/boot and I made the last line in syslinux.cfg to read

append root=/dev/sda13 vga=normal ro initrd=/boot/initrdfile

and I still get an abort of the boot with the message

could not find /boot/initrdfile

Larry


Quote:
Originally Posted by vonbiber View Post
in your syslinux.cfg on your usb stick have you tried this

...
append root=/dev/sda13 ro initrd=/boot/initrdfile

(assuming your initrdfile is in /dev/sda13/boot
if it's in /dev/sda13/initrdfile
then
append root=/dev/sda13 ro initrd=initrdfile
)
 
Old 08-03-2009, 01:09 AM   #4
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,756

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
lilo is looking for the initrd in the same location as the kernel. What do you have for the boot=?? entry? This is where the initrd should be.
 
Old 08-03-2009, 07:44 AM   #5
Larry37
LQ Newbie
 
Registered: Mar 2006
Posts: 18

Original Poster
Rep: Reputation: 0
I'm not using lilo. I'm using the boot stick built by slackware during installation. I believe it's the syslinux loader.

Larry
 
Old 08-04-2009, 11:22 AM   #6
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 299

Rep: Reputation: 50
Quote:
Originally Posted by Larry37 View Post
append root=/dev/sda13 vga=normal ro initrd=/boot/initrdfile

and I still get an abort of the boot with the message

could not find /boot/initrdfile
in /dev/sda13 do you have 'initrdfile' placed in the boot directory?
locate in that partition where it's located (and its exact name)
and type in the exact path in
initrd=....

you might want to use symbolic links if the name is too complicated,
e.g., say it's called
initrd-some_impossibly_too_long_complicated_name-3.5.25
and it's located in
/boot on your /dev/sda13
then on your /dev/sda13:
cd /boot
ln -sf initrd-some_impossibly_too_long_complicated_name-3.5.25 initrd

and in your syslinux.conf on your usb drive:

append root=/dev/sda13 vga=normal ro initrd=/boot/initrd
 
Old 08-05-2009, 08:07 PM   #7
Larry37
LQ Newbie
 
Registered: Mar 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks, but that is exactly what I have done that doesn't work.

As far as file names go, I originally tried to use the initrd symbolic link that was already defined in /boot. When that didn't work, I duplicatd the real file with the imposibly long name and renamed the dup initrdfile. That didn't work either. I have also tried using the real full impossibly long name and still no joy.

The file is in /boot. Specifically, it's in /dev/sda13/boot.

I've tried

initrd=/boot/filename

initrd=/dev/sda13/boot/filename

initrd=filename

In all cases, "filename' is one of the three varients described above -- nine test cases in total.

ALL abort the boot with the error message

could not find <whatever I had put after the initrd=>

I thought maybe booting from the thumb drive was somehow messing up the numbering/naming of the HDs, but if I leave the initrd parameter off, it finds the right kernel and boots everything just fine ... except my eth0 driver doesn't get loaded because (I assume) there is no initrd provided.

I'm being equally bumfoozled when I try to build a grub boot stick. I have the thumb drive booting fine and it runs grub, but when I try to get it to boot the kernel on (hd1,12), it says there is no such partition. (It seems that hd0 is the thumb drive, and hd1 is the first real HD.) (hd1,n) produces that error message for any n > 0.

I'm at a loss.....

Larry
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to pass a Kernel Parameter? brian.wright Linux - Newbie 3 02-24-2009 04:03 PM
how to pass in a parameter to a perl script new_2_unix Linux - Newbie 2 12-09-2007 12:48 AM
gtk - How to pass in a parameter Ian D Programming 4 10-28-2005 11:23 AM
how do I pass a module parameter? maerong Debian 2 02-07-2005 07:33 AM
PHP Pass Parameter Gerardoj Programming 2 05-25-2004 08:12 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration