LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-07-2012, 07:40 AM   #1
hgdcjq
LQ Newbie
 
Registered: Aug 2012
Posts: 29

Rep: Reputation: Disabled
Wink how to make slackware 13.37 be able to Chinese


I want to know how to let slackware13.37 be able to input Chinese and it should not influence the console output. What I mean is that in some cases when I can input Chinese in desktop in distributions like Fedora, Debian, Ubuntu, the console usually display some chars as ?????***** .This is what I need to avoid.
anyone can help me? Thanks
 
Old 09-07-2012, 08:10 AM   #2
slacktroll
Member
 
Registered: May 2011
Distribution: Slackware 13.37
Posts: 50

Rep: Reputation: 3
Slackware does not work as other distributions. in other distributions you simply chose a language and it's applied to everything. which utterly sucks. I remember the days of debian when i used to use 'swedish' keyboard in the setup and all man pages and all input in terminal consoles was in crappy swedish. Using the us keyboard disabled characters such as едц in terminals and console which sucks.

KDE might have support for Chinese characters so you can input them in koffice, konqueror and some nice gui application. however what do you mean with console? A terminal in a X environment or a tty?

To fix them in a virtual console just add
append=" vt.default_utf8=0"
in /etc/lilo.conf
That would probably do the job :-)

Terminal might be a bit difference.

rxvt-unicode from slackbuilds.org might have support for such characters.
 
Old 09-07-2012, 08:37 AM   #3
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by hgdcjq View Post
I want to know how to let slackware13.37 be able to input Chinese and it should not influence the console output. What I mean is that in some cases when I can input Chinese in desktop in distributions like Fedora, Debian, Ubuntu, the console usually display some chars as ?????***** .This is what I need to avoid.
anyone can help me? Thanks
Have you tried "chmod +x /etc/profile.d/scim.sh" and set locale to "en_US.UTF8" in "/etc/profil.d/lang.sh"?
 
1 members found this post helpful.
Old 09-07-2012, 08:49 AM   #4
hgdcjq
LQ Newbie
 
Registered: Aug 2012
Posts: 29

Original Poster
Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by guanx View Post
Have you tried "chmod +x /etc/profile.d/scim.sh" and set locale to "en_US.UTF8" in "/etc/profil.d/lang.sh"?
Yes,I have down that and it works. I have found a similar thread ,thanks you two guys anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chinese Input in Slackware 12, which WM? Piaculum Slackware 32 12-18-2007 07:15 AM
how to make chinese input effect under english enviroment? salinelove Linux - Software 5 09-25-2006 12:40 AM
How to make LICQ and GAIM fully support Chinese?? Mathsniper Linux - Software 0 06-25-2005 02:53 AM
How to make Chinese characters display correctly in Gentoo? fossilet Linux - Distributions 4 10-31-2004 08:21 AM
Can't display Chinese in Slackware 9.0 GrimCracker Slackware 15 10-22-2003 08:03 AM


All times are GMT -5. The time now is 06:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration