LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   how to make slackware 13.37 be able to Chinese (http://www.linuxquestions.org/questions/slackware-14/how-to-make-slackware-13-37-be-able-to-chinese-4175426114/)

hgdcjq 09-07-2012 07:40 AM

how to make slackware 13.37 be able to Chinese
 
I want to know how to let slackware13.37 be able to input Chinese and it should not influence the console output. What I mean is that in some cases when I can input Chinese in desktop in distributions like Fedora, Debian, Ubuntu, the console usually display some chars as ?????***** .This is what I need to avoid.
anyone can help me? Thanks

slacktroll 09-07-2012 08:10 AM

Slackware does not work as other distributions. in other distributions you simply chose a language and it's applied to everything. which utterly sucks. I remember the days of debian when i used to use 'swedish' keyboard in the setup and all man pages and all input in terminal consoles was in crappy swedish. Using the us keyboard disabled characters such as едц in terminals and console which sucks.

KDE might have support for Chinese characters so you can input them in koffice, konqueror and some nice gui application. however what do you mean with console? A terminal in a X environment or a tty?

To fix them in a virtual console just add
append=" vt.default_utf8=0"
in /etc/lilo.conf
That would probably do the job :-)

Terminal might be a bit difference.

rxvt-unicode from slackbuilds.org might have support for such characters.

guanx 09-07-2012 08:37 AM

Quote:

Originally Posted by hgdcjq (Post 4774958)
I want to know how to let slackware13.37 be able to input Chinese and it should not influence the console output. What I mean is that in some cases when I can input Chinese in desktop in distributions like Fedora, Debian, Ubuntu, the console usually display some chars as ?????***** .This is what I need to avoid.
anyone can help me? Thanks

Have you tried "chmod +x /etc/profile.d/scim.sh" and set locale to "en_US.UTF8" in "/etc/profil.d/lang.sh"?

hgdcjq 09-07-2012 08:49 AM

Quote:

Originally Posted by guanx (Post 4774976)
Have you tried "chmod +x /etc/profile.d/scim.sh" and set locale to "en_US.UTF8" in "/etc/profil.d/lang.sh"?

Yes,I have down that and it works. I have found a similar thread ,thanks you two guys anyway.


All times are GMT -5. The time now is 04:21 PM.