LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-17-2003, 05:24 AM   #1
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Rep: Reputation: 15
How to make regular users able to use the pppd


Well, ppp up and running after 2 weeks of headscratching =)
Now, I need to make regular users able to use the ppp-link aswell. Especially me, because I feel a little uncomfortable running a ppp-protocol as root =)
So, what do I need to do?
I did 'chmod u+s /usr/sbin/pppd' but I know there is something else I need to do.
So, enlighten me please
 
Old 11-17-2003, 06:14 AM   #2
a slacker
Member
 
Registered: Aug 2003
Distribution: Arch
Posts: 44

Rep: Reputation: 15
try:

chmod 755

and see if it works
 
Old 11-17-2003, 06:51 AM   #3
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Original Poster
Rep: Reputation: 15
fixed it!
i forgot to let regular users make output to /dev/modem =)
empirical knowledge, the best of all!
 
Old 11-17-2003, 08:15 AM   #4
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Original Poster
Rep: Reputation: 15
ok, it still does not work
i still need help
so:
ex. when the user "slackuser" tries to execute 'ppp-go' it says: Connect script failed.
I have made chmod u+s to theese files:

/usr/sbin/pppd
/usr/sbin/ppp-on
/usr/bin/ppp-off
/etc/ppp/pap-secrets
/etc/ppp/options
/etc/ppp/options.demand
/dev/modem

But it still does not work, plz help!
 
Old 11-17-2003, 08:34 AM   #5
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 825

Rep: Reputation: 30
This question has been asked many times before. Try searching the forums
 
Old 11-17-2003, 09:13 AM   #6
minio
Member
 
Registered: Sep 2003
Location: Czech Republic - Prague
Distribution: Slackware 9.1
Posts: 61

Rep: Reputation: 15
chmod u+s /usr/sbin/chat is missing
 
Old 11-18-2003, 04:40 AM   #7
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackware ARM, Salix and Porteus
Posts: 558

Rep: Reputation: 45
LOL

I forget that one every time I've set up about 10 boxes now and I still do it.

An easy mistake.
 
Old 11-18-2003, 07:51 AM   #8
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Original Poster
Rep: Reputation: 15
and PRESTO!
it works, thanks guys!
i knew i had forgotten something really really simple. and when you posted that it was the chat program, i felt like hitting myself upon the top of my head repeatedly with a shovel =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to sort regular users and system users from /etc/passwd joeyBig Red Hat 9 05-29-2008 12:59 AM
How do I make it so regular users can access an automounted floppy? mugwump84 Linux - Newbie 4 04-02-2005 11:43 PM
regular users using halt TimmyP Debian 4 11-08-2004 03:06 AM
Network up/down by regular joe users bluefire Linux - Networking 1 08-22-2004 03:26 PM
change permissions for regular users... questionasker Linux - General 6 01-26-2004 01:07 PM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration