LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How to make a sound card a Default Sound Card (http://www.linuxquestions.org/questions/slackware-14/how-to-make-a-sound-card-a-default-sound-card-758379/)

Srikanth VM 09-29-2009 12:52 AM

How to make a sound card a Default Sound Card
 
Code:

alias snd-card-0 snd-ca0106
alias sound-slot-0 snd-ca0106

This is the contents of my sound file in modprobe.d
If there is an unclean shutdown it rolls back to onboard sound card HDA Intel ,how to make sure that this is the default card always ???
:confused:

And one more weird thing is that whenever i am in windows and shut it down from windows only , I get noise in slackware and if i boot into windows and then restart and boot back again to slackware it works fine and no noise is there , i had this problem in my previous distro also(CentOS), i thought it was a bug in it :scratch:


:newbie:

stormtracknole 09-29-2009 01:04 AM

As root on a terminal type:
Code:

alsaconf
Select your card and let the script do it's thing.

Run alsamixer to set up your volumes. When you do that, make sure that it selects the correct soundcard. Most of the time it does, but just in case, you can do the following:

For card number 1:
Code:

alsamixer -c0
Second soundcard:
Code:

alsamixer -c1
Once that completes, type the following as root:
Code:

alsactl store
About the hissing sound, when you run alsamixer to set the volume control, look to see if any of the IEC* channels are enabled. If they are, just mute it.

Hope this helps.

Srikanth VM 09-29-2009 03:15 AM

How can i make c0 ---> SB card
and c1 ---> HDAIntel card always ???

Daedra 09-29-2009 03:36 AM

you need to edit your /etc/modprobe.d/sound file. See this post, it worked for me

http://www.linuxquestions.org/questi...device-713793/

stormtracknole 09-29-2009 03:48 AM

Quote:

Originally Posted by Daedra (Post 3700322)
you need to edit your /etc/modprobe.d/sound file. See this post, it worked for me

http://www.linuxquestions.org/questi...device-713793/

Thanks for pointing that out. I need to make a mental note of that since my box has two sound cards also (one on-board and an extra pci).

Srikanth VM 09-29-2009 05:01 AM

ah thanks that was what i was looking for , i had configured sound file previously but i didnt know the the options to append


All times are GMT -5. The time now is 11:34 PM.