LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2007, 08:19 AM   #1
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Rep: Reputation: 0
How to install gnome-devel in slackware11


I want to build fvwm2.5.18 from source code in my system . After configuration , it says :
Quote:
With GNOME libs support in FvwmGtk? no: Can't find working gnome-config
So , gnome-devel is needed here. But I can't find this tgz package from internet.Who can tell me how to install it ?
 
Old 03-18-2007, 11:26 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Looks like you need to compile the GNOME libs. Does Fvwm really need GNOME libs ? Or is it optional ?

Does it give you an error ?
 
Old 03-18-2007, 11:57 AM   #3
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,755

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
Try running make and see if it succeeds. Sounds like it will -if configure fifished without fatal errors. There is no gnome-devel package. Each package of gnome will install it's own headers when applicable. gnome-config is part of the gnome-lbs package, but you need to build 4-5 other things to build gnome-libs. However, if you don't mind installing pre-compiled binaries you may be ablr to get by with just the gnome-libs package.
I have a small project area where I keep about 30 packages which proide basic gnome-compatibility:
http://distro.ibiblio.org/pub/linux/...E-COMPAT-2.10/
 
Old 03-18-2007, 08:30 PM   #4
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H
Looks like you need to compile the GNOME libs. Does Fvwm really need GNOME libs ? Or is it optional ?

Does it give you an error ?
I'm not sure. Mybe it's optional. Becanse with that report,I can bulid my fvwm2.5.18 successfully. I don't know for what gnome-devel is used here.
 
Old 03-18-2007, 10:33 PM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
It's probably optional ...
 
Old 03-19-2007, 04:37 AM   #6
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H
It's probably optional ...
You're right. I found that in fvwm2.5.18/INSTALL.fvwm:
Quote:
It is safe *not* to compile in the following features:
bidi (not needed if you don't plan to read Arabic and Hebrew)
gnome-libs (really not needed, used only in FvwmGtk for minor things)
 
Old 03-19-2007, 04:44 AM   #7
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gnashley
Try running make and see if it succeeds. Sounds like it will -if configure fifished without fatal errors. There is no gnome-devel package. Each package of gnome will install it's own headers when applicable. gnome-config is part of the gnome-lbs package, but you need to build 4-5 other things to build gnome-libs. However, if you don't mind installing pre-compiled binaries you may be ablr to get by with just the gnome-libs package.
I have a small project area where I keep about 30 packages which proide basic gnome-compatibility:
http://distro.ibiblio.org/pub/linux/...E-COMPAT-2.10/
thnak you for your packages.
I,ve installed packages in Milestone 1. But configuration also report message for lack gnome-config.
When I checked config.log , I found it will check gnomeConf.sh in gnome-libs' directory. Does gnome -lib surely contain gnomeConf.sh ?
 
Old 03-19-2007, 04:59 AM   #8
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
~~~~~~No use post~~~~~~~~~~

Last edited by terree; 03-19-2007 at 05:00 AM.
 
Old 03-19-2007, 07:22 AM   #9
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gnashley
Try running make and see if it succeeds. Sounds like it will -if configure fifished without fatal errors. There is no gnome-devel package. Each package of gnome will install it's own headers when applicable. gnome-config is part of the gnome-lbs package, but you need to build 4-5 other things to build gnome-libs. However, if you don't mind installing pre-compiled binaries you may be ablr to get by with just the gnome-libs package.
I have a small project area where I keep about 30 packages which proide basic gnome-compatibility:
http://distro.ibiblio.org/pub/linux/...E-COMPAT-2.10/
gnashley , after installing gnome-compact Milestone 1, I can't start mu Dorpline gnome ,with this error message:
Quote:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "terry"
/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- dbus-launch --exit-with-session gnome-session
gnome-session: symbol lookup error: /usr/lib/libgnome-2.so.0: undefined symbol: bonobo_activation_get_goption_group
how should I solve this problem?
 
Old 03-19-2007, 08:07 AM   #10
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,755

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
Why in the world would you install my packages if you already have a full gnome installation?
 
Old 03-19-2007, 08:20 PM   #11
terree
LQ Newbie
 
Registered: Feb 2006
Location: Beijing,China
Distribution: slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gnashley
Why in the world would you install my packages if you already have a full gnome installation?
I installed full Dropline gnome before. But when i built fvwm2.5.18, it reported missing gnome-config. So I posted this thread here.
I didn't know your gnome-lib would replace the lib of dropline gnome. So the error is that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome-devel | build-essential Branta Linux - Software 1 02-22-2007 02:57 AM
installing gnome-libs-devel/slackware 10.2? digitalmojo17 Linux - Software 1 05-04-2006 12:58 PM
Package fam-devel needs libselinux-devel belkins Linux - Newbie 2 10-18-2004 03:02 PM
gnome-libs-devel... Linux~Powered Slackware 0 09-04-2004 08:01 PM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 03:57 AM


All times are GMT -5. The time now is 09:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration