LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-04-2011, 10:59 AM   #1
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 49
How to Install extras/source/grub properly


Hello:

I copied the extras/source/grub folder to my home folder.

I did: ./grub.SlackBuild as su.

The install went on for a long time and I saw warnings etc flash by.

I don't know if it has installed properly. I tried it before and it destroyed my grub menu. I managed to recover grub through LMDE and now, I am back for more!

Is there any way to tell if this app is installed properly before I run grubconfig?

Thanks,
 
Old 02-04-2011, 11:12 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Just running the SlackBuild script creates the package, but doesn't install it. You should have seen a message at the end saying the package was created. Really, though, the package should have been in the extra directory anyway, so you shouldn't have had to run the SlackBuild script. You install packages with "installpkg filename", where filename is the filename of the package you want to install (ending in e.g. .txz).
 
Old 02-04-2011, 11:30 AM   #3
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Nylex View Post
Just running the SlackBuild script creates the package, but doesn't install it. You should have seen a message at the end saying the package was created. Really, though, the package should have been in the extra directory anyway, so you shouldn't have had to run the SlackBuild script. You install packages with "installpkg filename", where filename is the filename of the package you want to install (ending in e.g. .txz).
I forgot to say that I cd to /tmp and use pkgtool to install, only after that did I do a grub-install.

I did all of this as I was using the example I found at:http://genek.net/LinuxAdventures/sysadmin/slackpkg.html

I copied the grub folder to home because at that point the SlackDVD wouldn't appear in /media - this has been fixed thanks to this forum.

So, at this point, should I do as you suggested? Or, do I need to something first to negate/reverse what I have already done?

Thanks,
 
Old 02-04-2011, 12:08 PM   #4
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 49
Hello:

I found this is the directory:
Code:
root@roblap:/media/SlackDVD/extra/source/grub# ls
ext2-support-256byte-inodes.diff.gz  grub-0.97.tar.gz        grubconfig_ext4fix.patch.gz
ext4-support.diff.gz                 grub-0.97.tar.gz.sig    grubconfig_localefix.patch.gz
gcc4.diff.gz                         grub.SlackBuild         slack-desc
grub-0.97-x86_64.patch.gz            grubconfig-1.28.tar.gz
root@roblap:/media/SlackDVD/extra/source/grub#
Which one do I use with installpkg?

Thanks,
 
Old 02-04-2011, 12:24 PM   #5
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Hello,

From that directory, you'd use none, those are sources not created packages, the one you'll be using with installpkg should be in /media/SlackDVD/extra/grub/grub-{version}.txz (i.e: installpkg /media/SlackDVD/extra/grub/grub-0.97-i486-8.txz)
 
Old 02-04-2011, 12:34 PM   #6
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Acron_0248 View Post
Hello,

From that directory, you'd use none, those are sources not created packages, the one you'll be using with installpkg should be in /media/SlackDVD/extra/grub/grub-{version}.txz (i.e: installpkg /media/SlackDVD/extra/grub/grub-0.97-i486-8.txz)
Yikes!!!

Thanks Acron, it is amazing how screwed-up I can get!
 
Old 02-04-2011, 12:55 PM   #7
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 49
Hello:

I ran grubconfig and got this msg:

Quote:
The partition '/dev/sda' is mounted read-only, either unmount it or mount it read-write.
How do I do what it wants?
 
Old 02-04-2011, 01:06 PM   #8
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
If I remember correctly, there is a "read-only" flag in lilo.conf related to the kernel you're booting that you can comment to avoid that message.

EDIT:

Ups, my bad, didn't read exactly "/dev/sda" and I found another post of yours where you had that error as well.

Where is this error happening exactly? I mean, at what point of using grubconfig, remember that in some point you'll be asked where to save the grub files which by definition is the partition where you have /boot. If you have slackware installed in /dev/sda1 and you have /boot in the same partition as the root partition (/dev/sda1 for instance), then in grubconfig "/dev/sda1" would be the place to save the grub files.

This might help you with grubconfig.

Last edited by Acron_0248; 02-04-2011 at 01:18 PM.
 
1 members found this post helpful.
Old 02-04-2011, 02:09 PM   #9
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Acron_0248 View Post
If I remember correctly, there is a "read-only" flag in lilo.conf related to the kernel you're booting that you can comment to avoid that message.

EDIT:

Ups, my bad, didn't read exactly "/dev/sda" and I found another post of yours where you had that error as well.

Where is this error happening exactly? I mean, at what point of using grubconfig, remember that in some point you'll be asked where to save the grub files which by definition is the partition where you have /boot. If you have slackware installed in /dev/sda1 and you have /boot in the same partition as the root partition (/dev/sda1 for instance), then in grubconfig "/dev/sda1" would be the place to save the grub files.

This might help you with grubconfig.
Thanks Acron, this fixed it as soon as I used: /dev/sda7 which is where the root directory for Slackware is.

My grub menu only launches xp and Slackware at the moment but this will give me yet another opportunity learn more about linux.

Thanks again for your help.
 
Old 02-04-2011, 02:16 PM   #10
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
happy slacking then
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Grub/ Grub2/ Lilo - canīt install any of them properly! spoovy Slackware 26 11-19-2010 07:35 AM
Problems with /boot/grub/grub.conf not being read properly on reboots cmeyer Linux - Software 1 10-11-2008 07:34 PM
fc3 install doesnt install grub properly onto sata drive sabo Linux - Newbie 4 02-03-2007 05:04 PM
Gnome Apps don't work properly on KDE 3.5 & unable to install Tar source on mandriva zouzou85 Mandriva 6 01-14-2007 08:11 AM
how to properly install kernel source in Debian ? kix_vn Debian 8 03-20-2004 02:30 PM


All times are GMT -5. The time now is 04:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration