LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How to Install extras/source/grub properly (http://www.linuxquestions.org/questions/slackware-14/how-to-install-extras-source-grub-properly-860710/)

Robert.Thompson 02-04-2011 09:59 AM

How to Install extras/source/grub properly
 
Hello:

I copied the extras/source/grub folder to my home folder.

I did: ./grub.SlackBuild as su.

The install went on for a long time and I saw warnings etc flash by.

I don't know if it has installed properly. I tried it before and it destroyed my grub menu. I managed to recover grub through LMDE and now, I am back for more!

Is there any way to tell if this app is installed properly before I run grubconfig?

Thanks,

Nylex 02-04-2011 10:12 AM

Just running the SlackBuild script creates the package, but doesn't install it. You should have seen a message at the end saying the package was created. Really, though, the package should have been in the extra directory anyway, so you shouldn't have had to run the SlackBuild script. You install packages with "installpkg filename", where filename is the filename of the package you want to install (ending in e.g. .txz).

Robert.Thompson 02-04-2011 10:30 AM

Quote:

Originally Posted by Nylex (Post 4248375)
Just running the SlackBuild script creates the package, but doesn't install it. You should have seen a message at the end saying the package was created. Really, though, the package should have been in the extra directory anyway, so you shouldn't have had to run the SlackBuild script. You install packages with "installpkg filename", where filename is the filename of the package you want to install (ending in e.g. .txz).

I forgot to say that I cd to /tmp and use pkgtool to install, only after that did I do a grub-install.

I did all of this as I was using the example I found at:http://genek.net/LinuxAdventures/sysadmin/slackpkg.html

I copied the grub folder to home because at that point the SlackDVD wouldn't appear in /media - this has been fixed thanks to this forum.

So, at this point, should I do as you suggested? Or, do I need to something first to negate/reverse what I have already done?

Thanks,

Robert.Thompson 02-04-2011 11:08 AM

Hello:

I found this is the directory:
Code:

root@roblap:/media/SlackDVD/extra/source/grub# ls
ext2-support-256byte-inodes.diff.gz  grub-0.97.tar.gz        grubconfig_ext4fix.patch.gz
ext4-support.diff.gz                grub-0.97.tar.gz.sig    grubconfig_localefix.patch.gz
gcc4.diff.gz                        grub.SlackBuild        slack-desc
grub-0.97-x86_64.patch.gz            grubconfig-1.28.tar.gz
root@roblap:/media/SlackDVD/extra/source/grub#

Which one do I use with installpkg?

Thanks,

Acron_0248 02-04-2011 11:24 AM

Hello,

From that directory, you'd use none, those are sources not created packages, the one you'll be using with installpkg should be in /media/SlackDVD/extra/grub/grub-{version}.txz (i.e: installpkg /media/SlackDVD/extra/grub/grub-0.97-i486-8.txz)

Robert.Thompson 02-04-2011 11:34 AM

Quote:

Originally Posted by Acron_0248 (Post 4248438)
Hello,

From that directory, you'd use none, those are sources not created packages, the one you'll be using with installpkg should be in /media/SlackDVD/extra/grub/grub-{version}.txz (i.e: installpkg /media/SlackDVD/extra/grub/grub-0.97-i486-8.txz)

Yikes!!!

Thanks Acron, it is amazing how screwed-up I can get!

Robert.Thompson 02-04-2011 11:55 AM

Hello:

I ran grubconfig and got this msg:

Quote:

The partition '/dev/sda' is mounted read-only, either unmount it or mount it read-write.
How do I do what it wants?

Acron_0248 02-04-2011 12:06 PM

If I remember correctly, there is a "read-only" flag in lilo.conf related to the kernel you're booting that you can comment to avoid that message.

EDIT:

Ups, my bad, didn't read exactly "/dev/sda" and I found another post of yours where you had that error as well.

Where is this error happening exactly? I mean, at what point of using grubconfig, remember that in some point you'll be asked where to save the grub files which by definition is the partition where you have /boot. If you have slackware installed in /dev/sda1 and you have /boot in the same partition as the root partition (/dev/sda1 for instance), then in grubconfig "/dev/sda1" would be the place to save the grub files.

This might help you with grubconfig.

Robert.Thompson 02-04-2011 01:09 PM

Quote:

Originally Posted by Acron_0248 (Post 4248472)
If I remember correctly, there is a "read-only" flag in lilo.conf related to the kernel you're booting that you can comment to avoid that message.

EDIT:

Ups, my bad, didn't read exactly "/dev/sda" and I found another post of yours where you had that error as well.

Where is this error happening exactly? I mean, at what point of using grubconfig, remember that in some point you'll be asked where to save the grub files which by definition is the partition where you have /boot. If you have slackware installed in /dev/sda1 and you have /boot in the same partition as the root partition (/dev/sda1 for instance), then in grubconfig "/dev/sda1" would be the place to save the grub files.

This might help you with grubconfig.

Thanks Acron, this fixed it as soon as I used: /dev/sda7 which is where the root directory for Slackware is.

My grub menu only launches xp and Slackware at the moment but this will give me yet another opportunity learn more about linux.

Thanks again for your help.

Acron_0248 02-04-2011 01:16 PM

happy slacking then :)


All times are GMT -5. The time now is 01:37 PM.