Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-28-2004, 09:05 AM   #1
Registered: Nov 2004
Location: Montreal
Distribution: Slackware 14.1
Posts: 161

Rep: Reputation: 15
How to install a Labtec webcam?

I just installed Slackware 10.1. I downloaded and compiled from scratch the last Linux 2.6.10 from the Linux Headquarters on an AMD 64 SATA machine.
Everything is working fine!
Except that Labtec webcam. It shows in the infoenter of KDE in the USB section.
But whehn I try to access it with xawtv...
Do I need a driver?
How to install it?
Please help.

Old 12-28-2004, 06:07 PM   #2
Registered: Aug 2003
Posts: 44

Rep: Reputation: 15
Here is a page with software that might work.

There is also this. I'm sure one of them works because I have been there and got a Labtec camera working myself. Just build and install the module and load it on boot from one of the /etc/rc.d scripts.
Old 03-06-2005, 03:01 PM   #3
Registered: Jan 2005
Location: Not up there but not down there!
Posts: 94

Rep: Reputation: 15
i cant figure out how to compile it. what were you saying about the boot?
Old 03-14-2005, 10:17 PM   #4
Registered: Nov 2004
Location: Montreal
Distribution: Slackware 14.1
Posts: 161

Original Poster
Rep: Reputation: 15
How to intall a Labtec Webcam

I compiled and installed the spca5xx module as explained:
root@hal:/etc/rc.d# lsmod
Module Size Used by
spca5xx 286616 0
radeon 130004 2
pl2303 18628 0
ati_remote 11272 0
amd64_agp 9544 1
agpgart 29036 2 amd64_agp
Now I created the device:
mknod /dev/video1 c 81 1
Now when I execute the command:
root@hal:/dev# spcaview -f yuv -d /dev/video1
Spcaview version:0.41 date: 1:01:2005 (C)
Initializing SDL.
SDL initialized.
bpp 3 format 15
Using video device /dev/video1.
Initializing v4l.
ERROR opening V4L interface
: No such device
I get the message:
ERROR opening V4L interface
I tied to do the same on a different computer.
Same message:
ERROR opening V4L interface
What´s wrong?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Install A Usb Webcam [Genius WebCam on Suse 9.1 Personal] ofvergara SUSE / openSUSE 4 11-29-2006 12:09 PM
how to get labtec webcam to work? greenbox Linux - Hardware 12 03-21-2005 11:22 AM
Labtec Webcam Rh9 2.4.20-6 install help konflict676 Linux - Hardware 0 07-28-2004 10:47 AM
Labtec Webcam No Drivers Either Kryptow Linux - Hardware 0 10-13-2002 04:18 AM
Labtec Webcam.........Can it work? Kryptow Linux - Hardware 3 09-16-2002 10:42 AM

All times are GMT -5. The time now is 08:45 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration