LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2006, 03:20 PM   #1
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
how to have cd-burner and dvd-burner? slack


Hi all

I can burn cd's no problem on my cd-burner, actually I really do get 52x speeds could never get that in windows.

Anyway....

However I also have a DVD burner here too. All the threads here I find are for people like in Shilo's situation that have just a DVD burner/rom...but not TWO devices like I do. I can't see my DVD and shilo's sticky doesnt work for me as I already have fstab of:

Quote:
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
I do have a "block device" called "cdrom" in /dev

I don't see any "block devices" called "dvdrom" or anything similar in my /dev.

I do see "block devices" of "hdd" "hdd1" ,etc.

Should I maybe do a symlink of so I can see the DVD burner:

Quote:
ln -s /dev/hdd /dev/dvdrom
Thank you in advance
 
Old 05-02-2006, 03:33 PM   #2
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 231
Blog Entries: 1

Rep: Reputation: 34
Yes, but since xine and others default to /dev/dvd maybe that's a better choice of names.
 
Old 05-02-2006, 04:53 PM   #3
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Do something like:

dmesg | grep hd

To find which block device is your DVD burner, then just create the symlink like you were thinking. The name is up to you, but /dev/dvd does tend to be the default for most programs. Though personally, I have two links to my actual device, /dev/dvd and /dev/dvdrw.

Then you would create an appropriate line in /etc/fstab for the device.

By the way, the link to /dev/dvd is really just for convenience, there is nothing stopping you from just using /dev/hdb or whatever the device file is for the burner on your system.
 
Old 05-02-2006, 07:32 PM   #4
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
When I try "dmesg | grep hd" i get

root@pooter:~# dmesg | grep hd
ide-scsi: unsup command: dev hdd: flags = REQ_CMD REQ_STARTED
end_request: I/O error, dev hdd, sector 0

So two questions, does slack see this DVD as "hdd" is that what that output gave me?

Last edited by Old_Fogie; 06-09-2006 at 03:30 PM.
 
Old 05-02-2006, 08:06 PM   #5
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Rep: Reputation: 31
I also have both dvd and cd burners on the same ide cable. I think the dvd burner is selected as master, and both show OK in k3b.
I can mount the dvd burner by doing #mount /dev/sr0 /mnt/cdrom,
and the cd burner by doing #mount /dev/hdd /mnt/cdrom
my fstab is /dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0

I don't remember doing anything special to make them work.

Here's the output of $dmesg | grep hd
Kernel command line: auto BOOT_IMAGE=Slackware10.2 ro root=301 hdc=ide-scsi
ide_setup: hdc=ide-scsi
ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdcMA, hddMA
hda: Maxtor 6E030L0, ATA DISK drive
hdc: PIONEER DVD-RW DVR-108, ATAPI CD/DVD-ROM drive
hdd: ASUS CRW-2410A, ATAPI CD/DVD-ROM drive
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 60058656 sectors (30750 MB) w/2048KiB Cache, CHS=3738/255/63, UDMA(133)
hdd: attached ide-cdrom driver.
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
hda: hda1 hda2 hda3
hdc: attached ide-scsi driver.

In /etc/lilo.conf I have the line: append="hdc=ide-scsi"
this was added during install of slackware.


Edit: WTF are those smilies doing in my BIOS lines???!

Last edited by WilliamS; 05-02-2006 at 08:08 PM.
 
Old 05-02-2006, 08:30 PM   #6
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,768

Rep: Reputation: 204Reputation: 204Reputation: 204
Why are you guys still using ide-scsi??

It was deprecated years ago. I'm not surprised you're having problems with it now.
Quote:
Originally Posted by WilliamS
WTF are those smilies doing in my BIOS lines???!
Your BIOS really likes you.
 
Old 05-02-2006, 08:48 PM   #7
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
LOL at the smileys comment you had hahahah.

But OMG OMG you William your comment just caught my eye and steered me to my lilo.conf of all things. I think you just indirectly fixed me

I am using the 2.6.10 kernel when I boot up I allways get some comment that ide-scsi is depracated..

I saw in my lilo I have append="hdd=ide-scsi apm=power-off"

Ow just banged my toe..

Last edited by Old_Fogie; 06-09-2006 at 03:32 PM.
 
Old 05-02-2006, 08:49 PM   #8
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
omg i just posted that and see rkelson's post now.
 
Old 05-02-2006, 08:55 PM   #9
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
Oh lastly:

I did make the symlinks:

Quote:
ln -s /dev/hdd /dev/dvdrw
ln -s /dev/hdd /dev/dvd
Would the following fstab be ideal for reading DVD's :

Quote:
/dev/hdd /mnt/dvd-rom iso9660 noauto,user,ro 0
0

Thanks again a ton.

Last edited by Old_Fogie; 06-10-2006 at 12:39 AM.
 
Old 05-02-2006, 09:04 PM   #10
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,768

Rep: Reputation: 204Reputation: 204Reputation: 204
Quote:
Originally Posted by Old_Fogie
Ow just banged my toe..
You need to "mount /dev/slippers"
 
Old 05-02-2006, 09:12 PM   #11
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
R-o-o-o-o-o-f-l-z
 
Old 05-03-2006, 12:04 AM   #12
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
after i told fstab to use the above my KDE shows DVD in the list of available devices now in storage.
 
Old 05-03-2006, 07:11 AM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,270
Blog Entries: 3

Rep: Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445
Quote:
Originally Posted by Old_Fogie
LOL at the smileys comment you had hahahah.


But OMG OMG you William your comment just caught my eye and steered me to my lilo.conf of all things. I think you just indirectly fixed me

I am using the 2.6.10 kernel when I boot up I allways get some comment that ide-scsi is depracated..but really did not know what it meant, the pc just worked and I'm only 2 months into slack so now I'm into tweaking stages...ie the DVD issue.

I saw in my lilo I have append="hdd=ide-scsi apm=power-off"

And I think Linux saw my DVD as "hdd" and made it scsi..

So I took out the part hdd=ide-scsi and right mounted it and I'm watching a DVD.

I opened up K3B and it saw the drive too...so maybe it will work.

Ow just banged my toe..

Anyway..I can mount a cd too and read data off it. So my guess is I'm good for now.

Only thing is ...when I'm in KDE and I click on "go to -- storage media" i do not see a device entry for DVD. Any thoughts on that all?
Hi,

You could place the;

Code:
append="hdd=ide-scsi"
in your 2.4 stanza of the lilo.conf file.

The insert;

Code:
append="hdd=ide-cd"
for the 2.6 stanza would pass the parameter for the kernel since the ide-cd is now the module that is used. This can be done to force the assignment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD Burner not working under slack 10.2 kernel 2.4.31 kde 4.3 duhasst0 Linux - Hardware 1 12-29-2005 09:59 AM
Problem with 2.6.8 and DVD burner - Slack 10 failure_man Slackware 10 08-20-2004 10:27 AM
dvd-rom drive won't play movies and dvd burner won't record calble Linux - Hardware 1 08-09-2004 07:35 AM
No CD Burner in Slack 9.0....Help!!!!! PenguinPwrdBox Slackware 5 04-12-2004 08:58 AM
trying to mount cd burner, cd burner being a whore lasalsademuerte Slackware 5 12-09-2003 03:56 PM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration