LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2007, 12:09 PM   #1
notsay
LQ Newbie
 
Registered: Oct 2004
Location: China
Distribution: redhat,debian,redflag
Posts: 12

Rep: Reputation: 0
how to get utf8 support for auto mount by hal(udev)?


My Slackware linux can auto mount or unmount USB-disk by udev, but when USB-disk mounted by udev, there is a bad interface, all chinese word display "???", I think should mount -o iocharset=zh_CN.utf8 , but auto mount by udev , I dont' know how to edit mount rules.
 
Old 09-11-2007, 09:04 AM   #3
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
Don't understand that solution. Is there another way? To cause HAL mount vfat with exact flags, such as iocharset=utf-8.
Why should i edit my fstab? I don't want to. Wanna mount any vfat filesystem with correct options. Example:
today i connect my flashdrive, ok, an entry for it /dev/sda1 in fstab is suitable for me
tomorrow i connect flashdrive with reiserfs, which doesn't understand iocharset option
day after tomorrow i connect two flashdrives, so i should create two entries in my fstab and so on.
There should be away to make HAL mount the filesystem with the option. And not using any third-party like http://slackwareart.blogspot.com/200...slackware.html when a program EDITS(imagine that) my fstab every time i insert my flashdrive into usb port. fstab is something static, not dynamic
 
Old 03-18-2008, 04:50 AM   #4
nemetho
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
mount options

I hope this will help:

#settings for specific devices
gnome-mount --display-settings --device /dev/sda1
gnome-mount --write-settings --fstype vfat --mount-options utf8 --device /dev/sda1
gnome-mount --erase-settings --device /dev/sda1

#general options for fstypes
#get options
gconftool -g /system/storage/default_options/vfat/mount_options
#set options
gconftool -s /system/storage/default_options/vfat/mount_options --list-type=string -t list [shortname=lower,uid=,flush,utf8]
 
Old 03-22-2008, 04:51 AM   #5
eumetaxas
LQ Newbie
 
Registered: Sep 2006
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by nemetho View Post
I hope this will help:
gconftool -g /system/storage/default_options/vfat/mount_options
#set options
gconftool -s /system/storage/default_options/vfat/mount_options --list-type=string -t list [shortname=lower,uid=,flush,utf8]
THANK YOU!
I've been trying for days to fix this and is so simple!(i am on debian testing now.) in ubuntu it's set by default.
THANK YOU AGAIN!
 
Old 03-22-2008, 02:59 PM   #6
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
Code:
# which gconf
which: no gconf in (/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/qt/bin:/root/scripts)
Actually neither gconf, nor gnome-mount is available on standard Slackware distribution.

Do you compile a custom kernel? I, myself solved it by setting the default charset to utf-8
Code:
Location:                                                               
  │     -> File systems                                                     
  │       -> Native language support
 
  


Reply

Tags
fstab, usb, utf8


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hal/dbus mount utf8 ToK Linux - Software 0 05-30-2007 01:53 AM
DVD (auto)mount problem, gnome-mount, hal, Fedora C 5 lazarion Linux - Hardware 5 01-10-2007 04:45 AM
mount problem after hal udev install itzig Slackware 18 04-28-2006 05:05 AM
How to let hal mount DOS/Win partition with UTF8? shreks Fedora 0 01-16-2006 10:27 AM
Multifunction support - Hal and Udev flebber Linux - Hardware 1 06-18-2005 09:44 PM


All times are GMT -5. The time now is 02:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration