LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-23-2012, 05:10 PM   #1
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,071

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
How to get GPM & Synaptic Touchpad/USB Mouse working in 13.37?


hey guys,
my old Averatec 3150 with Slackware 13.37 (2.6.37.6-smp) is working great except GPM is not working for either the synaptic touchpad or my USB mouse.
NOTE: The synaptic pad and usb mouse work, just not for GPM.
basically the mouse and synaptic work when X is running, but in console mode GPM is not working with either

I have googled and found nothing..
any ideas on how to get GPM working with both?
thanks
 
Old 01-23-2012, 05:53 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,281
Blog Entries: 3

Rep: Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446Reputation: 1446
Member response

Hi,

Quote:
#!/bin/sh
# Start/stop/restart the GPM mouse server:

if [ "$1" = "stop" ]; then
echo "Stopping gpm..."
/usr/sbin/gpm -k
elif [ "$1" = "restart" ]; then
echo "Restarting gpm..."
/usr/sbin/gpm -k
sleep 1
/usr/sbin/gpm -m /dev/mouse -t imps2
else # assume $1 = start:
echo "Starting gpm: /usr/sbin/gpm -m /dev/mouse -t imps2"
/usr/sbin/gpm -m /dev/mouse -t imps2
fi

# There is another way to run GPM, where it acts as a repeater outputting a
# virtual MouseSystems mouse on /dev/gpmdata. This is useful for feeding
# gpm's data to X, especially if you've got a busmouse (in that situation X
# and gpm may not coexist without using a repeater). To try running a GPM
# repeater for X, change the gpm command line to look like this:
# /usr/sbin/gpm -R msc -m /dev/mouse -t imps2
# Then, make sure that the mouse configuration in your XF86Config file refers
# to the repeater device (/dev/gpmdata) and a MouseSystems mouse type. If you
# edit the file directly, you'll want the lines to look like this (minus the
# comment marks '#' shown here, of course):
#Section "Pointer"
# Protocol "MouseSystems"
# Device "/dev/gpmdata"
What about trying a repeater as suggested above?

Or this thread should help;

Setting up a USB mouse in Slackware
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to auto disable the synaptic touchpad if usb mouse present? george-lappies Slackware 9 08-01-2011 04:18 AM
USB mouse not working but touchpad does DiverDown Linux - Newbie 5 04-09-2006 06:03 PM
synaptic(alps) touchpad coworking with usb mouse. lvgandhi Debian 1 10-06-2005 11:46 AM
touchpad/mouse won't work in X 2.4.26 kernel synaptics/gpm issue? dns21 Slackware 4 10-15-2004 12:34 AM
USB mouse not working with touchpad cb951303 Slackware 2 09-08-2004 06:28 PM


All times are GMT -5. The time now is 05:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration