LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-04-2013, 01:58 PM   #1
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 336

Rep: Reputation: 27
How to get both monitors to turn on at startup?


When I startup xfce, I have to do this:

xrandr --output DFP4 --auto
xrandr --output DFP4 --auto --right-of DFP3

To get my right monitor to turn on and have the desktop expanded across it. Otherwise it starts up with DFP3 on, and DFP4 off. Using amdcccle doesn't work - the settings don't seem to get saved, and are reset on startup, even when I do it as root. While this is not a major inconvenience, curious minds would like to know - is there way to get the displays to do this automatically?

Slackware 14.0 64 bit. Radeon HD 5870. 3.6.11 kernel.
 
Old 05-04-2013, 02:14 PM   #2
Marcelo_Belfalas
LQ Newbie
 
Registered: Apr 2012
Location: Brazil
Distribution: Slackware64-current multilib
Posts: 23

Rep: Reputation: 10
rc.local is a way to do it. But maybe there's a more specific configuration.
 
Old 05-04-2013, 02:38 PM   #3
chemfire
Member
 
Registered: Sep 2012
Posts: 69

Rep: Reputation: Disabled
Put your two xrandr lines in a shell script. Just copy them to a new text file and add

#!/bin/bash

as the first line. Save it somewhere in your home directory. Change the permissions so that its executable. Open the control panel in XFCE and select "Session and startup" Add your shell script to "Application auto start".

You could also modify your ~/.xession or /etc/X11/xintric
 
Old 05-04-2013, 03:26 PM   #4
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 336

Original Poster
Rep: Reputation: 27
Quote:
Originally Posted by chemfire View Post
Put your two xrandr lines in a shell script. Just copy them to a new text file and add

#!/bin/bash

as the first line. Save it somewhere in your home directory. Change the permissions so that its executable. Open the control panel in XFCE and select "Session and startup" Add your shell script to "Application auto start".

You could also modify your ~/.xession or /etc/X11/xintric
Adding it to Session and Startup did the trick - works very nice, TYVM! I would not have thought of that...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot turn off one of the 'dual' monitors yosato_uk Linux - Hardware 1 08-22-2011 01:39 PM
Dual Monitors Nvidia 9500 GT, I have to turn on the 2nd monitor after startup rcaca0 Linux - Hardware 2 03-01-2010 03:09 PM
[SOLVED] 2 monitors, turn one off vendtagain Linux - Hardware 8 01-02-2010 05:22 AM
LCD monitors + Fluxbox = bulbs dont turn off on powersave wakeboarder3780 Slackware 7 01-15-2007 03:50 AM
LCD monitors / Fluxbox / bulbs dont turn off wakeboarder3780 Linux - Hardware 2 01-13-2007 09:07 PM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration