LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-20-2005, 10:18 AM   #1
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Rep: Reputation: 15
how to get ATI drivers to work?


I have the latest ATI drivers installed in Slackware 10.1. I thought everything was working smooth but I realized when I ran "glxinfo" that direct rendering was not on. It turns out that the fglrx driver module is not running on my system. When I do a "modprobe fglrx" it finds the module, but it says that the operation is not permitted..

I am wondering if the reason the module isn't loading is because I have the kernel configured wrong? Originally I had the kernel's own AGPgart built in to the kernel, so I removed that from the kernel and fglrx will still not load. Do I need to do anything with the "Direct Rendering Managment" section of the kernel under Character Devices? My current kernel has Direct Rendering enabled.

Any help is appreciated.
 
Old 07-20-2005, 10:37 AM   #2
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
You need AGPGART as a module in the kernel.
 
Old 07-20-2005, 10:54 AM   #3
glussier
Member
 
Registered: Jul 2005
Location: Montreal, Qc, Canada
Distribution: Fedora Core 5/6 Slackware 10.1/11
Posts: 120

Rep: Reputation: 15
Make sure the 3 following lines are uncommented in your /etc/X11/xorg.conf file.

Code:
Section "DRI"
    Mode 0666
EndSection
Restart x and it should be working
 
Old 07-20-2005, 10:59 AM   #4
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
AGPGART is probably not the issue here - I have it compiled in, and it never causes any bother

Your problem is probably Direct Rendering Manager - disable it in your kernel.
 
Old 07-20-2005, 10:59 AM   #5
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by glussier
Make sure the 3 following lines are uncommented in your /etc/X11/xorg.conf file.

Code:
Section "DRI"
    Mode 0666
EndSection
Restart x and it should be working
Yeah, those are uncommented. The fglrx still doesn't load. I think there is some kind of incompatibility on my system between the kernel and the driver for some reason, I have no idea.
 
Old 07-20-2005, 11:03 AM   #6
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
maybe a stupid Q., but you do have ' Driver "fglrx" ' in your xorg.conf file ?
( in the ' device ' section. )

egag
 
Old 07-20-2005, 11:21 AM   #7
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15
egag- yeah I have the 'fglrx' in the config file. I just did a Google search, and from what I read (actually an old post on this forum) it says that the fglrx driver and Nvidia Nforce 2 based motherboards cause problems with ATI's Linux drivers. I have an Nforce 2 motherboard so I wonder about that. I am still not sure what to do to fix it.
 
Old 07-20-2005, 11:33 AM   #8
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
As I posted earlier, have you tried disabled Direct Rendering Management yet? It is prone to interfere with fglrx, and cannot co-exist with it in newer kernels (2.6.11+).
 
Old 07-20-2005, 11:33 AM   #9
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
in your first post you said that everything looked good.
which driver was/is loaded then ?

i got a " not permitted " error when doing a " modprobe fglrx " while the " radeon " driver was loaded.

egag
 
Old 07-20-2005, 11:44 AM   #10
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by egag
in your first post you said that everything looked good.
which driver was/is loaded then ?

i got a " not permitted " error when doing a " modprobe fglrx " while the " radeon " driver was loaded.

egag
By looked good I mean that the install of the ATI drivers went fine, no errors at all and it properly set up my xorgconf file. But then when I did a lsmod I was disappointed to see that they weren't actually loaded up. So I mean that since the install went fine I had originally assumed that the driver was working so I didn't initially think there was any problems until I tried to install a few 3-d games that just give me pages of errors because of opengl problems.

Right now when I do an lsmod there are no drivers loaded that have anything to do with video or 3d. Just my sound drivers are loaded. I tried to put the following in to rc.local just for experimentation purposes:

modprobe agpgart
modprobe fglrx

but that doesn't start up fglrx either. It just spits out the same error.

I found this thread here: http://www.linuxquestions.org/questi...03/11/4/114078
that is kind of helpful. It references a thread by a poster named "EnigmaZ" but does not link to the thread. I have tried to search for the thread but I didn't turn up anything. Maybe if I can find that thread I will be able to figure out how to fix it.

Last edited by kholdstayr; 07-20-2005 at 11:48 AM.
 
Old 07-20-2005, 11:50 AM   #11
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Click HERE to see this thread with all of the graphics, features, and links.

And all the threads posted by enigma Z :
http://www.linuxquestions.org/questi...archid=4237530

Last edited by keefaz; 07-20-2005 at 11:59 AM.
 
Old 07-20-2005, 12:08 PM   #12
kholdstayr
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 36

Original Poster
Rep: Reputation: 15
Problem solved. Thank you cathectic. I compiled a new kernel and disabled the kernel's own Direct Rendering code and fglrx loads up when I do a startx. Also, when I do a glxinfo it says I have direct rendering turned on. I think I owe cathectic somethinig now, I should have tried that right away.

I read all of the ATI documentation about their Linux drivers and they do not mention that. I would wish that they had better information. Yesterday I was reading an OpenGL in Linux site that said you should have the Direct Rendering drivers enabled in the kernel so that was part of the reason why I was stubborn about changing my kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
at long last, the new ati drivers WORK! garba Linux - Hardware 1 11-08-2005 10:02 AM
ATI DRIVERS WORK NOW! Kernel 2.6.11 antidelldude Fedora 51 08-25-2005 12:49 PM
Trying to get new ATI OpenGL drivers to work jgpatton Suse/Novell 2 07-31-2005 06:51 PM
cannot get DRI to work with ATI fglrx drivers under X alesz Fedora 2 06-09-2005 07:39 AM
winex3 with the ati 3.7.0 drivers doesnt work LavaDevil94 Linux - Games 0 01-24-2004 03:05 PM


All times are GMT -5. The time now is 07:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration