LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-19-2013, 10:19 AM   #1
pardalian
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Rep: Reputation: 0
how to get an wireless iw3945 on Slackware 14 working?


Hi.
I have installed Slackware14 x86 on a Dell latitude D820 and I do not know how to get the wireless adapter to work.

I am sure that my wireless adapter is a 3945ABG I used lspci to identify it

I manged to find some iwlwifi-3945-ucode files from slackware.com/~alien/slackbuilds/ and from wireless.kernel.org/en/users/Drivers/iwlegacy but I haven't been able to install none of them from the guides or tutorials about installation (at least not correctly)

Note I have freshly reinstalled the Slack so that all that I did will not affect your advice, I am waiting for guidance

I have read what I could find on the internet and here on Linuxquestions but nothing worked for me so far.

If anyone could help please note that I am a 48 hours beginner so pretty please step by step if you can .
 
Old 01-19-2013, 10:52 AM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
http://mirrors.dotsrc.org/slackware/...fi-3945-ucode/

ftp://ftp.splack.org/pub/splack/spla...4.1.5-fw-1.tgz

Last edited by tuxbg; 01-19-2013 at 11:01 AM.
 
Old 01-19-2013, 11:05 AM   #3
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
modprobe iwlegacy
 
Old 01-19-2013, 11:37 AM   #4
pardalian
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
ok I have downloaded the files but I might need some help to install them
the modprobe iwlegacy results in: FATAL: module iwlegacy not found
 
Old 01-19-2013, 11:43 AM   #5
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
installpkg <package name>
And here is a module http://www.slackware.com/~alien/slac...945.SlackBuild

Just download all files in that directory and become root.Then run sh ipw3945.SlackBuild,after that install package.Then modprobe ipw3945

Last edited by tuxbg; 01-19-2013 at 11:44 AM.
 
Old 01-19-2013, 12:06 PM   #6
pardalian
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
ok did all that but the sh command gives me an error :

.....

ipw3945d-1.7.22/LICENSE.ipw3945d
ipw3945d-1.7.22/x86_64/
ipw3945d-1.7.22/x86_64/ipw3945d
ipw3945d-1.7.22/README.ipw3945d
Building ...

WARNING: Your kernel contains ieee80211 symbol definitions and you
are not using the kernel's default ieee80211 subsystem. (Perhaps you
used the out-of-tree ieee80211 subsystem's 'make install' or have
provided a path to the ieee80211 subsystem via IEEE80211_INC.)

If you wish to use the out-of-tree ieee80211 subsystem then it is
recommended to use that projects' "make patch_kernel" facility
and rebuild your kernel to update the Module symbol version information.

Failure to do this may result in build warnings and unexpected
behavior when running modules which rely on the ieee80211 subsystem.


Aborting the build. You can force the build to continue by adding:

IEEE80211_IGNORE_DUPLICATE=y

to your make command line.


make: *** [check_inc] Error 1
install: cannot stat 'ipw3945.ko': No such file or directory
ipw3945.SlackBuild FAILED at line 188!
 
Old 01-19-2013, 12:36 PM   #7
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
I dont know about that error but here is a package http://www.slackware.com/~alien/slac...3945/pkg/11.0/
 
Old 01-19-2013, 01:27 PM   #8
pardalian
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Thx but sill not working I understand that I have to configure a file named firmware.agent but the location specified does not exist (/etc/hotplug/firmware.agent)
 
Old 01-19-2013, 01:55 PM   #9
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Where you read this ?
Just install firmware and the package that include intel module,reboot your machine,and then modprobe modules

Last edited by tuxbg; 01-20-2013 at 06:04 AM.
 
Old 01-20-2013, 09:03 PM   #10
red_fire
Member
 
Registered: Jan 2007
Location: Indonesia
Distribution: Slackware Linux
Posts: 51

Rep: Reputation: 8
that's really weird.. mine has been working out of the box since Slackware 13.0. you shouldn't need to install anything else. I use kernel-huge, try booting that one first and then check if the module is loaded.

first remove the driver you installed to prevent conflicts. then, edit /etc/lilo.conf and point the booting to your kernel-huge in /boot . If you did a full installation, it should be there. I don't use lilo myself but it should look similar to this

Code:
.
.
.
# Linux bootable partition config begins
image = /boot/vmlinuz-huge-kernel-version
  root = /dev/sda6
  label = Slackware
  read-only
# Linux bootable partition config ends
.
.
.
don't forget to run
Code:
#lilo
to update the configuration.

after booting, check if the module is loaded.

Code:
#lsmod
(the name of the module is iwl3945 under iwl_legacy)
otherwise, load the module.

Code:
#modprobe iwl3945
if you use GUI, try using wicd (can be found in slackware official repository under /extra) or NetworkManager (should be installed) to test the wireless. start NetworkManager first

Code:
#chmod +x /etc/rc.d/rc.networkmanager
#/etc/rc.d/rc.networkmanager start
then it should be loaded automatically in KDE and XFCE when either one starts.

Last edited by red_fire; 01-21-2013 at 04:27 PM.
 
1 members found this post helpful.
Old 01-21-2013, 11:03 AM   #11
pardalian
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
I'm not home for another two days to try but I'll let you know if it works ... thank you
 
Old 01-22-2013, 04:32 AM   #12
pardalian
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you very much ... it seems that the problem was my install disk (I realised that when my lilo started acting up and other processes failed) ... after re-burning the slack image on a new dvd even the install process went faster and the wifi was installed "out of the box" it was only a matter of starting the networkmanager : /etc/rc.d/rc.networkmanager start and problem solved.

thank you for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot get wireless working in slackware retne_cow Slackware 10 10-25-2011 02:23 AM
Slackware 13 wireless not working (ath9k) Cryophile Slackware 9 12-17-2009 06:10 PM
Unable to get wireless working with Slackware victor5 Linux - Laptop and Netbook 3 10-08-2009 12:27 PM
Wireless not working on Slackware 12 Rommeo Slackware 3 05-14-2008 07:06 PM
Wireless not working on Slackware 12 grandbazaar Linux - Wireless Networking 8 02-25-2008 07:56 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration