LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-04-2012, 10:40 AM   #1
raphaeldavidf
Member
 
Registered: Sep 2012
Location: São Paulo, Brazil
Distribution: Slackware 14.0
Posts: 33

Rep: Reputation: 17
How to Fix Wine slow start problem on Slackware 14.0


Hey guys,

I don't know if any one got the same problem but here goes the problem and the fix (for me at least it worked quite well). I installed wine(no errors) and then tried to run winecfg, but it was taking too long to start. Eventually it started and I stopped worrying about it. Then when I tried to run any program it took about 3 minutes just to open it. It was running ok(the program wasn't slow or any other problem), but took too long to open. After a lot of research I found this bug report http://bugs.winehq.org/show_bug.cgi?id=10358 that solved the problem. The fix is really simple, just run:
Code:
sudo sh /etc/rc.d/rc.cups start
and to make it permanent run:
Code:
chmod +x /etc/rc.d/rc.cups
This is more a workaround than a fix. In the same bug report there's a proper fix: recompile wine with --without-cups option.

That's it, hope that helps someone!
 
Old 10-05-2012, 04:16 AM   #2
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
Interesting. But I would guess that most users enable CUPS anyway.
 
Old 10-05-2012, 06:28 AM   #3
raphaeldavidf
Member
 
Registered: Sep 2012
Location: São Paulo, Brazil
Distribution: Slackware 14.0
Posts: 33

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by arubin View Post
Interesting. But I would guess that most users enable CUPS anyway.
xD if my printer hadn't broken last week i wouldn't need that either.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Possible Fix for the Slow WiFi Problem on Nexus S LXer Syndicated Linux News 0 08-31-2011 07:00 AM
LXer: A Windows-style Fix to a WINE Problem LXer Syndicated Linux News 0 06-12-2010 07:50 AM
FIX: wine error "No Program Start Menu Found" JackSmith Linux - Games 3 07-02-2009 10:38 PM
where do I start to fix the problem? mandrakemikael Linux - General 1 12-26-2004 02:31 PM


All times are GMT -5. The time now is 12:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration