LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-26-2008, 12:57 PM   #1
richikiki
Member
 
Registered: Mar 2005
Location: Montréal, Québec, Canada
Distribution: Slackware 12.1 x32, 13.1 x64
Posts: 90

Rep: Reputation: 15
Question how to dual boot windows linux (Slackware 12.1) with lilo


Hi community,

I'm wondering if you can give me some advice in how to boot from windows to my Slackware having into consideration the following constrains:

1) No MBR modification
2) Using windows boot manager

I got the following configuration:

Code:
Device    Boot  ID   Type
/dev/sda1    *   7   NTFS
/dev/sda2       82   Swap
/dev/sda3       83   Linux
I read that using Loadlin will not work.
My Slackware was install on partition three. I'm just missing the configuration to select from the windows boot manager between windows or Linux. Yes you will said get why windows. Well it is the company system but some data mining I prefer my Linux box.
 
Old 11-26-2008, 02:16 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,257

Rep: Reputation: Disabled
Information like that is abundant on the Internet. Here is just one of a million explanatory pages:

http://jaeger.morpheus.net/linux/ntldr.php

Eric
 
Old 11-27-2008, 01:16 AM   #3
richikiki
Member
 
Registered: Mar 2005
Location: Montréal, Québec, Canada
Distribution: Slackware 12.1 x32, 13.1 x64
Posts: 90

Original Poster
Rep: Reputation: 15
Unhappy

My good I just missed up my Disk

I was connecting another disk then I run

lilo -C lilo.conf -M /dev/sdb3 -b /dev/sdb3

Now non of my disk is working
Then I tried to restore boot record with dd if=boot.save of=/dev/sda

Now the table is a messed the system is telling me invalid table and none of the disk boot.

When starting with a linux boot I got:

Device boot Start End blocks Id System
/dev/sda1 ? 116388 126889 84344761 68 Unknow
Partition doesnt end on cylinder boundary.
...
...
..
..


Any help I got my files from the last 5 years on the disk.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware "freezes" (when BOOTING with LILO) ; Dual-Boot WinXP/Linux BlueSpirit Slackware 39 07-11-2006 06:18 PM
dual boot (xp pro and slackware 10.2) using lilo creeper_lin Slackware 4 06-06-2006 05:02 PM
Linux Slackware and Windows dual boot problem uro Linux - Newbie 7 04-08-2006 05:37 PM
i need help with a dual boot (windows and slackware linux) Tod_Con Slackware - Installation 1 06-13-2004 01:02 AM
Slackware dual boot, lilo troubles... lt1derful Linux - Newbie 2 07-01-2003 08:58 PM


All times are GMT -5. The time now is 06:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration