LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2009, 02:25 AM   #1
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Rep: Reputation: 15
How to disable xscreensaver while MPlayer is running?


Hello,

I installed "mplayer-svn_20081215" from the SlackBuilds dot org and noticed that xscreensaver was still active while watching video with MPlayer. I found an option for disabling screensaver using MPlayer's GUI, but it does not work. Then I tried to add "stop-xscreensaver=yes" line to "~/.mplayer/config" file. It did not work again. Do I have to use an option for disabling xscreensaver as default while compiling package?

Thanks.

Last edited by sertmusluman; 02-01-2009 at 06:05 AM.
 
Old 02-01-2009, 03:49 AM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
The config file should be "~/.mplayer/config". Pay attention to the dot.

$ cat .mplayer/config
# Write your default config options here!
stop-xscreensaver=1
ao=esd,arts,alsa,sdl

There are other ways to stop xscreensavers that do not support the proper X API. Use "man mplayer" and search for "xscreensaver".
 
Old 02-01-2009, 06:03 AM   #3
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
The config file should be "~/.mplayer/config". Pay attention to the dot.
Yes, thanks I edited

But adding following lines to "~/.mplayer/config" again yielded nothing.

Code:
stop-xscreensaver=1
ao=esd,arts,alsa,sdl
Screen saver still interrupts video stream.

I will look at man pages as you said. Thanks.
 
Old 02-01-2009, 06:35 AM   #4
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
If you use KDE, I remember reading somewhere that you need to use a different command in ~/.mplayer/config to pause the screensaver while mplayer is running. If I can find the info again I'll post it.
 
Old 02-01-2009, 06:50 AM   #5
sertmusluman
Member
 
Registered: Jan 2006
Location: Canakkale, Turkiye
Distribution: Slackware 12.2
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by digger95 View Post
If you use KDE, I remember reading somewhere that you need to use a different command in ~/.mplayer/config to pause the screensaver while mplayer is running. If I can find the info again I'll post it.
I use XFCE. Thank you very much digger95.
I have an old MPlayer precompiled package from "linuxpackages.net". I reinstalled it again, it stops screensaver while running, but it does not allow SMPLAYER to use new properties that is why I want to upgrade MPlayer to latest version.
 
Old 02-01-2009, 07:12 AM   #6
bergman
Member
 
Registered: Jan 2009
Distribution: slackware 12.1 (kernel 2.6.24.5-smp)
Posts: 39

Rep: Reputation: 17
Im having a similar problem, with my screen going black after 10 minutes of keyboard/mouse inactivity. Its a real pain when watching TV in my browser (although mplayer is fine with no black screens for the duration of the TV program/movie).

It doesnt appear to be an 'xscreensaver' problem, because I have uninstalled it, and the same thing happens.

Last edited by bergman; 02-01-2009 at 07:18 AM.
 
Old 02-01-2009, 08:18 AM   #7
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 64
Have a look in /etc/rc.d/rc.M (line #25)
Code:
/bin/setterm -blank 15 -powersave powerdown -powerdown 60
Or putting this in /etc/X11/xorg.conf (and restarting X):
Code:
Section "ServerFlags"
	Option "StandbyTime" "0"
	Option "BlankTime" "0"
	Option "OffTime" "0"
	Option "SuspendTime" "0"
EndSection
will stop all the display power management while X is running.
 
Old 02-01-2009, 08:25 AM   #8
bergman
Member
 
Registered: Jan 2009
Distribution: slackware 12.1 (kernel 2.6.24.5-smp)
Posts: 39

Rep: Reputation: 17
thanks wadsworth
 
Old 02-01-2009, 02:58 PM   #9
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
Thanks for the info, Wadsworth. Will commenting out the line in /etc/rc.d/rc.M prevent the screen from blanking out at the console also? I've always wondered how that even happens since technically X isn't running at console, right?
 
Old 02-01-2009, 03:11 PM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,937

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
You can use xset to disable screen blanking while in X:
Code:
xset -dpms
xset s off
 
Old 02-01-2009, 03:38 PM   #11
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
The screen blanking is the monitor's dpms "Energy Star" suspend function. Another way to disable it temporarily is to run "xset -dpms". You can then re-enable it with "xset +dpms".

According to Wikipedia, dpms is built into the monitor and controlled through the video card. I don't imagine the xorg settings would work in console mode, but using xset might work, unless it also requires a running x-server (I'm not going to shut down my x to test it ). However, you can also use vbetool to change the settings when X isn't running.
 
Old 02-01-2009, 04:56 PM   #12
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
Thanks very much David. I'm fairly new to Linux so a lot of times when I am at console trying to figure out what the heck I am doing (which is more often than not) my monitor blanks out, and it never did that under windows. I will try your suggestions.
 
Old 02-01-2009, 04:59 PM   #13
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
P.S. Sorry to threadjack the OP's original post. Let's get back to how to disable xscreensaver while mplayer is running. That will be of benefit to a lot of people I think, and I've read that it is a fairly common problem.
 
Old 02-01-2009, 08:24 PM   #14
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 64
You can disable the KDE screensaver with
Code:
dcop kdesktop KScreensaverIface enable false
or enable it with
Code:
dcop kdesktop KScreensaverIface enable true
Maybe execute those commands with desktop icons?

Odd that Mplayer can't cope with KDE's screensaver.
 
Old 04-28-2010, 03:55 PM   #15
Thursapr
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 44

Rep: Reputation: 18
Though the thread's rather old, hope this will be useful for someone.

The problem can be solved by adding this to ~/.mplayer/config
Quote:
heartbeat-cmd="xscreensaver-command -deactivate"
(from mplayer man page)
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xscreensaver not running on Zenwalk 4.8 in Fluxbox as root. andy90 Linux - Newbie 19 12-24-2007 01:14 PM
Xscreensaver daemon not running in an X-Windows session swampdog2002 Slackware 1 08-17-2006 03:01 PM
mplayer cannot stop xscreensaver lnthai2002 Linux - Software 1 08-01-2006 09:31 PM
Running Xscreensaver at Startup burningsun1981 DamnSmallLinux 1 07-04-2005 01:04 AM
running xscreensaver on bochs zaman Linux - Software 0 10-15-2003 08:58 PM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration